farhad6169

عضو سایت
  • تعداد ارسال ها

    37
  • تاریخ عضویت

  • آخرین بازدید

اعتبار در انجمن

1

درباره farhad6169

  • درجه
    تازه کار

آخرین بازدید کنندگان نمایه

323 بازدید کننده نمایه
  1. تشکر از شما من وارد این بخش شدم و یک دکمه بود تحت عنوان " ارائه مجوز دسترسی " که جلوش باید نام محصول رو تایپ میکردم. نام محصول رو تایپ کردم و محصول رو نمایش داد و مجوز دسترسی رو زدم. 2 تا مشکل: 1- فایل قبلی مجدد به این لیست add شد یعنی به کاربر 2 بار لینک دانلود فایل اول رو نمایش میده که باید یکی ش رو دستی حذف کرد. 2- فرض کنید مثلا من 200 یا 500 یا بیشتر، مشتری دارم. باید برای هرکدومشون این کارو انجام بدم؟! ممنون میشم راهنمایی بفرمائید. با تشکر
  2. سلام به همه من ووکامرس 3 رو نصب کردم و یک محصول ساختم. فرض کنید که یک قالب گذاشتم برای فروش، یک کاربر قالب رو خرید میکنه و استفاده میکنه. حالا یک فایل زبان رو میخام به این محصول اضافه کنم، طوری که به پروفایل کاربرانی که خرید کردند هم اضافه بشه. یعنی کسی که قالب رو خریده حالا در قسمت دانلودها فایل زبان رو هم ببینه و بتونه دانلود کنه. مشکل اینجاست که بعد از اضافه کردن فایل زبان (فایل دوم و فایلهای بعدی) ، این فایل به پروفایل کاربر اضافه نمیشه ! ظاهرا این مشکل در ووکامرس 3 بوجود اومده. لطفا راهنمایی بفرمائید. با تشکر فراوان
  3. با تشکر از شما دوستان نظر دیگری ندارند؟ یا پیشنهاد دیگری برای انجام این کار؟
  4. سلام خدمت همه دوستان تو ووکامرس کاربری که چیزی خریده باشه، مثلا یک فایل خریده باشه وقتی وارد حساب کاربری خودش میشه یکسری گزینه ها هست مثل " دانلود " و " مشخصات عمومی " و امثال اینها که بصورت تب در کنار هم یا زیر هم قرار میگیرند. نیاز دارم که مشابه تصویر ارسال شده یک تب به این تب ها اضافه بشه و کارش هم پشتیبانی و ارسال تیکت توسط کاربری که محصول رو خریده ، باشه. آیا پلاگینی برای این کار میشناسید؟ با تشکر
  5. این کارو کردم و به این شکل شد
  6. با سلام. وقتی که محصولی دارم و قیمتش صفر هست ، معمولا نباید قیمت صفر رو نمایش بده اما نمی دونم چرا داره نمایش میده. لطفا راهنمایی بفرمائید که چطور میشود این قیمت صفر را حذف کرد. با تشکر
  7. سلام چه کردی اون سایت عکس رو راه انداختی ؟؟؟؟من دیگیرشم

    1. farhad6169

      farhad6169

      کدوم سایت عکس؟

       

  8. با سلام خدمت همه دوستان دوست عزیزی که پشت هم تاپیکهای منو بلوک میکنید (مهدی)، تا جایی که من میدونم انجمنها برای این ایجاد میشن که سطح علمی همه دوستانی که ثبت نام میکنن رو ببره بالا. چه مدیران و چه کاربران از این قضیه مستثنا نیستند و همه برای ارتقاع سطح علمی همدیگه به هم کمک میکنیم. قبلا من با جوملا کار میکردم (حدود 2سال پیش) و بنا به دلایلی دیگه کار نکردم و با وردپرس کار رو شروع کردم. در انجمنهای جوملا که الان هم عضو هستم وقتی به مشکلی میخوردم همه دوستان کمک میکردند و دیگه بحث این نبود که چون افزونه ی شما اورجیناله باید از فروشنده خدمات بگیری! همین الان مشکلی که در تاپیک قبلی من بسته شد رو تا حدودی دوستان جوملا کار کمکم کردند تا حل شد. سازنده میگه ما کالا از RTL ساپورت نمیکنیم و هیچ پاسخی در این زمینه نمیدیم. این پاسخشونه! ---------------- I suppose that your want to make your site in RTL mode, right? Please keep in mind that our theme has no RTL support because it has been designed to be used in this layout, sorry! Unfortunately, we have no plan on implementing it in the near future. Implementing RTL support in our theme will require 2 style.css files and it will add significant “weight” to the theme. Using the RTL mode means that lots of elements have to be adjusted and this thing involves custom work and we cannot provide this at the moment! Please try to do a simple search of our forum and you will see that our team offers support only for theme related problems and which not require additional customizations. --------------- حالا من به انجمن وردپرس نیام کجا باید برم!! شما یه راهی به من بگید تا بتونم ازش نتیجه بگیرم، حتما انجام میدم. من مشکل فعلی م رو مطرح میکنم اگر بازم باید بلوک بشه که دیگه فکر کنم جایی که انتخاب کردم برای مطرح کردن مشکلاتم اشتباه بوده و باید به فکر جای دیگری باشم. درحال حاضر مشکلی که هست اینه: خودم کدهاش رو یه بلایی سرش آودم و از نو همه رو راست چین کردم. آدرس سایت : http://negarsima.com/demo/evportal4/ اما مشکل الان اینجاست که وقتی راست چین میشه و کدهای css رو قرار میدم که راست چین بشه صفحه بندی منوها و محتوا دیگه درست کار نمیکنه. داخل منو 5 تا عکس نشون میده که پایین شون 2تا فلش هست که مثلا 5تای بعدی رو بیاره اما وقتی میزنی 10تاش رو لود میکنه!! یه به ته ش که میرسه بجای اینکه هیچی لود نکنه کلا 5تا عکس هم نشون نمیده ! تو سایت انگلیسی درسته اما اینجا اینطوریه. سایت دمو: https://demo.tagdiv.com/newspaper/ درضمن وقتی که وردپرس رو انگلیسی میکنم این هم درست میشه! اگر ممکنه این مورد رو راهنمایی بفرمائید. با تشکر
  9. با سلام خدمت همه دوستان قالب newspaper 7 رو نصب کردم و دموی پیش فرضش رو هم نصب کردم بعد که اومد بالا دیدم که اسکرول پایین داره و در سمت چپ یه موقعیت هایی وجود داره که سایت رو بهم داره میریزه. زبان سایت رو انگلیسی کردم و این مشکل درست شد اما در حالت زبان فارسی این مشکل هست. در فایلهای قالب هم فایل rtl.css وجود نداره. اینم آدرس سایت: http://negarsima.com/demo/evportal2/ در صورت ممکن راهنمایی بفرمائید که چطوری باید این مشکل رو حل کنم. با تشکر
  10. در این سایت پاسخش رو پیدا کردم https://contactform7.com/2015/03/28/custom-validation/ کدها رو در functions.php قرار دادم و به شکلی که گفته فرم رو ساختم. و حل شد. add_filter( 'wpcf7_validate_email*', 'custom_email_confirmation_validation_filter', 20, 2 ); function custom_email_confirmation_validation_filter( $result, $tag ) { $tag = new WPCF7_FormTag( $tag ); if ( 'your-email-confirm' == $tag->name ) { $your_email = isset( $_POST['your-email'] ) ? trim( $_POST['your-email'] ) : ''; $your_email_confirm = isset( $_POST['your-email-confirm'] ) ? trim( $_POST['your-email-confirm'] ) : ''; if ( $your_email != $your_email_confirm ) { $result->invalidate( $tag, "Are you sure this is the correct address?" ); } } return $result; } و استفاده به این شکل Email: [email* your-email] Confirm email: [email* your-email-confirm] و اون افزونه ای که کار نمی کرد و هم پاک کردم
  11. با سلام خدمت همه با cantact form 7 یک فرمی درست کردم و نیازه که در آن کاربر ایمیل خودش رو وارد کنه بعد در باکس بعدی تکرار ایمیل رو باید بنویسه. همه میدونیم که ایمیل نوشته شده در این 2تا باکس باید کاملا مشابه هم باشه. مشکلی که هست اینه که اگر کاربر در باکس دوم دقیقا ایمیلی که در باکس اول نوشته رو وارد نکنه contact form 7 اجازه رد شدن بهش میده و ایراد نمیگیره. برای این مشکل سرچ کردم و به این افزونه رسیدم: https://wordpress.org/plugins/contact-form-7-confirm-email-feild/ و نصب کردم و یک آپشن به قسمت بالای افزونه طبق عکس ارسالی اضافه شد بنام confirm email. طبق عکس ارسالی به این شکل کدهای مورد نیازم رو درست کردم. مانند کد زیر: [email* user-email placeholder "your email"] [confirm_email* user-email placeholder "confirm_email"] اما بازم وقتی ایمیل ها رو مشابه وارد نمیکنم هیچ پیامی مبنی بر اشتباه بودن 2تا فیلد رو اعلام نمیکنه! به نظر شما باید چه کار دیگری انجام بدهم. با تشکر
  12. تشکر از دوستانی که پاسخ دادند. دوستان دیگر پاسخی اگر دارند منتظر شنیدن هستم. با تشکر
  13. تشکر از پاسخ شما. اما واقعا فکر نمیکنید که خلاف قوانین بودن این موضوع کمی غیر منطقی است!! در امنیت به مشکل خوردم حالا چون با قالب پریمیوم کار میکنم کسی نباید پاسخی بده؟!! واقعا دلیل این امر چیه؟
  14. اینم چند تا عکس از فایلها و پوشه ها
  15. با سلام خدمت همه دوستان و مدیران انجمن یک سایت طراحی کردم و بعد از گذشت 3 روز با باز شدن سایت یک صفحه سفید باز میشه و گوشه بالا سمت چپ بصورت خیلی کوچک مینویسه 404. نام سایت : iranyaskawa.com چند بار این اتفاق افتاد و من از اول سایت رو زدم و باز این مشکل پیش اومد. کل کاری که میکنم اینه: 1- دانلود وردپرس از سایت اصلی وردپرس که الان فکر کنم ورژنش 4.7.2 هستش. که الان با همین ورژن سایت رو بالا آوردم. 2- استفاده از آخرین نسخه قالب آوادا که اورجینال دارمش و سریالش رو هم وارد میکنم تا رجیستر بشه. دمو رو نصب کردم و اضافه ها رو پاک کردم و شروع به کار کردم. افزونه ی دیگری هم نصب نیست به هیچ وجه. نه اسلایدر و نه چیز دیگه. چند بار روی همین دامنه سایت رو بالا آوردم و باز مشکل دار شد. اینبار روی یه ساب دامنه ی یکی از دامنه های شخصی خودم طراحی کردم و تمام شد و منتقل کردم روی این دامنه. هاست هاشون متفاوت هستش. 3 روز پیش منتقل کرده بودم که مجدد به این شکل شد. طرز انتقال بخاطر اینکه خیال راحت باشه به این شکل عمل شده: هاست سایت رو به هاستینگ گفتم که صفر کردند، بعد وردپرس 4.7.2 رو نصب کردم و قالب آوادا رو نصب کردم. بعد تنظیمات قالب رو از هاست شخصی کپی کردم و وارد قالب سایت کردم. از درون ریزی و برون بری برای انتقال برگه ها استفاده کردم و منوها رو هم دستی مجدد ساختم. یعنی هیچ فایلی منتقل نکردم. کل محتوای سایت هم برگه ست ، نه پستی داره و نه اسلایدری و نه هیچ چیز دیگری. درضمن وقتی به این مشکل میخوره، theme option قالب آوادا هیچ تنظیماتی رو نشون نمیده و برگه سازش هم دیگه کار نمیکنه. یک مورد دیگه اینکه وقتی لینک یکی از مطالب رو تغییر میدم صفحه ش باز میشه!! این رو بصورت اتفاقی متوجه شدم. وقتی که اشتباهی یه لینکی رو وارد کردم و دیدم که استایل سایت بارگذاری شد و صفحه 404 قالب نشون داده شد. امروز که دیدم باز صفحه 404 غیر معمول میاد، رفتم تو هاست و یه سیستم چک ویروس داشت که زدم چک کرد. دیدم که میگه فایل php.404 قالب مشکل داره و دارای مالور است و همچنین یه پوشه قالب جدید به قالب های سایت اضافه شده که گزارش داده بود header.phpش مشکل داره!!! وارد فایل php.404 شدم که دیدم یکسری نوشته ی کد شده داخلش هست. درون فایلهای قالب آوادا فایلها رو بر اساس تاریخ آخرین تغییرات سورت کردم دیدم که 4تا فایل هست که همین امروز یا دیروز ادیت شدند: 1- 100-width.php 2- 404.php 3- wp-search.php 4- cache.php روی فایل شماره 1 ادیت رو زدم دیدم داخلش نوشته " 404 " . یعنی موقع لود صفحات سایت درواقع این فایل داره لود میشه!!! فایل دومی هم که همش کد بود. فایلهای 3 و 4 هم کدهای php بودند. فایل شماره 1 رو rename کردم و دیدم که سایت به راحتی باز شد و مشکل باز شدن صفحات از بین رفت و صفحه سفید 404 دیگه نماید. یه لینکی که وجود نداشت رو زدم که صفحه 404 خودم بیاد ، که دیدم یه صفحه باز شد و پسورد میخاد و صفحه 404 خودم بالا نمیاد!! فایل 2 رو هم rename کردم و این بخش هم درست باز شد!! اما وقتی وارد theme option قالب آوادا میشم باز هیچ آپشنی نمایش داده نمیشه و برگه سازش هم دیگه کار نمیکنه!! به نظر شما چیکار باید بکنم که به این مشکل دیگه بر نخورم. لطفا راهنمایی بفرمائید با تشکر