alireza.nh

auto thumbnail مشکل با

6 پست در این موضوع قرار دارد

با سلام :)

همون طور که در انجمن آموزش داده شد بنده از فانکشن زیر برای نمایش خودکار تصویر شاخص استفاده کردم.



function aldenta_get_post_image($size = 'thumbnail') {
global $post;
$photos = get_children( array('post_parent' => $post->ID, 'post_status' => 'inherit', 'post_type' => 'attachment', 'post_mime_type' => 'image', 'order' => 'ASC', 'orderby' => 'menu_order ID') );
if ($photos) {
$photo = array_shift($photos);
return wp_get_attachment_image($photo->ID, $size);
}
else{
return '<img src="'.get_bloginfo('template_url').'/images/default.jpg" border="0" />';
}
return false;
}

ولی متاسفانه با این که پست دارای عکس میباشد ، تصویر شاخصی یافت نمیشود و عکسی که برای تمامی پستهای بدون عکس گذاشتم نمایش داده میشه یعنی این بخش:

return '<img src="'.get_bloginfo('template_url').'/images/default.jpg" border="0" />';

.

به اشتراک گذاری این پست


لینک به پست

اینها رو تست کنید:

function catch_that_image() {
global $post, $posts;
$first_img = '';
ob_start();
ob_end_clean();
$output = preg_match_all('/<img.+src=[\'"]([^\'"]+)[\'"].*>/i', $post->post_content, $matches);
$first_img = $matches[1][0];

if(empty($first_img)) {
$first_img = "/path/to/default.png";
}
return $first_img;
}

استفاده:


if ( get_the_post_thumbnail($post_id) != '' ) {

echo '<a href="'; the_permalink(); echo '" class="thumbnail-wrapper">';
the_post_thumbnail();
echo '</a>';

} else {

echo '<a href="'; the_permalink(); echo '" class="thumbnail-wrapper">';
echo '<img src="';
echo catch_that_image();
echo '" alt="" />';
echo '</a>';

}

به اشتراک گذاری این پست


لینک به پست

ممنون آقا مرتضی.

این رو هم قبلا امتحان کرده بودم ، نتیجه ای نداره! :huh:

و تصویر شاخص همه پست ها png.default هست :wacko: .

به اشتراک گذاری این پست


لینک به پست

+فرقی نداره که پست تصویر داشته باشه یا نه! <_<

کلا default.png رو نمایش میده! :(

به اشتراک گذاری این پست


لینک به پست

این کد دیگه باید کار کنه! چون در حال استفاده هست:

    function get_first_image($thumb='', $num='0')
{
global $post, $posts;
$first_img = '';
ob_start();
ob_end_clean();
$output = preg_match_all('/<img.+src=[\'"]([^\'"]+)[\'"].*>/i', $post->post_content, $matches);
$first_img = $matches [1][$num];
if(empty($first_img))
{ //Defines a default image
$tID = $post->ID;
$names = substr($tID, -1);

if($thumb == 'large'){
$size="large";
}elseif($thumb == 'large-2'){
$size="large-2";
}
$first_img = get_bloginfo('template_url') . "/images/$size/$names.png";
}
return $first_img;
}

به اشتراک گذاری این پست


لینک به پست

ممنون.

حل شد بالاخره :wub:;) ;) :)

ویرایش شده در توسط alireza.nh

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط oonchiye
      سلام
      تنظیمات مربوط به افزونه رو انجام دادم برگه ها موجود هستش 
      شرت کد های مربوط هم درسته 
      فقط وقتی دکه پرداخت رو میزنی صفحه تسویه حساب فقز اسم برگه رو میاره 
      مینویسه check uot فقط
      چیکار کنم خیلی لازم دارم 
    • توسط behi13
      با سلام
      دوستام و اساتید محترم یک سوال
      من به سایت دوزبانه با افزونه wpml درست کردم الان یک مشکل هست توی گوگل صفحه اول سایت ایندکس شده و توی فارسی مشکلی ندارم
      ولی توی زبان انگلیسی وقتی توی گوگل به انگلیسی سرچ میکنم بازهم با نام و فارسی میاد
      ممنون میشم من و راهنمایی کنید
    • توسط j1989m
      سلام
      توی قسمت افزودن نوشته و از طریق پرونده های رسانه ای یه عکس انتخاب میکنم و منتشر میکنم. توی سایت عکس رو نشون میده اما این کدها رو هم میاره:
      [caption id="attachment_154" align="aligncenter" width="300"] [/caption]
      درواقع عکس بین دوتا caption بالا قرار میگیره.
      این مشکل توی افزودن برگه نیست.
      لطفا راهنمایی کنید
      خیلی فوریه
      ممنون
    • توسط xboby
      سلام،
      من سایتی با ورد پرس طراحی کردم و می خواهم با:
      یک برنامه تمام پستهای موجود در کانال تلگرامی که بنام آن سایت ایجاد کر ده ام را
      بتوانم از موبایلم دانلود کنم و بعد در آن سایت قرار دهم:
      آیا چنان برنامه ای وجود دارد؟ لطفا راهنمائی ام بفرمائید.
                                   متشکرم
    • توسط دکتر مهندس
      سلام
      من چندتا سایت دارم که همه رو وقتی خواستم به وردپرس 4.7 ارتقا بدم، همگی مشکل دار شدند.
      به این صورت که خود سایت باز میشه اما قسمت مدیریت سایت باز نمیشه و لینکهای بخش مدیریت به این صورت میاد: /wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F
       
      توی صفحه هم که میاد اینطوری مینویسه: 
       
      The www......ir page isn’t working
      www.......ir is currently unable to handle this request.
      HTTP ERROR 500