SeveniA

مشکل عکس ها بعد از آپگرید

17 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام و خسته نباشید به همگی دوستان

چندروز پیش به یک مشکلی عجیب برخوردم

بعد از این که وردپرسمو به 3.3.4 آپگرید کردم بعد از 2-3روز متوجه شدم که بعضی از عکس هایی که آپلود کرده بودم

به مشکل خوردند

این عکسو بهتون برای مثال نشون میدم

l7794i0s4s9542vijuw.jpg

حالا لینک این عکس ها شده این :

http://patoghestan.i...tal/default.png

جالبی دیگه هم که داره تصویر شاخص این ها کاملا حذف شده . عکس زیر را ببینید

xiwhxc4imzelqiyvzx6.jpg

همانطور که مشاهده میکنید به کلی حذف شده

و حتی اون عکسی که در تصویر 1 نشان دادم هم نبود

خیلی جست و جو کردم چیزی پیدا نکردم

خودمم خیلی باهاش کلنجار رفتم اما .....

من فعلا همین به چشمم خورده و ممکنه مشکل دیگه ای هم باشه

درضمن بک آپ هم نمیتونم ریستور کنم

چون خیلی پست جدید گذاشتم و بخوام بک آپ ریستور کنم خیلی بد میشه

اینم آدرس سایت میتوانید بخش فال روزانه مشاهده کنید :

http://patoghestan.ir

پیشاپیش ممنون از کمکتون

ویرایش شده در توسط Faramarzhidden
0

به اشتراک گذاری این پست


لینک به پست

سلام

اون عکسها آدرسشون توی بخش رسانه در دسترس هست؟

چک کردید که ببینید توی پوشه شون هستن یا خیر؟

0

به اشتراک گذاری این پست


لینک به پست

سلام

مشکل اینه که اصلا نمیدونم اسمشون چیه!

میرم اسمشون رو ببینم میره به اون لینک

اما باید باشه

چون من چیزی حذف نکردم

درضمن اگر نباشه باید not found بزنه ، نه اینکه عکس جایگزین بیاره

جالبه برام

0

به اشتراک گذاری این پست


لینک به پست

احتمال از افزونه ها همه را غیر فعال کنید و دوباره فعال اگه افزونه نباشه احتمالا سطح دسترسی است funection خود را نیز چک کنید.

0

به اشتراک گذاری این پست


لینک به پست

افزونه ها غیر فعال شد و دسترسی functions رو هم چک کردم ، روی 644 بود

اما هیچ تغییری نکرد

فکر نکنم درست شدنی باشه.

درسته ؟

من از افزونه Watermark My Image استفاده میکنم . ممکنه از این باشه و این افزونه عکس هارو خراب کرده باشه ؟

ولی موقعی که میخوام پست بذارم مشکلی نداره

اینم جالبه که اینطوری شده

درضمن اینم بگم که من افزونه blue admin رو هم نصب و فعال کرده بودم

و فکر کردم از اون باشه که الان غیر فعال کردم

0

به اشتراک گذاری این پست


لینک به پست

100% واترمارک هست افزونه را غیرفعال کنید و از واترمارکهای css یا php استفاده کنید

1

به اشتراک گذاری این پست


لینک به پست

منم همین مشکل رو دارم و مجبور به حذف و آپلود مجدد عکس ها شدم.

0

به اشتراک گذاری این پست


لینک به پست

افزونه blue-admin که بیشتر تغییر رو پوسته مدیریت داره.

ممکن هست از واترمارک باشه ولی درصدش کم هست.

الان مشکلتون به کجا رسید؟

1

به اشتراک گذاری این پست


لینک به پست

الان مشکلتون به کجا رسید؟

هیچ جا .

100% واترمارک هست افزونه را غیرفعال کنید و از واترمارکهای css یا php استفاده کنید

میشه شما یک واترمارک خوب به من معرفی کنید

آخه من این واترمارک رو حدوده 1-2ماهه دارمش و مشکلی نداشته

اما اگه شما میگید از اونه حتما هست

اگه میشه یک واترمارک خوب معرفی کنید

ممنون

0

به اشتراک گذاری این پست


لینک به پست

هیچ جا .

میشه شما یک واترمارک خوب به من معرفی کنید

آخه من این واترمارک رو حدوده 1-2ماهه دارمش و مشکلی نداشته

اما اگه شما میگید از اونه حتما هست

اگه میشه یک واترمارک خوب معرفی کنید

ممنون

اینی که قبلا توی سایتم استفاده میکردم واتر مارک php بود تو سایت barnamenevis.org یک تاپیک هست درباره همین موضوع واترمارک را توی برنامه نویس سرچ کنی کدش میاد!

0

به اشتراک گذاری این پست


لینک به پست

الان همچنان مشکل حذف عکس دارید؟ اگر دارید افزونه واترمارک رو برای مدت محدود غیرفعال کن. ببین مشکل ادامه پیدا میکنه؟

اگر نه فعلا باهاش ادامه کار بدید مشکل خیلی خاصی پیش نمیاد.

1

به اشتراک گذاری این پست


لینک به پست

سلام

من اینو پیدا کردم



<?php
$src = $_GET['src'];
header('Content-type: image/jpeg');
if (eregi("150x150", $src)) {
$watermark = imagecreatefrompng('empty.png');
} else {
$watermark = imagecreatefrompng('watermark.png');
}
$watermark_width = imagesx($watermark);
$watermark_height = imagesy($watermark);
$image = imagecreatetruecolor($watermark_width, $watermark_height);
if(eregi('.gif',$src)) {
$image = imagecreatefromgif($src);
}
elseif(eregi('.jpeg',$src)||eregi('.jpg',$src)) {
$image = imagecreatefromjpeg($src);
}
elseif(eregi('.png',$src)) {
$image = imagecreatefrompng($src);
}
else {
exit("Your image is not a gif, jpeg or png image. Sorry.");
}
$size = getimagesize($src);
$dest_x = $size[0] - $watermark_width - 0;
$dest_y = $size[1] - $watermark_height - 0;
imagecolortransparent($watermark,imagecolorat($wat ermark,0,0));
imagecopyresampled($image, $watermark, $dest_x, $dest_y, 0, 0, $watermark_width, $watermark_height, $watermark_width, $watermark_height);
imagejpeg($image, "", 95);
imagedestroy($image);
imagedestroy($watermark);
?>

خوب حالا اینو کجا بذارم ؟

0

به اشتراک گذاری این پست


لینک به پست

الان همچنان مشکل حذف عکس دارید؟ اگر دارید افزونه واترمارک رو برای مدت محدود غیرفعال کن. ببین مشکل ادامه پیدا میکنه؟

اگر نه فعلا باهاش ادامه کار بدید مشکل خیلی خاصی پیش نمیاد.

مشکل اینجاست که من که نمیفهمم اگر عکسی هم حذف بشه و نمیتونم که برم تمام پست هامو چک کنم

این پست رو فهمیدم چون هر روز آپدیت میشه

ولی شنیده بودم که واترمارک مشکل به وجود میاره

واسه این php اگه کمک کنید ممنون میشم

0

به اشتراک گذاری این پست


لینک به پست

کد یا افزونه فقط شاید در تعداد خط ها تفاوت داشته باشن و عملا هر دو دارن یک کار انجام میدن.

کدی هم که پیدا کردید باید تغییر کنه تا در وردپرس بشه استفاده کرد.

این افزونه و این توضیحاتش رو بررسی کنید.

1

به اشتراک گذاری این پست


لینک به پست

به نظر من مشکل از افزونه watermark باشه !!! چون منم این مشکلو از وقتی که این افزونه رو نصب کردم پیدا کردم

1

به اشتراک گذاری این پست


لینک به پست

من این افزونه که شما معرفی کردید قبلا داشتم

پس اینو نصب کنم مشکلی پیش نمیاد ؟

0

به اشتراک گذاری این پست


لینک به پست

هیچوقت نمیشه افزونه ایی رو 100% تایید کرد.

ممکن هست با یک تغییر نسخه همه چیز بهم بریزه....

ولی تا الان بهترین چیز یکه دیدم بود.

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری