masood1111

تصویر شاخص دیفالت

11 پست در این موضوع قرار دارد

عرض ادب

قالبی هست که کاربر مطلب ارسال میکنه، گزینه آپلودی هست که کاربر می تونه تصویری را برای تصویر شاخص مطلبش انتخاب کنه. این تصویر تحت عنوان $image1 در قالب شناخته میشه. به این صورت در فایل ها فراخوانی میشه:


<img src="<?php echo $image1; ?>"
border="0"
alt="<?php echo the_title(); ?>"
title="<?php echo the_title(); ?>"
height="80"
width="80"

چه کنم وقتی کاربر فیلد آپلود را خالی گذاشت یه عکس دیفالت قرار داده بشه؟

اینم گذاشتم که ارور میده نمیدونم کجاش اشتباه شده:


<?php if ((empty($image1)) {
<img src="<?php bloginfo('template_directory'); ?>/images/s-nopic.png" alt="<?php the_title(); ?>" />
} else { ?>
<img src="<?php echo $image1; ?>;
<?php } ?>

0

به اشتراک گذاری این پست


لینک به پست

تست کنید:

<?php if ((empty($image1)) { ?>
<img src="<?php bloginfo('template_directory'); ?>/images/s-nopic.png" alt="<?php the_title(); ?>" />
<?php } else { ?>
<img src="<?php echo $image1; ?>;
<?php } ?>

4

به اشتراک گذاری این پست


لینک به پست

ضمن تشکر، متاسفانه عمل نکرد.

همه جوره این کد را تغییر دادم فایده نداره. روش دیگه ای نیست دوستان؟

0

به اشتراک گذاری این پست


لینک به پست

تست کنید:

<?php if (has_post_thumbnail()) { ?>
<img src="<?php echo $image1; ?>;
<?php } else { ?>
<img src="<?php bloginfo('template_directory'); ?>/images/s-nopic.png" alt="<?php the_title(); ?>" />
<?php } ?>

3

به اشتراک گذاری این پست


لینک به پست

ممنون. تشکر آقا مرتضی. این مورد که شما عنایت فرمودید درست عمل می کنه منتها مشکل اینه همه تصاویر شاخص را میذاره همون No-pic حتی اونایی که کاربر براشون تصویر شاخص گذاشته.

اینو که دیدم رفتم دوباره چک کردم متوجه شدم تصویر شاخصی درکار نیست درواقع و این تصاویر از زمینه دلخواه لود می شند. بنابراین عنوان تاپیکم دیگه در مورد سوالم صدق نمی کنه.

الان چطور می تونه یه تصویر پیشفرضی برای زمینه دلخواه image1 تعیین کنم؟

قسمت مربوطه فایل index.php


<ul class='features-index-premium-file'>
<?php $post_per_page = get_option('wpf_homepage_numberofpost');
query_posts( "post_type=market-item&posts_per_page=".$post_per_page );
if(have_posts()) :
while ( have_posts() ) : the_post();
$image1= get_post_meta( $post->ID, 'WpF_Image1', true );
$image2= get_post_meta( $post->ID, 'WpF_Image2', true );
$terms_as_text = strip_tags( get_the_term_list( $wp_query->post->ID, 'item-cat', '', ' / ', '' ) );
//$image1= get_post_meta( $post->ID, 'Image1', true );?>
<li class="index-page-thumbnail">
<a href="<?php the_permalink(); ?>">
<img src="<?php echo $image1; ?>"
border="0"
alt="<?php echo the_title(); ?>"
title="<?php echo the_title(); ?>"
height="80"
width="80"
class="thumbnail-image-popup home-page-no-preview"
image-preview-width=""
image-preview-height=""
data-item-name="<?php the_title(); ?>"
data-item-author="<?php the_author(); ?>"
data-item-category="<?php echo __('Category : ','WpF'); ?><?php echo $terms_as_text; ?>"
data-item-cost="<?php echo wpf_currency_simb(); ?></sup><?php echo get_post_meta( $post->ID, 'WpF_price', true ); ?>"
popup-large="<?php echo $image2; ?>" />
</a></li>

<?php endwhile; endif;
wp_reset_query();
?>
</ul>

0

به اشتراک گذاری این پست


لینک به پست

همون کد محمد درست هست

که باید در تگ a کد شما قرار بگیره

2

به اشتراک گذاری این پست


لینک به پست

همون کد محمد درست هست

که باید در تگ a کد شما قرار بگیره

عرض کردم متاسفانه ارور میده. syntax error

هر چی بالا پایینش هم کردم فایده نداشت.

0

به اشتراک گذاری این پست


لینک به پست

متن خطا رو بزارید

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)


Parse error: syntax error, unexpected '{' in C:\xampp\htdocs\wp-content\themes\WP-F\index.php on line 71

ویرایش شده در توسط Ehsan1111
0

به اشتراک گذاری این پست


لینک به پست

<?php if (empty($image1)) { ?>
<img src="<?php bloginfo('template_directory'); ?>/images/s-nopic.png" alt="<?php the_title(); ?>" />
<?php } else { ?>
<img src="<?php echo $image1; ?>" >
<?php } ?>

3

به اشتراک گذاری این پست


لینک به پست

ممنون دوستان. با این کدها حل شد. میزارم شاید یه روزی یه جایی یه وقتی بدرد کسی خورد.


<?php if (get_post_meta( $post->ID, 'Wp-F_Image1', true )): ?>
<a href="<?php the_permalink(); ?>">
<img src="<?php echo $image1; ?>"
border="0"
alt="<?php echo the_title(); ?>"
title="<?php echo the_title(); ?>"
height="80"
width="80"
class="thumbnail-image-popup home-page-no-preview"
image-preview-width=""
image-preview-height=""
data-item-name="<?php the_title(); ?>"
data-item-author="<?php the_author(); ?>"
data-item-category="<?php echo __('Category : ','Wp-F'); ?><?php echo $terms_as_text; ?>"
data-item-cost="<?php echo Wp-F_currency_simb(); ?></sup><?php echo get_post_meta( $post->ID, 'Wp-F_price', true ); ?>"
popup-large="<?php echo $image2; ?>" />
</a>
<?php else: ?>
<a href="<?php the_permalink(); ?>">
<img src="<?php bloginfo('template_url'); ?>/images/s-nopic.png"
border="0"
alt="<?php echo the_title(); ?>"
title="<?php echo the_title(); ?>"
height="80"
width="80"
class="thumbnail-image-popup home-page-no-preview"
image-preview-width=""
image-preview-height=""
data-item-name="<?php the_title(); ?>"
data-item-author="<?php the_author(); ?>"
data-item-category="<?php echo __('Category : ','Wp-F'); ?><?php echo $terms_as_text; ?>"
data-item-cost="<?php echo Wp-F_currency_simb(); ?></sup><?php echo get_post_meta( $post->ID, 'Wp-F_price', true ); ?>"
popup-large="<?php bloginfo('template_url'); ?>/images/single-market-image.jpg" />
</a><?php endif ?>

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط Mostafa_Pc
      سلام وقتتون بخیر
      کلی میگم که وقتتون رو نگیرم
      عکسای سایت رو انتقال دادم رو هاست دانلودی که تازه خریدم
      سایت https بوده اما واسه هاست ssl نگرفتم چون هزینه اضافی سالیانه بابت آیپی اختصاصی داشت
      کلیه کارارو انجام دادم عکسا توی پست و غیره نمایش پیدا میکنن
      اما تنها مشکی که موجوده تصاویر شاخص لود نمیشه
      فقط هم مشکل اینه آدرس تصویر شاخص رو از هاست دانلود میاره اما با آدرس https
      همین باعث میشه تصویر شاخص لود نشه
      راهی وجود داره که وردپرس به زور لینک هاست رو با https لود نکنه؟
      حتی از افزونه هایی که تصویر شاخص از آدرس خاص لود کنه هم استفاده کردم ولی بازم داره https میذاره
      افزونه Really Simple SSL هم نصبه غیرفعالش کردم ولی بازم حل نشد...
      اساتید راهنمایی کنید
      سپاسگذارم
    • توسط akradim
      اولا این رو بگم که واقعا برای خودمون متاسف هستم که ما ایرانی ها فقط بلد هستیم که جواب هایی رو که مثل اب خوردن هستیم رو به همه بگیم لی اگه یک چیزی که مشکل همه هست رو که نمیدونیم رو به بحث نمیزاریم که بقیه نگن ما بلد نیستیم. من نمیدونم یک نفر توی این ایران خراب شده نیست که جواب بده؟ 15 هفته هست که در تمام سایت های فارسی این مطلب رو گذاشتم ولی هیچ کدوم جواب ندادن یا حرف های مذخرف زدن که اصلا با این مطلب مرتبط نبود نمیدونم دیگه چیکار کنم واقعا متاسفم باز هم میگم اگه کسی میدونه لطفا کمک کنه حتی اگه بلد نیست بگه چطور باید پیش رفت یا یک سورس بده تا دنبال کنم تا برای همه این مشکل رو رفع کنیم چون همه با این مشکل روبرو هستن.
      سلام دوستان عزیز 
      یک سوال داشتم اون هم اینکه من از یک هسات دانلود استفاده میکنم چون حجم هاست برای خریداری خیلی گرون بود. یک هسات دانلود خریدم .
      میخواستم تصاویری که آپلود میکنم رو برای تصاویر شاخص قرار بدم. برای مثال پوسته من از 18 نوع تصویر کوچیک و بزرگ استفاده میکنه یعتی برای قسمت وبلاگ تصاویری با اندازه 260*150میخواد. ولی وقتی تصویر شاخصی میزارم فقط تصویر شاخص اصلی که ساز بزرگی داره رو قرار میده و نه کوچک رو که خود رسانه وردپرس ادازه بندی و برش داده و با این وجود حتی وقتی تصیری آپلود میکنم تصویر به 18 تا تصویر مختلف برش داده میشه ولی فقط یکش مورد استفاده قرار میگیره . میشه لطفا بگین باید چیکار کنم ؟
      لطفا کمکم کنید خیلی لود سایتم پایین اومد

       
       
    • توسط akradim
      سلام دوستان عزیز 
      یک سوال داشتم اون هم اینکه من از یک هسات دانلود استفاده میکنم چون حجم هاست برای خریداری خیلی گرون بود. یک هسات دانلود خریدم .
      میخواستم تصاویری که آپلود میکنم رو برای تصاویر شاخص قرار بدم. برای مثال پوسته من از 18 نوع تصویر کوچیک و بزرگ استفاده میکنه یعتی برای قسمت وبلاگ تصاویری با اندازه 260*150میخواد. ولی وقتی تصویر شاخصی میزارم فقط تصویر شاخص اصلی که ساز بزرگی داره رو قرار میده و نه کوچک رو که خود رسانه وردپرس ادازه بندی و برش داده و با این وجود حتی وقتی تصیری آپلود میکنم تصویر به 18 تا تصویر مختلف برش داده میشه ولی فقط یکش مورد استفاده قرار میگیره . میشه لطفا بگین باید چیکار کنم ؟
      لطفا کمکم کنید خیلی لود سایتم پایین اومد

       
    • توسط akradim
      سلام دوست عزیز 
      یک سوال داشتم اون هم اینکه من از یک هسات دانلود استفاده میکنم چون حجم هاست برای خریداری خیلی گرون بود. یک هسات دانلود خریدم .
      میخواستم تصاویری که آپلود میکنم رو برای تصاویر شاخص قرار بدم. برای مثال پوسته من از 18 نوع تصویر کوچیک و بزرگ استفاده میکنه یعتی برای قسمت وبلاگ تصاویری با اندازه 260*150میخواد. ولی وقتی تصویر شاخصی میزارم فقط تصویر شاخص اصلی که ساز بزرگی داره رو قرار میده و نه کوچک رو که خود رسانه وردپرس ادازه بندی و برش داده و با این وجود حتی وقتی تصیری آپلود میکنم تصویر به 18 تا تصویر مختلف برش داده میشه ولی فقط یکش مورد استفاده قرار میگیره . میشه لطفا بگین باید چیکار کنم ؟
       

    • توسط varoone
      سلام
      سایز جدیدی که در قالب جدید برای برش تصاویر شاخص در نظر گرفته شده، برای مطالبی که بعد از تغییر قالب ارسال میشود اعمال میشه و برای تصاویر قبلی اعمال نمیشه. بعنوان مثال تصویری که 500در 500 هست (قبل از تغییر قالب ) و باید برش داده بشه به 100در 100 ، صرفا در سایز 100در100 کوچیک میشه و برش نمیخوره. این باعث میشه که یک تصویر بزرگ 500 در 500 در اندازه 100 در 100 لود بشه که سرعت بارگزاری سایت بیاد پایین.
      راه حلی هست که بشه کلیه تصاویر نسبت به سایز های جدید قالب برای تصاویر کوچیک بشه و برش بخورن؟
       
      ممنون از پاسخگوییتون