premier

فعال کردن htaccess روی لوکال هاست؟

14 پست در این موضوع قرار دارد

سلام !

من پیوند یکتا روی لوکال هاست که از طریق rewrite انجام میشه با wamp server انجام دادم ولی این مشکل حل نمیشه و دوباره اررور 404 میده حالا به نظر شما مشکل از کجاست؟

0

به اشتراک گذاری این پست


لینک به پست

ببخشید چطوری میتونم Htaccess را روی لوکال هاست در وردپرس اجرا کنم و خطای 500 دریافت نکنم اصلا عملی هست؟

0

به اشتراک گذاری این پست


لینک به پست

شما mod_rewrite رو روی آپاچی فعال کردید؟

ادغام شد/.

0

به اشتراک گذاری این پست


لینک به پست

شما mod_rewrite رو روی آپاچی فعال کردید؟

بله فعال کردم ولی باز این اررور میاد خودمم تعجب کردم چون قبلا انجام میشد!به نظرتون میتونه مشکل از برنامه proxifierباشه؟

0

به اشتراک گذاری این پست


لینک به پست

فکر نمیکنم. مستقیم به آپاچی برمیگرده.

شما بعد تغییر در فایل httpd.conf ف سرورتون رو ریست هم کردید؟

0

به اشتراک گذاری این پست


لینک به پست

فکر نمیکنم. مستقیم به آپاچی برمیگرده.

شما بعد تغییر در فایل httpd.conf ف سرورتون رو ریست هم کردید؟

بله

0

به اشتراک گذاری این پست


لینک به پست

جالبه!

قبلا فعال بود بدون مشکل کار میکردید یا تازه فعالش کردید؟

0

به اشتراک گذاری این پست


لینک به پست

error 500 در این موارد میتونه از همون فایل .htaccess باشه .

این فایل رو خودتون نشتید یا همون دست نوشتهی وردپرسه؟

محتویات رو اینجا بذارید

0

به اشتراک گذاری این پست


لینک به پست


<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /1/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /1/index.php [L]
</IfModule>

محتویات htaccess

قبلا کار میکرد و ویندوز که عوض کردم در این ویندوز فعال نیست خودمم تعجب کردم!

0

به اشتراک گذاری این پست


لینک به پست

این کد که مشکل نداره.

توی فایل httpd.conf چک کنید که AllowOverride روی all هست؟

1

به اشتراک گذاری این پست


لینک به پست

این کد که مشکل نداره.

توی فایل httpd.conf چک کنید که AllowOverride روی all هست؟

اینطوری نوشته!


<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

0

به اشتراک گذاری این پست


لینک به پست

بشه این:

<Directory />
Options FollowSymLinks
AllowOverride all
Order deny,allow
Deny from all
</Directory>

3

به اشتراک گذاری این پست


لینک به پست

بشه این:

<Directory />
Options FollowSymLinks
AllowOverride all
Order deny,allow
Deny from all
</Directory>

آقا مرتضی مرسی مشکل حل شد!

ببخشید ولی کارایی که گفتید را انجام دادم حل نشد

راه حل اون اینگونه بود(برای اطلاع دوستان :D ):

روی قسمت APACHE کلیک می کنید سپس SERVICE را میزنید و REMOVE SERVICE را میزنید برنامه WAMPSERVER را می بندید و دوباره باز می کنید سپس روی INSTALL SERVICE کلیک کرده و بعد از کلیک روی START/RESUME SERVICE کلیک می کنید. :lol:

ببخشید وقت شما را گرفتیم آقا مرتضی ;)

3

به اشتراک گذاری این پست


لینک به پست

جای این همه کار rewrite_module رو فعال میکردید و خود ومپ ریستارت میشد. و مشکلتون حل میشد.

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط pouyamahmoudi
      با عرض سلام ، وقت بخیر و خسته نباشید
      قالب وردپرس من با وجود واکنش گرا بودن در نسخه موبایل یک مشکل داره 
      مشکل اینه که به صورت یه صفحه خالی با رنگ پس زمینه سایت میاد و باید صفحه رو بکشم به سمت راست تا محتویات نمایش داده بشه 
      لطفا جهت حل این مشکل راهنمایی کنید
      با سپاس

    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط reza_yki
      سلام من ابزارکی نوشتم که کاربر بتونه به وسیله select option به صورتی multi بتونه چندین دسته رو انتخاب کنه همه چیز درست و بدون مشکل کار میکنه فقط یه مشکل هست اونم اینه که وقتی ابزارک رو برای اولین بار فعال میکنی خطای زیر رو میده وباید یه دونه دسته رو انتخاب و ذخیره کنی تا ابزارک به صورت صحیح کارکنه لطفا راهنماییم کنید.
      Warning: in_array() expects parameter 2 to be array, string given in E:\Program Files\xampp\htdocs\wordpress\wp-content\themes\mymag\functions\widgets\widgets.php on line 29  
      اینم سورس کد:
      <?php public function form( $instance ) { $title = ! empty( $instance['title'] ) ? $instance['title'] : esc_html__( 'عنوان ابزارک', 'text_domain' ); $args = array( 'hide_empty' => 0, 'type' => 'post', 'taxonomy' => 'category', 'orderby' => 'name', 'hierarchical' => true, ); $cats = get_categories( $args ); $instance['cat_id'] = isset( $instance['cat_id'] ) ? ( $instance['cat_id'] ) : '1'; $count_cat = isset ($instance['cat_id']) ? count($instance['cat_id']) : '1' ; $tab_number = isset( $count_cat ) ? absint( $count_cat ) : 1; ?> <p> <label for="<?php echo $this->get_field_name( 'title' ); ?>"><?php _e( 'Title:' ); ?></label><br> <input class="widefat" id="<?php echo $this->get_field_id( 'title' ); ?>" name="<?php echo $this->get_field_name( 'title' ); ?>" type="text" value="<?php echo esc_attr( $title ); ?>" /> </p> <p> <label for="<?php echo $this->get_field_id('tab_number'); ?>"><?php _e( 'تعداد زبانه:'); ?></label><br> <input id="<?php echo $this->get_field_id('tab_number'); ?>" name="<?php echo $this->get_field_name('tab_number'); ?>" type="number" min="0" class="my_widget_number" value="<?php echo $tab_number; ?>" size="3" /> </p> <label for="<?php echo $this->get_field_name( 'cat_id' ); ?>"><?php _e( 'انتخاب دسته بندی : ' ); ?></label> <select id="<?php echo $this->get_field_id( 'cat_id' ); ?>" name="<?php echo $this->get_field_name( 'cat_id[]' ); ?>" multiple="multiple" style="width: 100%; margin: 10px auto; height: auto;"> <?php foreach( $cats as $cat ): ?> <option value="<?php echo esc_attr(__($cat->term_id)); ?>"<?php selected(in_array($cat->term_id, $instance['cat_id'])); // selected($cat->term_id,$cats_id) ?>><?php echo esc_attr(__($cat->name)); ?></option> <?php endforeach; ?> </select> <p> <input type="text" value="<?php echo esc_attr(__(implode(',', $instance['cat_id']))); ?>"> </p> <?php }  
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟
    • توسط hamid_diablo
      سلام دوستان
      من وردپرس رو روی لوکال هاست نصب کرده بودم
       
      تا چند روز پیش مشکلی نداشتم تا اینکه یه پوسته جدید نصب کردم و بعد از اون متاسفانه وردپرس بالا نیامد (صفحه سفید ظاهر شد )
       
      فقط قالب صحیفه رو نمایش میده بدون پیشخوان!!!
       
      وردپرس و پاک کردم و دوباره روی لوکال هسات نصب کردم اما مشکل برطرف نشد !
      ممنون میشم راهنماییم کنید