9 پست در این موضوع قرار دارد

درود

من پلاگین Google XML Sitemaps رو نصب کردم و ساخت سایت مپ رو هم زدم حتی rebuild the sitemap رو هم زدم اما هنوز این ارر رو میده.

عکس ارر:

post-2979-0-20027200-1376406143_thumb.pn

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

درود

http://nimadownload.com/sitemap.xml

ویرایش شده در توسط نورزاد
3

به اشتراک گذاری این پست


لینک به پست

کد زیر رو به htacces اضافه کنید :


RewriteEngine On
RewriteCond %{HTTP_HOST} ^domain.com [NC]
RewriteRule ^(.*)$ http://www.domain.com/$1 [L,R=301]

اگه سایت بدون www بالا میاد کد زیر :


RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.domain.com [NC]
RewriteRule ^(.*)$ http://domain.com/$1 [L,R=301]

یا به فایل wp-content/plugins/google-sitemap-generator/sitemap-core.php مراجعه کنید و کد زیر رو پیدا :


function GetDefaultStyle() {
$p = $this->GetPluginPath();
if(file_exists($p . "sitemap.xsl")) {
$url = $this->GetPluginUrl();
//If called over the admin area using HTTPS, the stylesheet would also be https url, even if the blog frontend is not.
if(substr(get_bloginfo('url'),0,5) !="https" && substr($url,0,5)=="https") $url="http" . substr($url,5);
return $url . 'sitemap.xsl';
}
return '';
}

و بجاش اینو بذارید :


function GetDefaultStyle() {
$p = $this->GetPluginPath();
if(file_exists($p . "sitemap.xsl")) {
return '/wp-content/plugins/google-sitemap-generator/sitemap.xsl';
}
return '';
}

و در اخر ریبیلت رو بزنید و تست کنید

4

به اشتراک گذاری این پست


لینک به پست

سلام

مثل اینکه درست شد. :D

بعد یه سوال بعضی از سایت مپ ها یه شکل دیگه است این بهتره یا اون؟

سپاس

0

به اشتراک گذاری این پست


لینک به پست

بعضی از سایت مپ ها یه شکل دیگه است این بهتره یا اون؟

همین خوبه ... به نوعی بهترینه

2

به اشتراک گذاری این پست


لینک به پست

همین خوبه ... به نوعی بهترینه

خیلی ممنون از کمکتون

سپاس

0

به اشتراک گذاری این پست


لینک به پست

همین خوبه ... به نوعی بهترینه

من هم همین مشکل را دارم و تمام این کارها را انجام دادم و درست نشد

آیا راهکار دیگه ای دارید؟

0

به اشتراک گذاری این پست


لینک به پست

سلام دوستان

من با این پلاگین مشکل دارم و ارور زیر رو میده کلا بهم.

حتی از پلاگین yoast هم استفاده کردم برای سایت مپ اما همچین مشکلی داشت. راه بالا هم تست کردم ظاهرا که جوابگو نبود.

 

XML Parsing Error: XML or text declaration not at start of entity
Location: http://siteMan.ir/sitemap.xml
Line Number 1, Column 2:

<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="http://siteMan.ir/wp-content/plugins/google-sitemap-generator/sitemap.xsl"?><!-- sitemap-generator-url="http://www.arnebrachhold.de" sitemap-generator-version="4.0.8" -->
-^

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط meraj
      سلام
      من افزونه Google XML Sitemaps رو نصب کردم و تنظیمات لازم رو انجام دادم (مو به مو) اما الان آدرس سایت مپم اینطوری شده http://difiles.ir/sitemap.xml لطفا راهنماییم کنید که چطوری درستش کنم
    • توسط sajjjad95
      سلام دوستان من افزونه Google XML Sitemaps روی سایتم نصب هستش امروز متوجه شدم که http://nicedownload.ir/sitemap-tax-post_tag.xml با نمیشه بقیه درسته فقط این خرابه مشکلش از چیه ؟؟؟ کسی میتونه راهنمایی کنه ؟؟؟
    • توسط runy
      سلام
      این افزونه برای چند سایته هاست ولی کار نمیکنه یعنی نقشه سایت اصلی را نمیده ولی برای باقی زیر دامنه ها یا وبلاگ هام کار میده ولی قسمت اصلی سایت را کار نمیده اینم آدرس فایلی مه درست میکنه ولی کار نمیده
      http://nedaj.ir/sitemapindex.xml
      صفحه سفیده
      اینم آدری نقشه زیر دامنه ای که توش کار میده
      http://nedaj.ir/lear...itemapindex.xml
      چه کار کنم برای سایت اصلی هم نقشه بده؟
    • توسط rezanoroozy
      سلام
      مدتی هست که من با افزونه Google XML Sitemaps به مشکل بر خوردم
      بعضی مواقع که sitemap.xml رو باز میکنم (از طریق سایت) میبینم یک خطی رو اررور داده میرم اون خط رو پاک میکنم و درست میشه
      اما بعد که پست جدید میدم بعضی وقتها دوباره اون مشکل پیش میاد و ارور میده اما نه اون اررور قبلی تو اون خط
      یک اررور توی خط دیگه و توی پست دیگه و همینجوری من پاک میکنم و بعد مدتی ایجاد میشه
      ممنون میشم کمک کنید