greeneye

مشکل پیغام خطا در وردپرس

10 پست در این موضوع قرار دارد

سلام

ببخشید من یک مشکل بزرگ دارم و اینکه وقتی میخام یک مطلب رو انتشار بدم و یا یک چیزی رو به روز میکنم این پیغام که توی عکس پیوست شده هست برام میاد

post-1294-0-08369900-1376664024_thumb.pn

0

به اشتراک گذاری این پست


لینک به پست

خیلی مشکلات پیش اومده برام فکر میکنم از وردپرس 3.6 هست

چند تا از افزونه هام خراب شده ، حتی افزونه next gallery هم خراب شده

مجبور میشم غیر فعال کنم

چکار کنم

0

به اشتراک گذاری این پست


لینک به پست

نسخه جدید وردپرس نیاز به نسخه جدیدتر php داره و برخی سرورها هنوز مناسب این نسخه نیستن

http://wordpress.org/about/requirements/

2

به اشتراک گذاری این پست


لینک به پست

سلام

در مورد افزونه‌ها شما می‌تونید قبل از ارتقاء (حالا که گذشت (: ) در قسمت phpmyadmin هاست‌تون از افزون‌هایی که از پایگاه داده استفاده می‌کنند

یک فایل خروجی بگیرید و بعد از ارتقاء اون رو وارد کنید

البته خودم تست نکردم ولی چون معمولا افزونه‌ها از پایگاه داده استفاده می‌کنند و وردپرس ۳.۶ هم پایگاه داده رو به‌روز می‌کنه

شاید به خاطر همین افزونه‌ها مشکل پیدا کرده

1

به اشتراک گذاری این پست


لینک به پست

سلام

در مورد افزونه‌ها شما می‌تونید قبل از ارتقاء (حالا که گذشت (: ) در قسمت phpmyadmin هاست‌تون از افزون‌هایی که از پایگاه داده استفاده می‌کنند

یک فایل خروجی بگیرید و بعد از ارتقاء اون رو وارد کنید

البته خودم تست نکردم ولی چون معمولا افزونه‌ها از پایگاه داده استفاده می‌کنند و وردپرس ۳.۶ هم پایگاه داده رو به‌روز می‌کنه

شاید به خاطر همین افزونه‌ها مشکل پیدا کرده

ممنون مهدی اقا اما میشه یکم مبتدی تر برای من توضیح بدید و بگید چطور باید فایل خروجی رو بگیرم از افزونه قبل از ارتقا ؟ البته خوب برای دفعه بعد

و الان به نظرتون چاره چیه

0

به اشتراک گذاری این پست


لینک به پست

ببینید لازم کمی منابع آموزشی php و mySql رو بخونید تا آشنا بشید

برای آشنایی هم می‌تونید با برنامه‌ای مثل xampp شروع کنید

برای خروجی گرفتن هم می‌تونید به پشتیبان هاست‌تون بگید براتون این کار و انجام بده

اما حالا چه باید کرد

همون طور که آقا مرتضی گفتن اول باید ببینید هاست‌تون از نسخه جدید php پشتیبانی می‌کنه یا نه

اگر پشتیبانی می‌کنه:

از خود وردپرس از تمام فایل‌هاتون خروجی بگیرید

بعد وردپرس رو دوباره نصب کنید (با دیتابیس جدید٬ برای این کار می‌تونیدفقط با عوض کردن اسم دیتابیس‌تون٬ وردپرس رو دوباره نصب کنید) بعد فایل خروجی رو از خود وردپرس دوباره وارد کنید تا محتوای سایت‌تون برگرده و افزونه‌هاتون رو دوباره فعال کنید

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

ببینید لازم کمی منابع آموزشی php و mySql رو بخونید تا آشنا بشید

برای آشنایی هم می‌تونید با برنامه‌ای مثل xampp شروع کنید

برای خروجی گرفتن هم می‌تونید به پشتیبان هاست‌تون بگید براتون این کار و انجام بده

اما حالا چه باید کرد

همون طور که آقا مرتضی گفتن اول باید ببینید هاست‌تون از نسخه جدید php پشتیبانی می‌کنه یا نه

اگر پشتیبانی می‌کنه:

از خود وردپرس از تمام فایل‌هاتون خروجی بگیرید

بعد وردپرس رو دوباره نصب کنید (با دیتابیس جدید٬ برای این کار می‌تونیدفقط با عوض کردن اسم دیتابیس‌تون٬ وردپرس رو دوباره نصب کنید) بعد فایل خروجی رو از خود وردپرس دوباره وارد کنید تا محتوای سایت‌تون برگرده و افزونه‌هاتون رو دوباره فعال کنید

سلام

ممنون بابت لینک ها ، حتما استفاده میکنم

پشتیبانی نمیکنه ، پرسیدم

حالا باید برگردونم نسخه وردپرس رو ؟ اگر اینکارو باید بکنم چطور؟

ویرایش شده در توسط greeneye
0

به اشتراک گذاری این پست


لینک به پست

خوب براتون آپگرید نمیکنن؟

1

به اشتراک گذاری این پست


لینک به پست

خوب براتون آپگرید نمیکنن؟

اینطور که اینا میگن نه ، یه سرور دارن php 5.2.17 هست که میگه اگر میخواین انتقال بدیم

اما من برای وردپرس اونطوری که متوجه شدم php 5.2.4 میخواد درسته ؟

0

به اشتراک گذاری این پست


لینک به پست

پس با اینحال مجبورید دان گرید کنید که اصلا درست نیست

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط masoudmosleh267
      سلام دوستان. من یه سایتی رو از بکاپ گرفتم و از یه هاست و دامنه به یه هاست و دامنه جدید انتقال دادم. حالا چه سایت رو که باز میکنم چه وارد پیشخوان وردپرس میشم یه ارور میاد یکی از خطلی functions.php قالب رو نشون میده.
      Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /public_html/wp-content/themes/khadamator/functions.php on line 1132
      مشکل چیه؟
    • توسط amirsa
      سلام
      من محصولات متغیر رو در ووکامرس که وارد میکنم،(محصول ممکنه 2 یا 3 صفت داره که باید انتخاب بشه)
       توی فروشگاه ووکامرس بصورت حد اقل و حداکثر قیمت ها نشون داده میشه
      مثلا کالا دونوع 10 و  20 تومانی هست.صفت آ 15 تومن برای مشتری هایی که بخوان.تو فروشگاه قیمت رو بصورت 10-35 نشون میده که بیشتر از قیمت اصلی است.من میخوام همون 10 و 20 رو نشون بده
      این مشکل انرژی زیادی ازم گرفته ممنون میشم راهنماییم کنید 
    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط صالح طالبی
      باسلام خدمت شما عزیزان
      بنده این تکه کد رو که در اصل افزونه نمایش آخرین های انجمن بود برای وردپرس به صورت کد در خود فانکشن قالب دراوردم:
      function ipslatest_main($query) { if ( is_home() && $query->is_main_query() ) { $db_user = 'root'; $db_name = 'ipsdb'; $db_pass = ''; $db_host = 'localhost'; $prefix = get_option('ipslatest_db_prefix'); $url = 'http://localhost/IPS'; $limit = '5'; $title = ''; $width = '300'; $direction = 'rtl'; $translations = array('عنوان','بازدید','پاسخ ها','ارسال شده به وسیله'); $db = new wpdb( $db_user, $db_pass, $db_name,$db_host ); $q = $db->get_results( 'SELECT topic_id,author_name FROM '.$prefix.'forums_posts ORDER BY pid DESC LIMIT '.$limit ); echo '<div id="ipslatest-mainTitle" style="width:'.$width.'">'.$title.$position.'</div>'; echo '<table id="ipslatestTopics" border=0 style="padding:10px;width:'.$width.'">'; echo '<tr><td class="ipslatest-row-views">'.$translations[2].'</td><td class="ipslatest-row-answers">'.$translations[1].'</td><td class="ipslatest-row-sender">'.$translations[3].'</td><td class="ipslatest-row-title">'.$translations[0].'</td> </tr>'; if (is_array($q) || is_object($q)) { foreach ($q as $key => $row) { $topicDetails = $db->get_row('SELECT title,tid,views,posts FROM '.$prefix.'forums_topics WHERE tid='.$row->topic_id); $userMemberID = $db->get_row('SELECT member_group_id FROM '.$prefix."core_members WHERE name='".$row->author_name."'"); $userShowingData = $db->get_row('SELECT prefix,suffix FROM core_groups WHERE g_id='.$userMemberID->member_group_id); echo '<tr id="ipstopic"> <td class="ipslatest-row-views-content"> <span>'.$topicDetails->views.' </span></td> <td class="ipslatest-row-answers-content"><span>'.$topicDetails->posts.'</span></td> <td id="ipslatest-row-sender-content">'.$userShowingData->prefix.$row->author_name.$userShowingData->suffix.'</td> <td class="ipsTitle"> <a rel="follow" href="'.$url.'topic/'.$topicDetails->tid.'-'.strtolower(str_replace(" ","-",$topicDetails->title)).'">'. strip_tags($topicDetails->title) .' </a> </td> </tr>'; } /*}*/ } echo '</table>'; } } به صورت خودکار خود افزونه از کد زیر برای نمایش اون در اول پست های سایت و یا در آخر پست های سایت استفاده میکنه کد ها هم به این شکله:
      add_action( 'wp', 'ipslatestMain' ); function ipslatestMain( $query ) { $position = "bottom"; if($position === "bottom") $acton = "loop_end"; elseif ($position === "top") $acton = "loop_start"; add_action($acton,"ipslatest_main"); } الان بدون هیچ مشکلی نمایش میده در پایین پست ها ولی من میخام این نمایش رو در یه قسمت دیگه از قالب انجام بدم و چجوری میتونم این فانکشن و تابع رو نمایش بدم؟؟؟
      نام افزونه هم در ضمن ipsuite-latest-topics هست و من از حالت افزونه فقط خارجش کردم و در خود قالب و فانکشن اون اوکی کردم.
      فقط مشکل اینه که نمیخام در بالای پست یا پایین پست ها نمایش بدم و میخام در جایی که خودم تعیین میکنم تابع رو نمایش بدم؟!!!
      ممنون میشم راهنمایی بفرمایید.
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟