Saeed Fard

مشكلات و سوالات رفع ارورهاي قالب در W3C

469 پست در این موضوع قرار دارد

با تشکر مجدد از پیگیری شما،

چرا با کپی کردن این کد قبل از تگ بادی تعداد ارورها بسیار کاهش یافت؟

با توجه به فرمایش قبلی شما  تگ time را که فرمودید پیدا نکردم دقیقا این تگ در کدام قسمت قرار دارد؟

 

0

به اشتراک گذاری این پست


لینک به پست

تگ تایم یعنی توی کدهای شما نیست؟

1

به اشتراک گذاری این پست


لینک به پست

متاسفانه هر چی گشتم پیدا نکردم!!

تگ time دقیقا کجاست؟

0

به اشتراک گذاری این پست


لینک به پست
در در ۱۳۹۵/۱۰/۵ ه‍.ش. at 14:45، mehran242 گفته است :

با تشکر فراوان از راهنمایی مفید شما،

سایت من ورد پرس هست و زمانیکه این کدها را :   <p>We open at <time>10:00</time> every morning.</p>
<p>I have a date on <time datetime="2008-02-14 20:00">Valentines day</time>.</p>

در قسمت header.php و قبل از تک body کپی میکنم ارورها برطرف می شود ولی در صفحه اول سایت در بالای هدر به این صورت :

We open at 10:00 every morning.

I have a date on Valentines day.

در سایت نشان داده می شود دلیل این مساله چیست؟

شما اینجا گفتید کد فوق رو توی سایتتون کپی می کنید. منظور من این بود که شما تگ time رو کجا قرار می دید؟

0

به اشتراک گذاری این پست


لینک به پست
در در 12/31/2016 at 20:27، mehran242 گفته است :

متاسفانه هر چی گشتم پیدا نکردم!!

تگ time دقیقا کجاست؟

ادرس سایت رو برای بررسی دوستان قرار بدین

0

به اشتراک گذاری این پست


لینک به پست

دوستان ممنون میشم راهنماییم کنید برای رفع این خطاها

 A document must not include both a meta element with an http-equiv attribute whose value is content-type, and a meta element with a charset attribute.

 

 A document must not include more than one meta element with its name attribute set to the value description.

 

Element div not allowed as child of element ul in this context. (Suppressing further errors from this subtree.)

 

Bad value ss for attribute required on element input.

 

Element style not allowed as child of element body in this context. (Suppressing further errors from this subtree.)

0

به اشتراک گذاری این پست


لینک به پست

سلام

 

نقل قول

A document must not include both a meta element with an http-equiv attribute whose value is content-type, and a meta element with a charset attribute.

این یعنی شما توی فایل HTML تون هم

<meta http-equiv="content-type" content="text/html; charset=UTF-8">

دارید و هم

<meta charset="UTF-8">

یکیشو پاک کنید توصیه من اینه که اولی رو پاک کنید.

نقل قول

A document must not include more than one meta element with its name attribute set to the value description.

این یعنی که دو یا چند تا از

<meta name="description" content="توضیحات">

توی فایل HTML تون دارید که خوب باید یکیشو نگه دارید و بقیه رو پاک کنید.

نقل قول

Element div not allowed as child of element ul in this context. (Suppressing further errors from this subtree.)

این یعنی توی یه جایی از کدهای HTML تون تگ div رو گذاشتید توی تگ ul که خوب اشتباهست.

فقط تگ li میتونه فرزند تگ ul باشه.

نقل قول

Bad value ss for attribute required on element input.

این یعنی برای اتربیوت required تگ input مقدار ss رو تعریف کردید که احتیاجی نیست. اتریبیوت required مقدار نداره مثلا به شکل زیر باید باشه:

<input type="text" name="usrname" required>
نقل قول

Element style not allowed as child of element body in this context. (Suppressing further errors from this subtree.)

اینم یعنی تگ style رو درون تگ body تعریف کردید که باید درون تگ head تعریفش کنید.

 

موفق باشید

ویرایش شده در توسط mehran-b
0

به اشتراک گذاری این پست


لینک به پست
در 21 ساعت قبل، mehran-b گفته است :

سلام

 

این یعنی شما توی فایل HTML تون هم


<meta http-equiv="content-type" content="text/html; charset=UTF-8">

دارید و هم


<meta charset="UTF-8">

یکیشو پاک کنید توصیه من اینه که اولی رو پاک کنید.

این یعنی که دو یا چند تا از


<meta name="description" content="توضیحات">

توی فایل HTML تون دارید که خوب باید یکیشو نگه دارید و بقیه رو پاک کنید.

این یعنی توی یه جایی از کدهای HTML تون تگ div رو گذاشتید توی تگ ul که خوب اشتباهست.

فقط تگ li میتونه فرزند تگ ul باشه.

این یعنی برای اتربیوت required تگ input مقدار ss رو تعریف کردید که احتیاجی نیست. اتریبیوت required مقدار نداره مثلا به شکل زیر باید باشه:


<input type="text" name="usrname" required>

اینم یعنی تگ style رو درون تگ body تعریف کردید که باید درون تگ head تعریفش کنید.

 

موفق باشید

خیلی ممنون از لطفتون حل شدن

1

به اشتراک گذاری این پست


لینک به پست

سلام خسته نباشید.ممنون از مطالب خوبتون.

اگه میشه یه زحمت بکشید این ارور های سایت منو بررسی کنید بگید چجوری رفعش کنم.این ارور ها در توضیحاتتون نبود.

Www.bestdesignerr.ir

و اینکه رفع  warning ها برای سئو مهم هست؟

0

به اشتراک گذاری این پست


لینک به پست

سلام

سایت من اینارو داده به عنوان هشدار؟

خطریه؟ باید چیکار کنم؟

Untitled.png

0

به اشتراک گذاری این پست


لینک به پست
در 13 ساعت قبل، morteza3375 گفته است :

سلام

سایت من اینارو داده به عنوان هشدار؟

خطریه؟ باید چیکار کنم؟

Untitled.png

سلام دوست عزیز

تلگرام پیام بدید واساون حل کنم

@hasanataieir

0

به اشتراک گذاری این پست


لینک به پست

سلام خسته نباشید

دوستان این دو ارور رو چطور برطرف کنم

Capture1.JPG

0

به اشتراک گذاری این پست


لینک به پست

سلام و درود

 

در 2 دقیقه قبل، akbar-pc گفته است :

سلام خسته نباشید

دوستان این دو ارور رو چطور برطرف کنم

Capture1.JPG

مورد اول میگه تگ style ای توی کدهاتون دارید که فرزند تگ noscript هست که اشتباهه باید مستقیم داخل تگ head قرارش بدید تگ style رو.

مورد دوم هم میگه اتریبیوت type برای تگ استایل احتیاجی نیست و باید حذف بشه.

 

موفق باشید

0

به اشتراک گذاری این پست


لینک به پست
در 4 دقیقه قبل، mehran-b گفته است :

سلام و درود

 

مورد اول میگه تگ style ای توی کدهاتون دارید که فرزند تگ noscript هست که اشتباهه باید مستقیم داخل تگ head قرارش بدید تگ style رو.

مورد دوم هم میگه اتریبیوت type برای تگ استایل احتیاجی نیست و باید حذف بشه.

 

موفق باشید

ممنون از پاسختون

تمام کد ها رو کشتم از صبح تک style  اصلا ندارم توی کد های قالب

اتریبیوت type همون ارور بالا رو یگه ؟

0

به اشتراک گذاری این پست


لینک به پست

درود مجدد

 

نقل قول

تمام کد ها رو کشتم از صبح تک style  اصلا ندارم توی کد های قالب

بالاخره همچین چیزی هستش توی خروجی سایت که داره ازش ایراد میگیره.

نقل قول

اتریبیوت type همون ارور بالا رو یگه ؟

بله همون تگ style ای که توی تگ noscript هست این اتریپیوت رو داره.

0

به اشتراک گذاری این پست


لینک به پست
در 20 دقیقه قبل، mehran-b گفته است :

درود مجدد

 

بالاخره همچین چیزی هستش توی خروجی سایت که داره ازش ایراد میگیره.

بله همون تگ style ای که توی تگ noscript هست این اتریپیوت رو داره.

پیداش کردم از یه پلاگین بود حل شد ممنون که جواب دادین

0

به اشتراک گذاری این پست


لینک به پست
در هم اکنون، akbar-pc گفته است :

پیداش کردم از یه پلاگین بود حل شد ممنون که جواب دادین

خواهش میکنم.

موفق باشید

0

به اشتراک گذاری این پست


لینک به پست
در در 6/8/2012 at 14:02، Morteza گفته است :

ببینید بستگی داره.

بیشتر باید ویرایش و رفع خطا کنید تا حذف کردن.

در کل وقتی خطا میده معناش این نیست که اون بخش باید حذف بشه.

سلام. بنظر شما اصلا این کار لازم هست؟

راهنمایی کنید

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط masoudmosleh267
      سلام دوستان. من یه سایتی رو از بکاپ گرفتم و از یه هاست و دامنه به یه هاست و دامنه جدید انتقال دادم. حالا چه سایت رو که باز میکنم چه وارد پیشخوان وردپرس میشم یه ارور میاد یکی از خطلی functions.php قالب رو نشون میده.
      Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /public_html/wp-content/themes/khadamator/functions.php on line 1132
      مشکل چیه؟
    • توسط amirsa
      سلام
      من محصولات متغیر رو در ووکامرس که وارد میکنم،(محصول ممکنه 2 یا 3 صفت داره که باید انتخاب بشه)
       توی فروشگاه ووکامرس بصورت حد اقل و حداکثر قیمت ها نشون داده میشه
      مثلا کالا دونوع 10 و  20 تومانی هست.صفت آ 15 تومن برای مشتری هایی که بخوان.تو فروشگاه قیمت رو بصورت 10-35 نشون میده که بیشتر از قیمت اصلی است.من میخوام همون 10 و 20 رو نشون بده
      این مشکل انرژی زیادی ازم گرفته ممنون میشم راهنماییم کنید 
    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط صالح طالبی
      باسلام خدمت شما عزیزان
      بنده این تکه کد رو که در اصل افزونه نمایش آخرین های انجمن بود برای وردپرس به صورت کد در خود فانکشن قالب دراوردم:
      function ipslatest_main($query) { if ( is_home() && $query->is_main_query() ) { $db_user = 'root'; $db_name = 'ipsdb'; $db_pass = ''; $db_host = 'localhost'; $prefix = get_option('ipslatest_db_prefix'); $url = 'http://localhost/IPS'; $limit = '5'; $title = ''; $width = '300'; $direction = 'rtl'; $translations = array('عنوان','بازدید','پاسخ ها','ارسال شده به وسیله'); $db = new wpdb( $db_user, $db_pass, $db_name,$db_host ); $q = $db->get_results( 'SELECT topic_id,author_name FROM '.$prefix.'forums_posts ORDER BY pid DESC LIMIT '.$limit ); echo '<div id="ipslatest-mainTitle" style="width:'.$width.'">'.$title.$position.'</div>'; echo '<table id="ipslatestTopics" border=0 style="padding:10px;width:'.$width.'">'; echo '<tr><td class="ipslatest-row-views">'.$translations[2].'</td><td class="ipslatest-row-answers">'.$translations[1].'</td><td class="ipslatest-row-sender">'.$translations[3].'</td><td class="ipslatest-row-title">'.$translations[0].'</td> </tr>'; if (is_array($q) || is_object($q)) { foreach ($q as $key => $row) { $topicDetails = $db->get_row('SELECT title,tid,views,posts FROM '.$prefix.'forums_topics WHERE tid='.$row->topic_id); $userMemberID = $db->get_row('SELECT member_group_id FROM '.$prefix."core_members WHERE name='".$row->author_name."'"); $userShowingData = $db->get_row('SELECT prefix,suffix FROM core_groups WHERE g_id='.$userMemberID->member_group_id); echo '<tr id="ipstopic"> <td class="ipslatest-row-views-content"> <span>'.$topicDetails->views.' </span></td> <td class="ipslatest-row-answers-content"><span>'.$topicDetails->posts.'</span></td> <td id="ipslatest-row-sender-content">'.$userShowingData->prefix.$row->author_name.$userShowingData->suffix.'</td> <td class="ipsTitle"> <a rel="follow" href="'.$url.'topic/'.$topicDetails->tid.'-'.strtolower(str_replace(" ","-",$topicDetails->title)).'">'. strip_tags($topicDetails->title) .' </a> </td> </tr>'; } /*}*/ } echo '</table>'; } } به صورت خودکار خود افزونه از کد زیر برای نمایش اون در اول پست های سایت و یا در آخر پست های سایت استفاده میکنه کد ها هم به این شکله:
      add_action( 'wp', 'ipslatestMain' ); function ipslatestMain( $query ) { $position = "bottom"; if($position === "bottom") $acton = "loop_end"; elseif ($position === "top") $acton = "loop_start"; add_action($acton,"ipslatest_main"); } الان بدون هیچ مشکلی نمایش میده در پایین پست ها ولی من میخام این نمایش رو در یه قسمت دیگه از قالب انجام بدم و چجوری میتونم این فانکشن و تابع رو نمایش بدم؟؟؟
      نام افزونه هم در ضمن ipsuite-latest-topics هست و من از حالت افزونه فقط خارجش کردم و در خود قالب و فانکشن اون اوکی کردم.
      فقط مشکل اینه که نمیخام در بالای پست یا پایین پست ها نمایش بدم و میخام در جایی که خودم تعیین میکنم تابع رو نمایش بدم؟!!!
      ممنون میشم راهنمایی بفرمایید.
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟