rasivell

مشكلي عجيب در پلاگين WP Page Number

25 پست در این موضوع قرار دارد

سلام خدمت مدير محترم انجمن! مشكلي پيش امده كه باور بفرماييد به هر دري زديم درست نشده! خيلي عجيبه اصلا كسي ازش سر در نمياره! انجمن اصليش هم جواب نميده فكر كنم به علت ايراني بودن سايت جواب نميدن! لطفا يه برسي بفرماييد و اگر اكانت پنل و .. ميخوايد بديم خدمدتون برسي بفرماييد!

مشكل از اين قراره كه توي صفحه اصلي فروشگاه ما ، صفحه بندي وجود داره و ما از پلاگيين WP Page Numbers استفاده ميكنيم! تا همين 4 روز پيش داشت مثل ساعت درست و حسابي كار ميكرد. باور بفرماييد جدي ميگم هيچ تغيري نداديم هيچ دستي به قالب نزديم ولي يك شبه از كار افتاده! ميخواي بري صفحه دوم و ... ميزنه كه 404 پيدا نشد !! چطور تا چند روز پيش سالم بود يكدفعه غيبش زد!

كارايي كه ما كرديم از اين قراره= پا كردن پلاگين و نصب دوباره ان 2- پاك كردن قالب و نصب دوباره ان 3- پاك كردن كل سيستم وردپرس و نصب دوباره ان و بازيابي اطلاعات!!! 4- نصب پوسته اورجينال كه ديگه هيچ مشكلي نداره ولي باز كار نكرد!! 5- دعا كردن!!! :) 6- مراجعه به شما // البته تو پرانتز بگم يك بار اطلاعا پنل داديم يكي از دوستان قابل اعتمادمون برسي فرمودن ولي به نتيجه نرسيد. بعد از اون هم كل سايت رو پاك كردن و دوباره سيستم و پلاگين ها و قالب رو نصب كرديم و درون ريزي كرديم اطلاعات رو!

اينم لينكه :

http://www.game-iran.com/shop/page/2

اميدواريم كه بشه كاري كرد براش :unsure:

0

به اشتراک گذاری این پست


لینک به پست

احیانا پیوند یکتارو عوض نکردین؟

2

به اشتراک گذاری این پست


لینک به پست

پيوند يكتا هموني كه بود بود هست!! يعني روز اول عوض كرديم و اونطوري كه ميخواستيم گذاشتيمش و از اون روزم بهش دست نزديم و اينكه اگر از پيوند يكتا و.. بود پس چرا داشت تا همين چند روز پيش كار ميكرد يكدفعه يادش افتاده كه پيوند يكتايي هم وجود داره!!! نه عزيزم همون قبليه و دست نخورده! اصلا نميدونيم چش شده

0

به اشتراک گذاری این پست


لینک به پست

بعضی وقتها ممکنه پشتیبان سایت یه رستور بک آپ داشته باشه :rolleyes: در این مواقع بعضی وقتها سطح دسترسی فایلها به هم میرزه بعضی وقتها هم فایل .htaccess حذف میشه .

شما توی پیوند یکتا یبار به حالت پیشفرض برگردید example.com/?p=1 و بعد دوباره پیوند یکتای خود را بنویسید تا وردپرس فایل .htaccess رو دوباره بنویسه .

3

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

پ.ن= كسي نوشته من رو درست مطالعه نكرده!! ايا فراتر از نصب دوباره وردپرس و تمام پلاگين ها داريم؟؟؟ ديگه ريست كردن سيستم از اين بالاتر؟؟ هم خودم و هم اون دوستمون كه كارشونم حرف نداره اين كار تغير پيوند يكتارو انجام دادن ولي باور بفرماييد درست نشده! ولي براي اينكه خودمم دوباره از شك در بيام اين كارو همين الان يه بار تست كردم! به حالت پيش فرض گذاشتم سيو كردم رفتم سايت رو ديدم خراب بود! و باز برگردوندم به حالت قبل

مشكل فراتر از اين حرفاست!

يه چيز جديد كشف كردم!!! اقا مرتضي منتظر جواب شمام در اين باره!!

دوستان خوب توجه كنيد لطفا تا كاملا متوجه اين پديده بشيد!!!

من گفتم شايد مشكل از تم باشه با  اينكه دارم ميگم 100000000000 درصد بدونيد كه كوچكترين تغيري توش ندادم ! يعني امادش كرديم و قشنگ صفحاتش كار ميكرد بعد يك هفته از كار افتاد تو اون يك هفته باور بفرماييد دست بهش نزدم!!

خب = من گفتم شايد اين تم ما قاطي داره! رفتم يه كاري كردم و اون اين بود! گفتم توي بخش تنظيمات كه تو هر صفحه 18 تا نوشته نشون بده! بعد سريع قالب رو عوض كردم و حدودا 23 تا نوشته داشتيم كه تو قالب جديد 18 تاي اول امد به صفحه اول و الباقي رفت صفحه دوم! در كمال نا باوري توي قالب پيش فرض خود وردپرس كار كرد صفحات !! پ.ن= پلاگين مشكلي نداره! خب در جا منم كلك رشتي زدم و امدم سريع تم رو عوض كردم و ديگه اون تنظيمات كه گفته بودم تو هر صفحه 18 تا مطلب نشون بده رو دست نزدم! و ديدم تو قالب خودمون درست شد!!!! جلل خالق!

حالا نتكه جالب اينجاست: ما ميخوايم تو هر صفحه مثلا 10 تا مطلب باشه نه 18 تا! وقتي بعد از اينكه درست شده بود باز رفتم اون عدد رو عوض كردم تو پنل و 18 رو كردم 10 ! باز خراب شد!!!

بازم نكنه جالبترش اينجاست كه ديگه عدد رو گذاشتم رو 10 موند و باز تم رو تغير دادم ديدم تو تم جديد كار ميكنه و سريع دوباره تم خودمون رو فعال كردم ديدم بله كار كرد! يعني ما ميخوايم مثلا يه صفحه اضافه كنيم بايد تم رو 100 بار عوض كنيم تا كار كنه!! اين احساس ميكنم يه سرنخي باشه كه اقا مرتضي عزيز بدونه چرا وقتي تم رو عوض ميكني و دوباره بر ميگردي سر تم قبلي درست ميشه و چرا اين پروسه رو بايد انجام داد!!؟ شايد متوجه مشكل بشيد استادان! ما از پلاگين كش و... استفاده نميكنيم ولي احساس ميكنم اين يه جايي كش ميشه كه باعث ميشه وقتي قالب رو عوض ميكنيم از روي كش قبلي صفحات كار كنه! باز نميدونم چيه اين به ذهنم رسيد گفتم!!!

به هر حال هنوز مشكل پا برجاست و اين چيزارو هم جديد كشف كرده بودم گفتم :)

ویرایش شده در توسط Morteza
0

به اشتراک گذاری این پست


لینک به پست

یوزر پسورد ادمین سایتت رو بده چک کنم ، البته اگه تمایل داری!

0

به اشتراک گذاری این پست


لینک به پست

آیا افزونه‌ دیگری را هم تست کردید؟

مانند wp-pagenavi

2

به اشتراک گذاری این پست


لینک به پست

سلام

1- روی پوسته های دیگه همین مشکل رو دارید؟

2- محتویات پوشه wp-content چه فایلها و پوشه هایی هستن؟

0

به اشتراک گذاری این پست


لینک به پست

آیا افزونه‌ دیگری را هم تست کردید؟

مانند wp-pagenavi

سلام... اره تست كردم همين مشكل رو داشتيم

سلام

1- روی پوسته های دیگه همین مشکل رو دارید؟

2- محتویات پوشه wp-content چه فایلها و پوشه هایی هستن؟

نه روي پوسته هاي ديگه مشكلي نداريم ! البته تو يكي از پست هاي همين بالا كامل توضيح دادم كه چطوري درست ميشه وقتي پوسه هارو يه بار عوض ميكنيم..

توي اون فولدر هم همونايي هستند كه بايد باشن ديگه! اگر ميخوايد يوزر بدم

0

به اشتراک گذاری این پست


لینک به پست

خوب پس مشکل از پوسته هست.

اما سوال:

شما در پوسته تئون از query_)posts یا WP_Query استفاده کردید؟

پ.ن:

فعلا تا جاییکه بشه سعی میکنیم با هم مشکل رو حل کنیم. نهایتا نشد آنلاین سایت شما رو بررسی میکنیم.

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

اره فكر كنم از پوسته باشه ولي اين پوسته يه ورژن اورجينالم داره كه اونم كار نكرد!! قاطي داره اصلا حتي يادمه ابزاركش از كار افتاده بود و اون كدي كه توي قالب باعث نشون دادن ابزارك ميشد رو با Np++ و پلاگين Compair يا همون مقايسه ، برسي كردم با ورژن اصلي ديدم هيچ فرقي نداره ولي ارور ميده در كل يه بار ديگه كدش رو كپي كردم درست شد!!! الانم اين شكلي شده

درباره سوالي كه كرديد چيزي سر در نميارم ولي كوئري و.. زياد هست تو قالب.

نئون چي هست!!؟

ویرایش شده در توسط rasivell
0

به اشتراک گذاری این پست


لینک به پست

اگر صفحه بندی کار میکنه اولین و مهمترین علت میتونه ریست نشدن یکی از کوئرهای پست باشه.

شما باید بررسی کنید که هرجا کوئری باز شده در انتهای حلقه تابع wp_reset_query وجود داره یا خیر.

همچنین برای کوئریهای حلقه پست و قبل صفحه بندی ها باید چک کنید که خاصیت paged به کوئری اضافه شده یا خیر.

0

به اشتراک گذاری این پست


لینک به پست

سلام... اقا مرتضي نگاه كردم تا حدودي چون دقيقا نميدونم كدوم فايل هارو بايد مشاهده كنم و نگاهم كردم اونايي كه ميدونستم ! مثلا قالب صفحات و صفحه اصلي ! و برگه محصولات.. چيزي به نام ريست كوئري نديدم و همچنين خاصيت Paged

قالبمون كمي پيچيده است!! اگر قالب سايت اصلي بود اون رو خودم درستش كردم ميتونستم اوكي كنمش ولي اين قالب فروشگاه فوق العاده زياد فانگشن و كوئري داره كه من زياد سر در نميارم ازشون ! PHP زياد بلد نيستم. بايد زحمت بكشيد يه نگاه بندازيد كه يه موقع خودم از ايني كه هست خرابترش نكنم! :(

0

به اشتراک گذاری این پست


لینک به پست

کدهای سایت شما رو بررسی کردم.

خیلی بد کدنویسی شده.

تعریف custom post type در پوسته شما خیلی نامنظم و غیراستاندارد هست و جای تعجب نیست که خیلی چیزها درست کار نکنه.

تعریف کوئری هم خیلی تعریفی نداره.

انگار برای وردپرس نسخه 2 کدنویس شده.

بهتره نحوه custom post type عوض بشه و همچنین کوئری های پوسته مخصوصا در ایندکس درست تعریف بشه.

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

متشكرم.. خب با اين اوضاع چه بايد كرد؟؟؟ چيكار كنيم حالا؟ :unsure:

ویرایش شده در توسط rasivell
0

به اشتراک گذاری این پست


لینک به پست

یا اینکه پوسته رو کلا عوض کنید.

یا اینکه بخش تعریف custom post type و کوئری رو دوباره بنویسید.

0

به اشتراک گذاری این پست


لینک به پست

خب نميشه عوض كرد كه !!! ما روي اين كلي كار كرديم و اون كاري كه شما ميگيد رو هم از دستمون بر نمياد! ولي باز بگيد دقيقا كدوم فايله كدوم فايل ها بايد از دوباره باز نويسي بشن شايد تونستيم كاري كنيم.. متشكرم.

مساله اينه كه چرا تا 10 روز پيش اين مشكل نبود و يك دفعه اين قالب متوجه شده مشكل داره و شماره صفحات از كار افتاده!!!

0

به اشتراک گذاری این پست


لینک به پست

همونطور که بالاتر هم گفتم یکی از علت ها میتونه این باشه.

100% نمیشه گفت. شاید جای دیگه ایی از خود وردپرس مشکل ایجاد کنه ولی در حالت کلی با این کدها روی وردپرس نباید مشکل پیش بیاد.

مثلا روی یک وردپرس تابع wp_query جواب نمیداد ولی تابع query_posts جواب میداد!

برای رفع مشکل هم فایل post-type رو ریکد کنید. امیدوارم مشکل حل بشه.

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

متشكرم... راستي روي لوكال هاست مثل ساعت كار ميكنه چرا؟؟؟؟ همين قالب روي لوكال هاست خوب جواب ميده و هيچ مشكلي نداره اصلا!

يه مشكلي هم هست!!! ديگه شماره صفحات از ديروز رفته و نيست!!!! كدش سرجاشه و پلاگين هم فعاله ولي ديگه اون شماره صفحات نيستش زير سايت!

تا ديروز بود ولي الان هر كاري ميكنيم نمياد!!!

درضمن اين پوسته به صورت كامل توي لوكال هاست داره كار ميكنه و صفحاتشم درسته فقط تو هاست اصلي خرابه!!

پوسته رو بازيابي كردم اون شماره ها برگشت ولي خب مشكل پا برجاست ولي تو لوكال خوب خوب كار ميكنه!!

ویرایش شده در توسط Morteza
0

به اشتراک گذاری این پست


لینک به پست

متشكرم... راستي روي لوكال هاست مثل ساعت كار ميكنه چرا؟؟؟

خب مشکل شما کاملا مشخص شد

مدیر سرور کانفینگ خاصی انجام داده و باعث از کار افتادن اون افزونه شده

0

به اشتراک گذاری این پست


لینک به پست

سلام! خسته نباشيد عرض ميكنم...

ساعت يه اصتلاحه... براي بيان كاركرد درست

باعث خوشحاليه كه مشكل كشف شده ولي خب بايد بگم با مدير هاست صحبت كردم و گفتن كه ما هيچ تغيري نداديم رو سرور و اگر قرار بود كه بدن بايد سايت اصلي هم كه از اين افزونه استفاده ميكنه از كار ميوفتاد چون فروشگاه تو يه پوشه تو همون هاسته و اينكه چرا روي پوسته ديگه كار ميكنه!!

0

به اشتراک گذاری این پست


لینک به پست

جالبه!

کدها همه درست هستن اما پوسته شما نمیخواد نشون بده!

فقط برای صفحه بندی چند مدل کد رو تست کردم اما جواب نمیده....

تجربه جالبی بود ;)

0

به اشتراک گذاری این پست


لینک به پست

اره واقعا! ميبينيد شما كه استاديد، با يه نمونه نادر برخورد كرديد. ببينيد ما چي كشيديم تو اين 10 روز!!

واقعا اگر مشخص بشه مشكلش جدا يه تجربه خواهد بود! تو لوكال خوب جواب ميده ها ولي نميدونم چش شده! حتي تو يه فولدر ديگه تو هاست يه بار ديگه وردپرس نصب كردم قالب رو روش سوار كردم ديدم نه بابا رو اونم مشكل داره! اين كارو براي اين كردم گه گفتم شايد مشكل از ديتابيس باشه!! ديگه هر فكري به ذهنم ميرسيد تست كردم! فقط يه مساله هست اونم اينه كه وقتي مياي قالب پيش فرض رو فعال ميكني بعد 18 تا مطلب تستي ارسال ميكني كه باعث بشه صفحه دومش بياد و بعد يه بار ميري تو صفحه دوم و بعدش قالب رو دوباره بر ميگردوني به قالب خودت ،‌ براي يه لحظه ميره صفحه دوم ولي باز اون مطالب پيش فرض رو كه پاك ميكني همه چي بهم ميريزه!

يا مثلا پوسته 404 رو پاك ميكنم راحت صفحه 2 رو باز ميكنه ولي تو عنوان صفحه ميزنه كه : پيدا نشد404

:blink:

0

به اشتراک گذاری این پست


لینک به پست

مشکل حل شد.

2 تغییر کوچیک و خیلی پیش پا افتاده نیاز داشت!

1 : در بخش خواندن تعداد نوشته ها رو برابر 1 میبایست باشه.

2 : در کوئری تعداد نوشته ها در صفحه رو برابر 18 (تعداد پست موردنظرشما) میباست باشه.

2

به اشتراک گذاری این پست


لینک به پست

ايول.. ماشاالله.. احسنت داريد :wub:

1- متشكرم واقعا ممنونم ، يعني شما توي پنل گفتي 1 باشه ولي تو پوسته گفتيد 18 درسته؟

2- دقيقا تو خود قالب درسته؟؟

===

واقعا واقعا دستتون درد نكنه ، اعتماد به نفس رو از دست داده بوديم 10 روزه واقعا سرد شده بوديم! نميدونم چطور تشكر كنم

يه سوال كوچيكم دارم. الان پيوند يكتامون رو پيش فرضه ، ميتونم عوضش كنم؟؟ راستشو بخوايد ديگه ميترسم دست بزنم :unsure:

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط nnmmss
      سلام
      من كاملا در وردپرس تازه كار هستم. سايتي با پوسته RealNews طراحي شده. منوهايي دارم كه داراي منو و زير منو هستند. وقتي يك نوشته را به زير منو اختصاص ميدم بعد روي منو ميروم كليه نوشته هاي زير منو را هم نشان ميدهد. مثلا من به اين صورت است
      منو1
      زيرمنو 1-1
      زير منو1-2
       
      من اگر روي زير منو 1-1 كليك كنم فقط نوشته هاي زير منو 1-1 را نشان ميده ولي وقتي روي منو1 كليك كنم تمام نوشته هاي منو1   ,    زيرمنو1-1 و زيرمنو1-2 را نشان ميدهد. چطور ميتوانم اين موضوع را تصحيح كنم كه با كليك كردن روي منو1 فقط نوشته مربوط به منو1 را نشان دهد
    • توسط rendesharif
      با سلام 
      24 ساعت پیش در حال آپدیت تب های وبسایت بودم که اینترنت قطع شد و هنگامی که سعی کردم دوباره وارد کنترل پنل بشم دیدم صفحات ساختار خودشون رو از دست دادن و به نحوی بصورت لایت بارگزاری میشن برای حل این مشکل چیکار میتونم بکنم آیا راه حلی هست.
      تصویر قسمت لاگین هم اضافه کردم میتونید ببینید که دیگه خبری از ساختار اصلی نیست در مابقی صفحات کنترل پنل هم به همین شکل هست

    • توسط naff
      سلام.
      من  میخوام یه صفحه ی استاتیک رو روی ftp  آپلود کنم به عنوان  index اصلی و بعد از کلیک روی دکمه ی مورد نظر کاربر منتقل بشه به سایت اصلی یا همون قالب وردپرس.
       مشکل اینجاست که وقتی صفحه ی  html  رو روی  ftp  آپلود میکنم سایت فقط این صفحه رو به عنوان  index  میشناسه و  این رو جایگزین  index وردپرس میکنه و این صفحه  رو  front page  میشناسه.
       در صورتی که من هر دوتاش رو  میخوام . و صفحه ی html  رو به عنوان  index  میخوام یعنی با وارد کردن اسم سایت اسن صفحه ظاهر بشه.
      صفحه ی اچ دی ام ال:
      https://altourneur.com/new.html
       صفحه ی اصلی سایت:
      https://altourneur.com

       
    • توسط Streetlife
      سلام کارشناسان عزیز و محترم
      دوستان چند روزه هرچی میگردم هیچ چیز مناسبی رو پیدا نمیکنم لطفا کمک بفرمایید.من یک طراح ورد پرسم و میخام واسه یک سایت که بلاگ وردپرس و فروشگاه پرستا شاپ هستش به صورت پاپ اپ یک نظرسنجی رو طراحی کنم که یه سوالی بپرسه و جواب رو بازدیدکننده ها تایپ کنن اما به این صورت که لایو سرچ باشه این فیلد یعنی از بین محصولات که روی دیتا بیس هستند با تایپ یک یا چند حرف ساجست بده لطفااااااااااا راهنمایی بفرمایید
    • توسط amirhosseinganjeh
      سلام دوستان نمیدونم چیکار کردم که عنوان صفحه رو نمایش میده توی همه صفحه ها
      این قسمت ابی رنگو توی عکس اول رو میگم

      تونستم توی صفحاتی که ویرایشگرشون بازه، نمایش عنوان صفحه رو خاموش کنم ولی توی صفحه فروشگاهم نمیتونم نمایشش رو خاموش کنم
       خاموشش هم میکنم باز هم نمایش میده(عکس دوم)
      اگه راه حلی دارید بفرمایید لطفا..