farzadwin7

کار نکردن pagenavi

30 پست در این موضوع قرار دارد

من هر کاری میکنم افزونه pagenavi کار نمیکنه . با هر کدی گذاشتم توی قالب کار نکرد .

هم با کد


<div class="wp-pagenavi">
<div id="wp_page_numbers">
<ul>
<li class="active_page"><!--?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?--></li>
</ul>
</div>
</div>

هم با کد


<?php wp_pagenavi(); ?>

اسم قالب Rasputin

هم توی homepage.php گذاشتم هم توی index.php

چکار کنم ؟

0

به اشتراک گذاری این پست


لینک به پست

این کد رو امتحان کنید:

<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>

5

به اشتراک گذاری این پست


لینک به پست

این کد رو امتحان کنید:

<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>

اینم نشد .

عجیبه هیچ اروری هم نمیده

0

به اشتراک گذاری این پست


لینک به پست

اینم نشد .

عجیبه هیچ اروری هم نمیده

کد رو بذارید توی قالب و لینک سایتتون رو بدید

3

به اشتراک گذاری این پست


لینک به پست

کد رو تو کدم فایل از قالب استفاده می کنید؟

2

به اشتراک گذاری این پست


لینک به پست

هم توی index.php گذاشتم هم توی homepage.php

کد رو میزاری وقتی از سایت سورس میگیری کد توی سورس سایت نیست برای اینکه نشون بدم کد رو کجا گذاشتم کنار کد یه * هم گذاشتم که ببینید کجای قالب لود شده .


آدرس :
******. com

0

به اشتراک گذاری این پست


لینک به پست

الان شما چندتا پست دارید که میخواید شماره صفحه بیاد برای صفحه 2 !؟

توی تنظیمات همگانی و بیشترین تعداد نوشته‌ها در هر برگه‌ی وبلاگ چه عددی وارد کردید

5

به اشتراک گذاری این پست


لینک به پست

برای هر صفحه تعداد 4 تا رو وارد کردم

سایت هم 12 تا پست داره

ویرایش شده در توسط farzadwin7
0

به اشتراک گذاری این پست


لینک به پست

در اون بخش از کوئری استفاده کردید؟

4

به اشتراک گذاری این پست


لینک به پست

در اون بخش از کوئری استفاده کردید؟

نمیدونم استفاده شده یا نه ...

یکی از دوستام یه تغییراتی ایجاد کرد افزونه لود میشه ولی وردپرس صفحات بعدی رو نمیسازه .

من 12 تا پست زدم توی هر صفحه هم گذاشتم که 4 تا پست باشه 4 تا پست اخر روی میاره ولی صفحات 2 و 3 رو نمیسازه .

0

به اشتراک گذاری این پست


لینک به پست

شاید پلاگین دیگه ای استفاده کردین که با این یکی تداخل داره. یا شاید توابع استاندارد سازی پوسته دستکاری شده.

2

به اشتراک گذاری این پست


لینک به پست

نه از افزونه دیگه ای استفاده نکردم

وردپرس صفحات بعدی رو نمیسازه .

0

به اشتراک گذاری این پست


لینک به پست

دوستان کسی هست با هزینه مشگل رو حل کنه ؟

فکر کنم پاسخ گو نستید .

0

به اشتراک گذاری این پست


لینک به پست

دوستان کسی هست با هزینه مشگل رو حل کنه ؟

فکر کنم پاسخ گو نستید .

شما تنظیمات افزونه رو چک کردید؟

میتونه مشکل از تنظیمات افزونه باشه.

3

به اشتراک گذاری این پست


لینک به پست

کد رو داخل شرط میزارید یا بیرون اون ؟

اگر امکان داره فایلی که دستور رو بهش اضافه میکنید رو اینجا قرار بدید.(فایل رو فشرده کنید)

3

به اشتراک گذاری این پست


لینک به پست

کد رو داخل شرط میزارید یا بیرون اون ؟

اگر امکان داره فایلی که دستور رو بهش اضافه میکنید رو اینجا قرار بدید.(فایل رو فشرده کنید)


<?php
get_header(); ?>

<?php get_template_part( 'slide', 'index' ); ?>
<div class="clear"></div>

<div class="intro grid_8">
<h2><?php echo of_get_option('w2f_intro_title','The intro title goes here');?></h2>
<p><?php echo of_get_option('w2f_intro_text','The intro text goes here');?></p>
</div>

<div class="clear"></div>
<div id="primary" class="content-area container_6">

<div id="article-area" class="cf ">


<div class="article-list">
<?php
$count = of_get_option('w2f_blog_number','8');
$args = array( 'numberposts' =>$count );
$lastposts = get_posts( $args );
foreach($lastposts as $post) : setup_postdata($post); ?>

<div class="article-box grid_2">

<?php
$thumb = get_post_thumbnail_id();
$img_url = wp_get_attachment_url( $thumb,'full' ); //get full URL to image (use "large" or "medium" if the images too big)
$image = aq_resize( $img_url, 220, 170, true ); //resize & crop the image
?>


<?php if($image) : ?> <a class="sqimg" href="<?php the_permalink(); ?>"><img class="grey-img" src="<?php echo $image ?>"/></a> <?php endif; ?>

<div class="post-hover">
<h2><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h2>
<?php print_excerpt(100); ?>

</div>

</div>

<?php endforeach; ?>
</div>

</div>
</div><!-- #primary .content-area -->
*
<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>
<?php get_footer(); ?>

افزونه لود میشه ولی صفحات بعدی رو نمیسازه

0

به اشتراک گذاری این پست


لینک به پست

خب بگید ما هم یاد بگیریم. :D

1

به اشتراک گذاری این پست


لینک به پست

خب بگید ما هم یاد بگیریم. :D

مشکل از حلقه قالب برگشون بود.

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

مشکل از حلقه قالب برگشون بود.

سلام - ببخشید تاپیک قدیمی رو بروز میکنم.

من وقتی از کوئری ساده زیر استفاده میکنم، این افزونه جواب میده.


<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
...
<?php endwhile; endif; ?>

این کوئری رو چطور شخصی سازی کنم؟ مثلاً محدودش کنم به دسته ای خاص! (فقط مطالب دسته 5 رو نشون بده مثلاً)

این کد جواب نمیده:


<?php $recent = new WP_Query("cat=5"); while($recent->have_posts()) : $recent->the_post();?>
...
<?php endwhile; ?>

ممنون

ویرایش شده در توسط Light Moon
0

به اشتراک گذاری این پست


لینک به پست

کد دوم درست هست باید جواب بده

قبل از کویری ریست کنید با تابع wp_reset_query

با :


query_posts("cat=10");

برای کد اول میشود

قبل از حلقه درج شود

2

به اشتراک گذاری این پست


لینک به پست

ممنون

کد اول هم لینک شمارنده ها فعال هستند و هم اینکه با کلیک روی هر شماره، مطالب عوض میشه. با اضافه کردن query_posts("cat=10") مطالب توی فیلتر دسته قرار گرفت. اما مثل کد دوم شد!

در کد دوم با کلیک روی شماره های pagenavi آدرس صفحه تغییر میکنه و پیج بعدی رو میاره. اما مطالب عوض نمیشن.

*ریست کوئری هم زدم .

این کد بیچاره من که کامل کار نمیکنه


<?php $light = new WP_Query( "cat=5" );while ( $light->have_posts() ) : $light->the_post(); ?>
....
<?php endwhile;?>
<?php if (function_exists('wp_pagenavi')){wp_pagenavi( array( 'query' => $light ) );}?>

0

به اشتراک گذاری این پست


لینک به پست

یه نمونه:


<?php
$paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
query_posts(array('cat'=> '10', 'paged' => $paged));
while (have_posts()):the_post();?>
<a target="_blank" title="<?php the_title(); ?>" href="<?php the_permalink(); ?>">
<?php the_title(); ?>
</a>
<?php endwhile; ?>
<div id="pagenavi">
<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); }?>
</div>
<?php wp_reset_query(); ?>

این حالت کوئری برای شماره صفحات جواب میده.

به جای wp-query از query_posts استفاده کنید.

3

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

من هر کاری میکنم افزونه pagenavi کار نمیکنه . با هر کدی گذاشتم توی قالب کار نکرد .

هم با کد


<div class="wp-pagenavi">
<div id="wp_page_numbers">
<ul>
<li class="active_page"><!--?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?--></li>
</ul>
</div>
</div>

هم با کد


<?php wp_pagenavi(); ?>

اسم قالب Rasputin

هم توی homepage.php گذاشتم هم توی index.php

چکار کنم ؟

مشکل از حلقه قالب برگشون بود.

دوستان من هم همين مشكل رو دارم

اين كد رو داخل index.php قالب ميزارم

<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>

صفحات رو نشون ميده اما وقتي رو صفحه دوم كليك مي كنم همون صفحه اول رو نشون ميده در واقع عمل نميكنهكه بره صفحه ي دوم يا صفحه هاي بعدي...

مشكل از كجاست بنظرتون ؟

اشكان عزيز گفتند مشكل از حلقه برگشت قالب هستش اما من متوجه نشدم كجاست و چجوري رفع ميشه.

پ.ن: چون دوستان درمورد اين افزونه بحث مي كردند ديگه گفتم تايپيك جديدي ايجاد نكنم

ويرايش: صفحه هاي قسمت موضوعات سايت بخوبي كار ميكنه و به صفحه بعدي ميره ، اما صفحه اصلي همچنان مشكل داره!

مرسي

درست شد مرسي، يك اشتباه ساده كردم تيك يك قسمت رو نزده بودم!!

ویرایش شده در توسط HTM
1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط masoudmosleh267
      سلام دوستان. من یه سایتی رو از بکاپ گرفتم و از یه هاست و دامنه به یه هاست و دامنه جدید انتقال دادم. حالا چه سایت رو که باز میکنم چه وارد پیشخوان وردپرس میشم یه ارور میاد یکی از خطلی functions.php قالب رو نشون میده.
      Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /public_html/wp-content/themes/khadamator/functions.php on line 1132
      مشکل چیه؟
    • توسط amirsa
      سلام
      من محصولات متغیر رو در ووکامرس که وارد میکنم،(محصول ممکنه 2 یا 3 صفت داره که باید انتخاب بشه)
       توی فروشگاه ووکامرس بصورت حد اقل و حداکثر قیمت ها نشون داده میشه
      مثلا کالا دونوع 10 و  20 تومانی هست.صفت آ 15 تومن برای مشتری هایی که بخوان.تو فروشگاه قیمت رو بصورت 10-35 نشون میده که بیشتر از قیمت اصلی است.من میخوام همون 10 و 20 رو نشون بده
      این مشکل انرژی زیادی ازم گرفته ممنون میشم راهنماییم کنید 
    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط صالح طالبی
      باسلام خدمت شما عزیزان
      بنده این تکه کد رو که در اصل افزونه نمایش آخرین های انجمن بود برای وردپرس به صورت کد در خود فانکشن قالب دراوردم:
      function ipslatest_main($query) { if ( is_home() && $query->is_main_query() ) { $db_user = 'root'; $db_name = 'ipsdb'; $db_pass = ''; $db_host = 'localhost'; $prefix = get_option('ipslatest_db_prefix'); $url = 'http://localhost/IPS'; $limit = '5'; $title = ''; $width = '300'; $direction = 'rtl'; $translations = array('عنوان','بازدید','پاسخ ها','ارسال شده به وسیله'); $db = new wpdb( $db_user, $db_pass, $db_name,$db_host ); $q = $db->get_results( 'SELECT topic_id,author_name FROM '.$prefix.'forums_posts ORDER BY pid DESC LIMIT '.$limit ); echo '<div id="ipslatest-mainTitle" style="width:'.$width.'">'.$title.$position.'</div>'; echo '<table id="ipslatestTopics" border=0 style="padding:10px;width:'.$width.'">'; echo '<tr><td class="ipslatest-row-views">'.$translations[2].'</td><td class="ipslatest-row-answers">'.$translations[1].'</td><td class="ipslatest-row-sender">'.$translations[3].'</td><td class="ipslatest-row-title">'.$translations[0].'</td> </tr>'; if (is_array($q) || is_object($q)) { foreach ($q as $key => $row) { $topicDetails = $db->get_row('SELECT title,tid,views,posts FROM '.$prefix.'forums_topics WHERE tid='.$row->topic_id); $userMemberID = $db->get_row('SELECT member_group_id FROM '.$prefix."core_members WHERE name='".$row->author_name."'"); $userShowingData = $db->get_row('SELECT prefix,suffix FROM core_groups WHERE g_id='.$userMemberID->member_group_id); echo '<tr id="ipstopic"> <td class="ipslatest-row-views-content"> <span>'.$topicDetails->views.' </span></td> <td class="ipslatest-row-answers-content"><span>'.$topicDetails->posts.'</span></td> <td id="ipslatest-row-sender-content">'.$userShowingData->prefix.$row->author_name.$userShowingData->suffix.'</td> <td class="ipsTitle"> <a rel="follow" href="'.$url.'topic/'.$topicDetails->tid.'-'.strtolower(str_replace(" ","-",$topicDetails->title)).'">'. strip_tags($topicDetails->title) .' </a> </td> </tr>'; } /*}*/ } echo '</table>'; } } به صورت خودکار خود افزونه از کد زیر برای نمایش اون در اول پست های سایت و یا در آخر پست های سایت استفاده میکنه کد ها هم به این شکله:
      add_action( 'wp', 'ipslatestMain' ); function ipslatestMain( $query ) { $position = "bottom"; if($position === "bottom") $acton = "loop_end"; elseif ($position === "top") $acton = "loop_start"; add_action($acton,"ipslatest_main"); } الان بدون هیچ مشکلی نمایش میده در پایین پست ها ولی من میخام این نمایش رو در یه قسمت دیگه از قالب انجام بدم و چجوری میتونم این فانکشن و تابع رو نمایش بدم؟؟؟
      نام افزونه هم در ضمن ipsuite-latest-topics هست و من از حالت افزونه فقط خارجش کردم و در خود قالب و فانکشن اون اوکی کردم.
      فقط مشکل اینه که نمیخام در بالای پست یا پایین پست ها نمایش بدم و میخام در جایی که خودم تعیین میکنم تابع رو نمایش بدم؟!!!
      ممنون میشم راهنمایی بفرمایید.
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟