farzadwin7

کار نکردن pagenavi

30 پست در این موضوع قرار دارد

من هر کاری میکنم افزونه pagenavi کار نمیکنه . با هر کدی گذاشتم توی قالب کار نکرد .

هم با کد


<div class="wp-pagenavi">
<div id="wp_page_numbers">
<ul>
<li class="active_page"><!--?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?--></li>
</ul>
</div>
</div>

هم با کد


<?php wp_pagenavi(); ?>

اسم قالب Rasputin

هم توی homepage.php گذاشتم هم توی index.php

چکار کنم ؟

به اشتراک گذاری این پست


لینک به پست

این کد رو امتحان کنید:

<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>

به اشتراک گذاری این پست


لینک به پست

اینم نشد .

عجیبه هیچ اروری هم نمیده

کد رو بذارید توی قالب و لینک سایتتون رو بدید

به اشتراک گذاری این پست


لینک به پست

کد رو تو کدم فایل از قالب استفاده می کنید؟

به اشتراک گذاری این پست


لینک به پست

هم توی index.php گذاشتم هم توی homepage.php

کد رو میزاری وقتی از سایت سورس میگیری کد توی سورس سایت نیست برای اینکه نشون بدم کد رو کجا گذاشتم کنار کد یه * هم گذاشتم که ببینید کجای قالب لود شده .


آدرس :
******. com

به اشتراک گذاری این پست


لینک به پست

الان شما چندتا پست دارید که میخواید شماره صفحه بیاد برای صفحه 2 !؟

توی تنظیمات همگانی و بیشترین تعداد نوشته‌ها در هر برگه‌ی وبلاگ چه عددی وارد کردید

به اشتراک گذاری این پست


لینک به پست

در اون بخش از کوئری استفاده کردید؟

به اشتراک گذاری این پست


لینک به پست

در اون بخش از کوئری استفاده کردید؟

نمیدونم استفاده شده یا نه ...

یکی از دوستام یه تغییراتی ایجاد کرد افزونه لود میشه ولی وردپرس صفحات بعدی رو نمیسازه .

من 12 تا پست زدم توی هر صفحه هم گذاشتم که 4 تا پست باشه 4 تا پست اخر روی میاره ولی صفحات 2 و 3 رو نمیسازه .

به اشتراک گذاری این پست


لینک به پست

شاید پلاگین دیگه ای استفاده کردین که با این یکی تداخل داره. یا شاید توابع استاندارد سازی پوسته دستکاری شده.

به اشتراک گذاری این پست


لینک به پست

دوستان کسی هست با هزینه مشگل رو حل کنه ؟

فکر کنم پاسخ گو نستید .

شما تنظیمات افزونه رو چک کردید؟

میتونه مشکل از تنظیمات افزونه باشه.

به اشتراک گذاری این پست


لینک به پست

کد رو داخل شرط میزارید یا بیرون اون ؟

اگر امکان داره فایلی که دستور رو بهش اضافه میکنید رو اینجا قرار بدید.(فایل رو فشرده کنید)

به اشتراک گذاری این پست


لینک به پست

کد رو داخل شرط میزارید یا بیرون اون ؟

اگر امکان داره فایلی که دستور رو بهش اضافه میکنید رو اینجا قرار بدید.(فایل رو فشرده کنید)


<?php
get_header(); ?>

<?php get_template_part( 'slide', 'index' ); ?>
<div class="clear"></div>

<div class="intro grid_8">
<h2><?php echo of_get_option('w2f_intro_title','The intro title goes here');?></h2>
<p><?php echo of_get_option('w2f_intro_text','The intro text goes here');?></p>
</div>

<div class="clear"></div>
<div id="primary" class="content-area container_6">

<div id="article-area" class="cf ">


<div class="article-list">
<?php
$count = of_get_option('w2f_blog_number','8');
$args = array( 'numberposts' =>$count );
$lastposts = get_posts( $args );
foreach($lastposts as $post) : setup_postdata($post); ?>

<div class="article-box grid_2">

<?php
$thumb = get_post_thumbnail_id();
$img_url = wp_get_attachment_url( $thumb,'full' ); //get full URL to image (use "large" or "medium" if the images too big)
$image = aq_resize( $img_url, 220, 170, true ); //resize & crop the image
?>


<?php if($image) : ?> <a class="sqimg" href="<?php the_permalink(); ?>"><img class="grey-img" src="<?php echo $image ?>"/></a> <?php endif; ?>

<div class="post-hover">
<h2><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h2>
<?php print_excerpt(100); ?>

</div>

</div>

<?php endforeach; ?>
</div>

</div>
</div><!-- #primary .content-area -->
*
<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>
<?php get_footer(); ?>

افزونه لود میشه ولی صفحات بعدی رو نمیسازه

به اشتراک گذاری این پست


لینک به پست

خب بگید ما هم یاد بگیریم. :D

مشکل از حلقه قالب برگشون بود.

به اشتراک گذاری این پست


لینک به پست

مشکل از حلقه قالب برگشون بود.

سلام - ببخشید تاپیک قدیمی رو بروز میکنم.

من وقتی از کوئری ساده زیر استفاده میکنم، این افزونه جواب میده.


<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
...
<?php endwhile; endif; ?>

این کوئری رو چطور شخصی سازی کنم؟ مثلاً محدودش کنم به دسته ای خاص! (فقط مطالب دسته 5 رو نشون بده مثلاً)

این کد جواب نمیده:


<?php $recent = new WP_Query("cat=5"); while($recent->have_posts()) : $recent->the_post();?>
...
<?php endwhile; ?>

ممنون

ویرایش شده در توسط Light Moon

به اشتراک گذاری این پست


لینک به پست

کد دوم درست هست باید جواب بده

قبل از کویری ریست کنید با تابع wp_reset_query

با :


query_posts("cat=10");

برای کد اول میشود

قبل از حلقه درج شود

به اشتراک گذاری این پست


لینک به پست

ممنون

کد اول هم لینک شمارنده ها فعال هستند و هم اینکه با کلیک روی هر شماره، مطالب عوض میشه. با اضافه کردن query_posts("cat=10") مطالب توی فیلتر دسته قرار گرفت. اما مثل کد دوم شد!

در کد دوم با کلیک روی شماره های pagenavi آدرس صفحه تغییر میکنه و پیج بعدی رو میاره. اما مطالب عوض نمیشن.

*ریست کوئری هم زدم .

این کد بیچاره من که کامل کار نمیکنه


<?php $light = new WP_Query( "cat=5" );while ( $light->have_posts() ) : $light->the_post(); ?>
....
<?php endwhile;?>
<?php if (function_exists('wp_pagenavi')){wp_pagenavi( array( 'query' => $light ) );}?>

به اشتراک گذاری این پست


لینک به پست

یه نمونه:


<?php
$paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
query_posts(array('cat'=> '10', 'paged' => $paged));
while (have_posts()):the_post();?>
<a target="_blank" title="<?php the_title(); ?>" href="<?php the_permalink(); ?>">
<?php the_title(); ?>
</a>
<?php endwhile; ?>
<div id="pagenavi">
<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); }?>
</div>
<?php wp_reset_query(); ?>

این حالت کوئری برای شماره صفحات جواب میده.

به جای wp-query از query_posts استفاده کنید.

به اشتراک گذاری این پست


لینک به پست

من هر کاری میکنم افزونه pagenavi کار نمیکنه . با هر کدی گذاشتم توی قالب کار نکرد .

هم با کد


<div class="wp-pagenavi">
<div id="wp_page_numbers">
<ul>
<li class="active_page"><!--?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?--></li>
</ul>
</div>
</div>

هم با کد


<?php wp_pagenavi(); ?>

اسم قالب Rasputin

هم توی homepage.php گذاشتم هم توی index.php

چکار کنم ؟

مشکل از حلقه قالب برگشون بود.

دوستان من هم همين مشكل رو دارم

اين كد رو داخل index.php قالب ميزارم

<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>

صفحات رو نشون ميده اما وقتي رو صفحه دوم كليك مي كنم همون صفحه اول رو نشون ميده در واقع عمل نميكنهكه بره صفحه ي دوم يا صفحه هاي بعدي...

مشكل از كجاست بنظرتون ؟

اشكان عزيز گفتند مشكل از حلقه برگشت قالب هستش اما من متوجه نشدم كجاست و چجوري رفع ميشه.

پ.ن: چون دوستان درمورد اين افزونه بحث مي كردند ديگه گفتم تايپيك جديدي ايجاد نكنم

ويرايش: صفحه هاي قسمت موضوعات سايت بخوبي كار ميكنه و به صفحه بعدي ميره ، اما صفحه اصلي همچنان مشكل داره!

مرسي

درست شد مرسي، يك اشتباه ساده كردم تيك يك قسمت رو نزده بودم!!

ویرایش شده در توسط HTM

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط behi13
      با سلام
      دوستام و اساتید محترم یک سوال
      من به سایت دوزبانه با افزونه wpml درست کردم الان یک مشکل هست توی گوگل صفحه اول سایت ایندکس شده و توی فارسی مشکلی ندارم
      ولی توی زبان انگلیسی وقتی توی گوگل به انگلیسی سرچ میکنم بازهم با نام و فارسی میاد
      ممنون میشم من و راهنمایی کنید
    • توسط j1989m
      سلام
      توی قسمت افزودن نوشته و از طریق پرونده های رسانه ای یه عکس انتخاب میکنم و منتشر میکنم. توی سایت عکس رو نشون میده اما این کدها رو هم میاره:
      [caption id="attachment_154" align="aligncenter" width="300"] [/caption]
      درواقع عکس بین دوتا caption بالا قرار میگیره.
      این مشکل توی افزودن برگه نیست.
      لطفا راهنمایی کنید
      خیلی فوریه
      ممنون
    • توسط xboby
      سلام،
      من سایتی با ورد پرس طراحی کردم و می خواهم با:
      یک برنامه تمام پستهای موجود در کانال تلگرامی که بنام آن سایت ایجاد کر ده ام را
      بتوانم از موبایلم دانلود کنم و بعد در آن سایت قرار دهم:
      آیا چنان برنامه ای وجود دارد؟ لطفا راهنمائی ام بفرمائید.
                                   متشکرم
    • توسط دکتر مهندس
      سلام
      من چندتا سایت دارم که همه رو وقتی خواستم به وردپرس 4.7 ارتقا بدم، همگی مشکل دار شدند.
      به این صورت که خود سایت باز میشه اما قسمت مدیریت سایت باز نمیشه و لینکهای بخش مدیریت به این صورت میاد: /wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F
       
      توی صفحه هم که میاد اینطوری مینویسه: 
       
      The www......ir page isn’t working
      www.......ir is currently unable to handle this request.
      HTTP ERROR 500
    • توسط hessam75
      سلام
      من یه سایت با غالب be theme طراحی کردم فقط یه مشکل داره اونم اینه که پس زمینه رو پارالاکس انتخاب کردم ولی تو مرورگر internet xplorer پارالاکس نمایش داده نمیشه!
      در ضمن قالبم هم پول دادم از سایت معتبری خریدم ازین دانلودی ها نیست.
      لطفا کمک کنید بتونم رفع اشکال کنم.
      آدرس سایت : senateb.com