U3F

مشکل برخی کدهای php در <script>

8 پست در این موضوع قرار دارد

سلام.

دوستان من یه مشکل خاص دارم که اگه کمک کنید زودتر حلش کنم ممنونتون میشم.

من از یه ویدیو پلیر دارم استفاده میکنم که برای نمایشش باید از <script> استفاده کرد به این صورت:


<script>
CodoPlayer({
title: "<?php the_title(); ?>",
poster: "<?php echo get_post_meta($post->ID, 'poster', true); ?>",
src: "<?php echo get_post_meta($post->ID, 'mp4', true); ?>",
engine: "auto"
}, {
width: 960,
height: 540,
volume: 80,
preload: false
});
</script>

مشکل اینجاست که تایتل رو نمایش میده اما زمینه ها رو نه و اصلا تو سورس هم نمیاد به جای زمینه لینک رو قرار میدم نمایش میده، چجوری باید این مشکل رو حل کنم ؟

اسراری تو استفاده از زمینه نیست راه دیگه ای هم میدونید معرفی کنید

ممنون

0

به اشتراک گذاری این پست


لینک به پست

به جای


$post->ID

اینو جایگزین کن


get_the_ID

2

به اشتراک گذاری این پست


لینک به پست

جواب نداد، الان کد به این شکل هست


title: "<?php the_title(); ?>",
poster: "<?php get_post_meta(get_the_ID, 'poster', true); ?>",
src: "<?php get_post_meta(get_the_ID, 'mp4', true); ?>",

اما تو سورس خالیه


title: "ویژگی های جدید و بهبود یافته آی او اس 7",
poster: "",
src: "",

0

به اشتراک گذاری این پست


لینک به پست

اینو امتحان کنید ...


title: "<?php the_title(); ?>",
poster: "<?php echo get_post_meta(get_the_ID, 'poster', true); ?>",
src: "<?php echo get_post_meta(get_the_ID, 'mp4', true); ?>",

2

به اشتراک گذاری این پست


لینک به پست

بازم نشد

این کار رو هم کردم


title: "<?php the_title(); ?>",
poster: "<?php bloginfo('template_directory'); ?>/data/<?php echo get_post_meta(get_the_ID, 'poster', true); ?>",
src: "<?php bloginfo('template_directory'); ?>/data/<?php echo get_post_meta(get_the_ID, 'mp4', true); ?>",

تو سورس اینجوری میاد


title: "ویژگی های جدید و بهبود یافته آی او اس 7",
poster: "http://localhost/wordpress/wp-content/themes/MVideo/data/",
src: "http://localhost/wordpress/wp-content/themes/MVideo/data/",

یعنی زمینه رو اصلا نمایش نمیده

ویرایش شده در توسط U3F
0

به اشتراک گذاری این پست


لینک به پست

بجای get_the_ID بایدبزارید get_the_ID() چون تابع هست

1

به اشتراک گذاری این پست


لینک به پست

فرقی نکرد

مرتضی جان اسراری تو استفاده از زمینه دلخواه نیست راه دیگه ای به ذهنت میرسه بگو که بشه تو اون قسمت یه لینک گذاشت که نمایش داده بشه

ویرایش شده در توسط U3F
0

به اشتراک گذاری این پست


لینک به پست

یعنی الان این خروجی نداره؟

<?php echo get_post_meta(get_the_ID(), 'mp4', true); ?>

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری