hajeyan.71

مشکل شکستن خط در عنوان پست ها

10 پست در این موضوع قرار دارد

سلام دوستان

من یک قالب طراحی کردم

ولی وقتی پستی رو قرار میدم و یک عنوان برای پست تعریف میکنم اگر عنوان بیشتر از عرض باشه به خط بعد شکسته نمیشه

اینم عکسش

ممنون میشم راهنماییم کنید

26745738117194689612.png

0

به اشتراک گذاری این پست


لینک به پست

شما عنوانی که برای تست انتخاب کردی پشت سرهم هست و به هم چسبیده و هیچ فضای خالی نداره (space )برای همین شکسته نمیشه

یه عنوان طولانی ولی جمله بندی شده انتخاب کن و تست کن

1

به اشتراک گذاری این پست


لینک به پست

سلام

مثلا اگه متن رو در تگ H1 میذارید بهش عرض مشخص بدید تا از یه عرضی که بیشتر شد شکسته شه به خط بعد مثلا :


h1 {
width:500px;
}

3

به اشتراک گذاری این پست


لینک به پست

با تشکر از دوستانی که راهنمایی کردن ولی متاسفانه درست نشدش

0

به اشتراک گذاری این پست


لینک به پست

یه نمونه براتون درست کردم ... نگاه کنید :

http://codepen.io/fa...asemi/pen/rbtEF

همینطور که در نمونه می بینید هرچقدر هم عنوان طولانی باشه چون عرض مشخصی داره به جای اینکه از کادر بزنه بیرون میشکنه به خط بعد

2

به اشتراک گذاری این پست


لینک به پست

مرسی آقا فرید بابت راهنمایت

ولی فکر کنم یک مشکل اساسی داره نمیدوم شاید تو جایی اشتباهی کردم باید بگردم پیداش کنم

عرض رو هم کم کردم ولی به خط بعد نرفت و نوشته ها روی هم افتادن یعنی وقتی که سطر پر میشه به خط بعد نمیره و دوباره از اول همون سطر شروع میکنه

0

به اشتراک گذاری این پست


لینک به پست

خواهش میکنم //

کدهاتون رو بذارید اینجا تا بررسی کنم

0

به اشتراک گذاری این پست


لینک به پست


<div id="main-content">
<!--start post-title-->
<div class="post-title">
<h1>به نام خدابه نام خدابه نام خدابه نام خدابه نام خدابه-به نام خدابه نام خدابه نام خدا-به نام خدا

</h1>
</div>
<!--end post-title-->

</div>
<!--evd main content-->


#main-content {
float: left;
width: 510px;
height:600px;
}
.post-title {
padding-top:10px;
width:510px;
height:200px;
background: url("images/post-title.gif") no-repeat scroll 0 0 transparent;

}
.post-title h1 {
color: #C6005C;
padding: 18px 15px 2px 12px;
text-shadow: 0 0 1px #9E9E9E;
width:200px;
height:100px;

}

ویرایش شده در توسط hajeyan.71
0

به اشتراک گذاری این پست


لینک به پست

ببینید الان کار میکنه !

http://codepen.io/faridghasemi/pen/cFkwH

احتمالا در قالبتون تحت تاثیر یه کد دیگه هست که براتون کار نمیکنه ... الان نمونه بالا رو نگاه کنید درسته ;)

2

به اشتراک گذاری این پست


لینک به پست

اشکا پیدا کردم

دایو کلی که همه ی دایو ها رو درون اون قرار داده بودم دایرکشن اون رو تعیین نکرده بودم rtl که گذاشتم درست شدش

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری