NWWG

مشکل آدرس دهی افزونه Add From Srever

6 پست در این موضوع قرار دارد

سلام علیکم

ما برای محتوای چند رسانه‌ای یک ساب دامنه ایجاد کردیم: http://dl.sitename.ir

با استفاده از افزونه Add from Server آنها را در کتابخانه وردپرس فراخوانی میکنیم

اما یک مشکل وجود دارد و اینکه همه فایلها را با این آدرس فراخوانی میکند: http://dl.sitename.ir/file.jpg

درحالی که آدرس صحیح به این شکل است: http://dl.sitename.ir/folder/subfolder/file.jpg

راهکار چیست؟

به اشتراک گذاری این پست


لینک به پست

خود افزونه هیچ تنظیم دیگه ای نداره؟

به اشتراک گذاری این پست


لینک به پست

هیچ تنظیم دیگری ندارد! :/

به اشتراک گذاری این پست


لینک به پست

من با این افزونه کار نکردم. چیز زیادی هم ازش نیست نهایت این عکسهاش بود که فکر کنم خودتون دیدید:

http://wordpress.org/plugins/add-from-server/screenshots/

به اشتراک گذاری این پست


لینک به پست

من هاست رو عوض کردم و مشکل بدتر شد قبلا فقط بخشی از آدرس اشتباه بود اما الان وقتی ادد میزنم عکس رو درون پوشه کانتکت پیشفرض وردپرس یکبار دیگه آپلود میکنه، انگار به طور عادی توی وردپرس عکس آپلود کرده باشی!

آیا تنظیم خاصی در هاست دارد؟

مشکل کجاست؟

به اشتراک گذاری این پست


لینک به پست

خروجی این کد رو بدید:

echo __FILE__

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط hiwa
      سلام دوستان
      یک مشکل خاصی 1-2 هفته است من رو بدون گرفتن نتیجه به خودش مشغول کرده (با کلی استرس و اعصاب خوردی). الان به ذهنم رسید که مشکل رو اینجا مطرح کنم شاید کسی بتونه کمکم کنه. حتی اگه هزینه ای مطالبه باهاش واقعا ممنونتون میشم.
      من در یک سایت آگهی (لینک) که از افزونه wp job manager و افزونه های مکمل این افزونه برای ساخت این سایت استفاده کرده ام (قالب listify).
      سایت به خوبی کار میکرد تا اینکه مجبور شدم سایت رو به کمک polylang دو زبانه کنم (توسعه دهنده قالب این افزونه رو توصیه کرده: لینک)
      پس از نصب این افزونه، فایل mo افزونه job manager دیگه لود نمیشه. یعنی بخشهایی از سایت که مربوط به این افزونه است، انگلیسی میشه (این صفحه سایت، وقتی polylang غیرفعال باشه کاملا فارسیه اما وقتی فعال باشه به این صورت نمایش داده میشه یعنی ترکیبی از فارسی و انگلیسی)
      با غیر فعال کردن polylang مشکل رفع میشه
      اما من باید سایت رو دو زبانه کنم. پس مجبورم از polylang استفاده کنم.
      آیا راهی وجود داره که بدون استفاده از فایل po بخشهایی که مربوط به این افزونه job manager هست رو فارسی کنم؟
      ممنون میشم هر راه حل و سرنخی به ذهنت میرسه رو بهم بگید
      زیاد سرچ کردم. بقیه هم این مشکل رو با ترکیب این دو افزونه دارند(لینک) اما راه حلی که واسه من موثر باشه رو پیشنهاد نکرده ان.
       
    • توسط majidted
      سلام  خسته نباشید بسیار ، به مشکلی خوردم و درخواست کمک هر کسی میتونه کمک کنه ، اینم شمارمه 09300151579 درصورت نیاز تماس بگیرید

      مشکل ما اینه که ما وقتی میخوایم داخل فایل htaccess از کد
      RewriteEngine On RewriteCond %{HTTP:X-Forwarded-Proto} !https RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L] استفاده کنیم ، (کدی که اجبار به استفاده از HTTPS ) میکنه این ارور رو میده : the page isn't redirecting properly

       
      اینم فایل htaccess من

      خیلی لطف میکنید اگر کمکم کنید ،
      htaccess.txt
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac
    • توسط 11057
      مشکل در نصب وردپرس روی دایرکت ادمین
      بعد نصب کردن ورد پرس سایت بالا نمیاد،این اخطار رو نشون میده:
       
      Not Found
      The requested URL / was not found on this server.
      Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.