wp-user

مواجه شدن با صفحه ی سفید با فعال کردن یک پوسته خاص

11 پست در این موضوع قرار دارد

با سلام

متاسفانه با مشکلی مواجه شدم که واقعا اعصابمو ریخته به هم!

لطفا اگر کسی میدونه جوابشو بده

من خودم یک قالب درست کردم که در لوکال هاست بدون عیب بود

به دلایلی نتونستم از دیتابیس لوکال هاستم بک آپ رو به هاست انتقال بدم و مجبور شدم وردپرس و افزونه هارو از اول تو هاست نصب کنم

حالا بعد از اون همه سختی و مشقت به محض اینکه پوسته ی خودمو فعال میکنم با مشکل عجیبی روبرو میشم

مثلا وقتی میخوام افزونه ای رو فعال کنم ، با یک صفحه ی خالی و سفید روبرو میشم!

و همینطور برای بیرون رفتن از وردپرس و چند چیز دیگر هم با همین مشکل مواجه میشم که کار به جایی میرسه که وقتی کش و کوکی های مرورگرو پاک میکنم کلا دیگی هیچی نمیاد و حتی وارد وردپرس هم نمیتونم بشم و با همون صفحه ی سفید روبرو میشم

لطفا هر چه زودتر کمکم کنید

من برای قالبم چندماه وقت صرف کردم و الان که اینطوری شده ریختم به هم!

واقعا نمیدونم باید چیکار کنم

لطفا هر کی میدونه بگه چیکار کنم

با تشکر

به اشتراک گذاری این پست


لینک به پست

آدرس آنلاین بدین بررسی کنیم.

به اشتراک گذاری این پست


لینک به پست

اگر آدرس ندم بهتره!

بخاطر برخی از دلایل دارم میگم!

------

اما خود سایت که باز میشه!

فقط تو محیط وردپرس این مشکلات ظاهر میشه!

یعنی شما میتونی رمز کاربریتو وارد کنی ولی دیگه وارد مدیریت وردپرس نمیشی و همونجا صفحه ی سفید میاد

به اشتراک گذاری این پست


لینک به پست

نوع خطاها متفاوته!! امکان داره مشکل از فایل functions باشه. شاید هم تو header یه کد اضافه یا اشتباه استفاده کردین. ولی خب تا سایت رو نمی نم نمی تونم نظر بدم.

به اشتراک گذاری این پست


لینک به پست

بله من هم احساس کردم مشکل از فانکشن باشه

جالبه که وقتی functions رو از قالب بر میدارم همه چی درست میشه!!!

اما مشکل اینه که من نمیدونم مشکل از کجای فانکشن هست!

تو دریم ویور هم هیچ قسمتیو نمیگه مشکل داره!

لطفا اگه میشه کمک کنین

اگر لازمه که فایل فانکشن رو بذارم؟

به اشتراک گذاری این پست


لینک به پست

فانکشن رو بزارید شاید جاییش مشکل داشته باشه.

به اشتراک گذاری این پست


لینک به پست

با سپاس از پیگیریتون :)

من با آزمایش و خطا متوجه شدم که مشکل از تکه کد آخر یعنی این کد است


<?php
function mypo_parse_query_useronly( $wp_query ) {
if ( strpos( $_SERVER[ 'REQUEST_URI' ], '/wp-admin/edit.php' ) !== false ) {
if ( !current_user_can( 'level_10' ) ) {
global $current_user;
$wp_query->set( 'author', $current_user->id );
}
}
}
add_filter('parse_query', 'mypo_parse_query_useronly' );?>

حالا اگر میدونین مشکل این کد چیه خیلی ممنون میشم اگر به مشکلش اشاره کنید :)

ویرایش شده در توسط faver

به اشتراک گذاری این پست


لینک به پست

این فانکشن قابلیت ادیت هر مطلب رو فقط به یک کاربر میده، مشکلی نداره بنظرم

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط behi13
      با سلام
      دوستام و اساتید محترم یک سوال
      من به سایت دوزبانه با افزونه wpml درست کردم الان یک مشکل هست توی گوگل صفحه اول سایت ایندکس شده و توی فارسی مشکلی ندارم
      ولی توی زبان انگلیسی وقتی توی گوگل به انگلیسی سرچ میکنم بازهم با نام و فارسی میاد
      ممنون میشم من و راهنمایی کنید
    • توسط j1989m
      سلام
      توی قسمت افزودن نوشته و از طریق پرونده های رسانه ای یه عکس انتخاب میکنم و منتشر میکنم. توی سایت عکس رو نشون میده اما این کدها رو هم میاره:
      [caption id="attachment_154" align="aligncenter" width="300"] [/caption]
      درواقع عکس بین دوتا caption بالا قرار میگیره.
      این مشکل توی افزودن برگه نیست.
      لطفا راهنمایی کنید
      خیلی فوریه
      ممنون
    • توسط xboby
      سلام،
      من سایتی با ورد پرس طراحی کردم و می خواهم با:
      یک برنامه تمام پستهای موجود در کانال تلگرامی که بنام آن سایت ایجاد کر ده ام را
      بتوانم از موبایلم دانلود کنم و بعد در آن سایت قرار دهم:
      آیا چنان برنامه ای وجود دارد؟ لطفا راهنمائی ام بفرمائید.
                                   متشکرم
    • توسط دکتر مهندس
      سلام
      من چندتا سایت دارم که همه رو وقتی خواستم به وردپرس 4.7 ارتقا بدم، همگی مشکل دار شدند.
      به این صورت که خود سایت باز میشه اما قسمت مدیریت سایت باز نمیشه و لینکهای بخش مدیریت به این صورت میاد: /wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F
       
      توی صفحه هم که میاد اینطوری مینویسه: 
       
      The www......ir page isn’t working
      www.......ir is currently unable to handle this request.
      HTTP ERROR 500
    • توسط hessam75
      سلام
      من یه سایت با غالب be theme طراحی کردم فقط یه مشکل داره اونم اینه که پس زمینه رو پارالاکس انتخاب کردم ولی تو مرورگر internet xplorer پارالاکس نمایش داده نمیشه!
      در ضمن قالبم هم پول دادم از سایت معتبری خریدم ازین دانلودی ها نیست.
      لطفا کمک کنید بتونم رفع اشکال کنم.
      آدرس سایت : senateb.com