ham3d

مشکل لینک ها در وردپرس نصب شده در فولدر

4 پست در این موضوع قرار دارد

سلام دوستان

قضیه اینه که من وردپرسو تو یه فولدر به نام fa نصب کردم. حالا مشکل اینه که توی آدرس تمام لینک هایی که تو صفحم هست وقتی کلیک میکنم fa نشون داده نمیشه.

یعنی مثلا آدرس لینک من اینه: http://domain.com/fa/?page_id=457

اما به این صورت نشون داده میشه: http://domain.com/?page_id=457

در نتیجه هیچ کدوم از لینک ها کار نمیکنه...

با permalinks(پیوند های یکتا)، فایل .htaccess و index.php هم خیلی سرو کله زدم! حدود 20 تا فرومو بالا پایین کردم اما هیچ کدوم از روش های معرفی شده جواب نداد.

الان فعلا فایل .htaccess و index.php هر دو توی فولدری هستن که وردپرسو توش نصب کردم.

محتویات فایل .htaccess الان اینه:


[right]# BEGIN WordPress[/right]


[right]<IfModule mod_rewrite.c>[/right]


[right]RewriteEngine On[/right]


[right]RewriteBase /fa/[/right]


[right]RewriteRule ^index\.php$ - [L][/right]


[right]RewriteCond %{REQUEST_FILENAME} !-f[/right]


[right]RewriteCond %{REQUEST_FILENAME} !-d[/right]


[right]RewriteRule . /fa/index.php [L][/right]


[right]</IfModule>[/right]


[right]# END WordPress[/right]



[/right]

محتویات index.php هم اینه:


[right]<?php[/right]


[right]/**[/right]


[right] * Front to the WordPress application. This file doesn't do anything, but loads[/right]


[right] * wp-blog-header.php which does and tells WordPress to load the theme.[/right]


[right] *[/right]


[right] * @package WordPress[/right]


[right] */[/right]



[right]/**[/right]


[right] * Tells WordPress to load the WordPress theme and output it.[/right]


[right] *[/right]


[right] * @var bool[/right]


[right] */[/right]


[right]define('WP_USE_THEMES', true);[/right]



[right]/** Loads the WordPress Environment and Template */[/right]


[right]require('./wp-blog-header.php');[/right]


[right]?>[/right]


[/right]

0

به اشتراک گذاری این پست


لینک به پست

برو به ادرس زیر ببین تنظیمات نشانی ورد پرس و نشانی سایت درست وارد شده اند یا نه

www.yoursite.com/wp-admin/options-general.php

به صورت جزئی تر هم در لینک زیر آورده

http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Within_Your_Site

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

برو به ادرس زیر ببین تنظیمات نشانی ورد پرس و نشانی سایت درست وارد شده اند یا نه

www.yoursite.com/wp-admin/options-general.php

به صورت جزئی تر هم در لینک زیر آورده

http://codex.wordpre...ithin_Your_Site

آره اون قسمت هم چک کردم و مشکلی نداره دیگه واقعا نمیدونم چیکار کنم! به این صورته:

نشانی وردپرس:

http://domain.com/fa

نشانی سایت:

http://domain.com

الان تو permalinks بهش فولدری که وردپرس نصب هستو دادم و لینک ها درست شده اما اینجوری دیگه صفحه اولمو نشون نمیده و not found میزنه. یعنی header و footer به همراه لینک هایی که پایین صفحه هستن نشون داده میشن اما محتوای صفحه اصلی نشون داده نمیشه!

ویرایش شده در توسط ham3d
0

به اشتراک گذاری این پست


لینک به پست

هر دو رو روی http://domain.com/fa ست کنید

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط novin
      با سلام خدمت دوستان می خواستم بدونم پیوندهای یکتای سایت در چه حالتی باشد از نظر سئو بهتر است