• اطلاعیه ها

    • Morteza

      باهم بسازیم: اطلس ووکامرس و وردپرس   14/07/96

      تاپیک ایجاد شده برای بحث در جهت ایجاد یک منبع، ویکی، صفحات توضیحی و یا بخش آموزشی جامع برای وردپرس و متعلقات مختلف آن است. لطفا جهت مشارکت در این بحث، ارائه پیشنهاد و یا انتقاد به تاپیک فوق مراجعه کنید. باهم بسازیم: اطلس ووکامرس و وردپرس
فرهاد

مشکل افزونه wp-poll با فایل پیوست

8 پست در این موضوع قرار دارد

سلام

من یه سایت از 0 طراحی کردم که آخراش وقتی برای ابزارک نوشتم و داخل یه پوشه قرار دادم و از فانکشن اون پپوشه رو فراخوانی کردم اینطوری :


require get_template_directory() . '/widgets/qore.php';

به خوبی هم کار کردش

اما وقتی خواستم برا مطلبم تصویر بزارم دیدم ارور میده و عکس های قبلی رو هم نشون نمیده

بعد از یه هفته گشت و گذار بالاخره فهمیدم مشکل از افزونه نظر ستجی wp-poll هستش

وقتی افزونه رو غیر فعال میکنم به خوبی سیستم کار میکنه و میتونم تصویر پیوست کنم

البته این رو بگم که خود افزونه مشکل ساز نیست

یعنی وقتی هم افزونه فعال باشه و هم از این کد استفاده کنم این مشکل بوجود میادش

در اصل افزونه با این مشکل داره :


require get_template_directory() . '/widgets/qore.php';

خب شما میگین چی کار کنم الان ؟

راه حل دیگه ای برا فراخوانی اون فایل دارین یا روش حل مشکل افزونه رو میدونین؟

این رو هم بگم که تعداد ابزارک ها کمی زیاده و نمیشه همش رو داخل فانکشن بزارم چون اون موقع فکر کنم یه 700 800 خط فایل فانکشن بشه

0

به اشتراک گذاری این پست


لینک به پست

چه خطایی نمایش داده میشه؟ و در کجا؟

مشکل با این خط نیست. احتمالا بخشی لود نمیشود

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

وقتی همزمان هم افزونه فعاله و هم این کد فراخوانی داخل فانکشن هست این ارور رو موقع گذاشتن تصویر شاخص و یا گذاشتن هر فایلی در قسمت رسانه میادش :

post-2747-0-65063100-1384062318_thumb.jp

وقتی افزونه رو غیر فعال کنمش و یا کد رو از فانگشن حذف کنم مشکل برطرف میشه

افزونه رو که نمیشه از کار انداخت چون لازمه

اما میشه کد ابزارک ها رو کلا بیارم داخل فانکشن که در این حالت به خوبی کار میکنه

اما فانکشن 700 800 خط میشه

در مورد کد ها هم چندین ابزارک دیگه که روی قالب های معتبر بودش رو هم تست کردم

یعنی اون ابزارک ها رو روی قالب خودم گذاشتم

باز هم همون مشکل بودش

ویرایش شده در توسط فرهاد
0

به اشتراک گذاری این پست


لینک به پست

مشکل احتمالا از محتوای اون فایل هست

0

به اشتراک گذاری این پست


لینک به پست

خب منم چند تا ابزارک دیگه که وجود داره را جایگزین ابزارک کردم و دوباره فراخوانی کردم همچنان مشکل باقیست

تازه ابزارکی که خودم نوشتم هم رو روی یه قالب دیگه گذاشتم و به همون روش فراخوانی کردم و مشکلی هم بوجو نیومد

یعنی افزونه با این نوع فراخوانی تداخل داره نه کدهای من , چون همون کدهای ابزارک رو میزارم تو فانکشن اون مشکل دیگه بوجود نمیاد

افزونه هم آخرین ورژنه

0

به اشتراک گذاری این پست


لینک به پست

این رو تست کنید


require_once(dirname(__FILE__).DIRECTORY_SEPARATOR."widgets".DIRECTORY_SEPARATOR."qore.php") ;

یا آدرس را دستی قرار دهید

2

به اشتراک گذاری این پست


لینک به پست

کد رو n بار ویرایش کردم در حالات مختلف کلا نتونست ابزارک رو داخل قسمت ابزارک ها بیاره یعنی چیزی به ابزارک اضافه نکرد

مشکل باید در فراخوانی ویدجت wp-polls باشه

0

به اشتراک گذاری این پست


لینک به پست

مشکل باید از سمت سور شما باشه که یکسری توابع محدود شده هستن و ابزارک درست فراخوانی نمیشه

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری