Sgwgo

کمک برای حل یه مشکل مربوط به تصویر شاخص

36 پست در این موضوع قرار دارد

شما یک save as web از همون صفحه بگیرید و فشرده و اینجا آپلود کنید روی ولیدیتور چکش کنم.

منظور شمارو متوجه نشدم ولی هرچی هست صفحه ی اصلی سایت منه

صفحه ی مشکل دار را باز کنید بعد از لود از منوی فایل - save as کنید با فرمت html روی هارد دیسک یک فایل به همراه یک پوشه ذخیره می شه آن دو را با هم زیپ کنید و بگذارید روی سایت

1

به اشتراک گذاری این پست


لینک به پست

یه سوال

میشه تصاویر شاخص به روش غیر از روش thimb نشون داد؟

فرقش چیه؟

منظورتون کد دیگه هست؟

بله می شه

من معمولا از این استفاده می کنم

داخل حلقه


<?php the_post_thumbnail(); ?>

و داخل functions


add_theme_support('post-thumbnails');
set_post_thumbnail_size(520, 250, true);

2

به اشتراک گذاری این پست


لینک به پست

آقا ایمان لینک هارو چیکار کنم به لینک تصویر شاخص هادقت کن

نمیدونم واسه چی اینکار ولی قرار دادم

fadroid.rar

0

به اشتراک گذاری این پست


لینک به پست

این کد تصویر ساختن لینک هم که داخل حلقه مشخصه شما بخشی که قراره در حلقه باشه را درست بجای تگ img توی کدی که خودت داری استفاده کن در ضمن اعداد 520 و 250 مقدار w و h هستند که اونها رو هم تنظیمشون کن

2

به اشتراک گذاری این پست


لینک به پست

خب ایمان جان من تو اون کدهای بالا که مسئول نشون دادن تصویر شاخص بودن این تغییرات دادم

یعنی کد زیر


<?php if (has_post_thumbnail( $post->ID )): ?>
<?php $image = wp_get_attachment_image_src( get_post_thumbnail_id( $post->ID ), 'full' ); ?>
<a href="<?php the_permalink(); ?>">
<img src="<?php echo MOM_SCRIPTS ?>/timthumb.php?src=<?php echo $image[0]; ?>&h=<?php echo $nbImgh; ?>&w=<?php echo $nbImgw; ?>&zc=1" alt="<?php the_title(); ?>" title="<?php the_title(); ?>" />
<?php

به این کد تغییر دادم


<a href="<?php the_permalink(); ?>">
<img src=" <?php the_post_thumbnail(); ?>" title="<?php the_title(); ?>" />

شرط حذف کردم و در قسمت آدرس عکس کد زیر

<?php the_post_thumbnail(); ?>

ولی سایتم سفید شد

اون کدهایی هم که گفتی توی فانکشن گذاشتم

0

به اشتراک گذاری این پست


لینک به پست

آقا ایمان لینک هارو چیکار کنم به لینک تصویر شاخص هادقت کن

نمیدونم واسه چی اینکار ولی قرار دادم

برای راحتتر بررسی کردن کدها هست.

همونطور که حدس زده بودم در کد شما width و height وجود نداره( حداقل 5 بار گفتم قرار بدید!)

شرط حذف کردم و در قسمت آدرس عکس کد زیر

<?php the_post_thumbnail(); ?>

ولی سایتم سفید شد

اون کدهایی هم که گفتی توی فانکشن گذاشتم

چون با حذف کد اول تگ php باز مونده و بسته نشده و همچنین شما شرط رو نبسته رها کردید.

همچنین این نوع فراخوانی عکس کلا اشتباه هست:

<img src="  <?php the_post_thumbnail(); ?>" title="<?php the_title(); ?>" />

چون خود تابع the_post_thumbnail عکس رو مستقیم لود میکنه.

در همون کد اول به تگ img مقادیر width و height اضافه کنید کافی هست.

شما اگر به پوسته the_post_thumbnail رو اضافه کنید مشکلتون پیچیده تر میشه چون نمیتونید به این تابع دستی چیزی اضافه کنید. خودش عکس رو لود میکنه و شمادسترسی ندارید.

1

به اشتراک گذاری این پست


لینک به پست

مرتضی جان قربون قد و قامتت برم خب بعد هر بار گفتنت من هم گفتم که گذاشتم ولی بازم مشکل حل نشد

0

به اشتراک گذاری این پست


لینک به پست

الان کدهایی که من گفتم روی سایت شما هست؟ اگر هست آنلاین روی ولیدیتور بررسی میکنم تا ببینیم دقیقا مشکل رو از کجا میگیره.

1

به اشتراک گذاری این پست


لینک به پست

با ولیدیتور هیچ خطایی نیست در این رابطه

با سایت gtmetrix مشکل هست

0

به اشتراک گذاری این پست


لینک به پست

توی کدوم بخشش هست؟ الان روی تست کلی مشکل خاصی نبود(چک کردم)

1

به اشتراک گذاری این پست


لینک به پست

مشکل حل کردم خوشبختانه

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری