payamf1

مشکل اساسی بعد از انتقال هسته وردپرس

4 پست در این موضوع قرار دارد

سایت وردپرس من تو فولدر روت نبود تو یه فولدر دیگه به اسم wordpress بود. (صفحه اول سایت آدرسش www.example.com/wordpress بود) امروز تصمیم گرفتم بیارمش تو روت و کل محتویات فولدر wordpress رو move کردم تو public_html حالا وقتی میخوام برم تو مدیریت باز ریدارکت میشه به همون فولدر wordpress قبلی (example.com/wordpress/wp-admin?redirect...) و پنل مدیریت باز نمیشه.

چجوری میتونم این مشکلو حل کنم؟؟

خیلی تلاش کردم ساده بنویسم ببشخید خلاصه

0

به اشتراک گذاری این پست


لینک به پست

باید در تنظیمات عمومی وردپرس آدرس رو تغییر بدی

قبلا که ایطور بوده : www.example.com/wordpress

تغییرش بده به www.example.com/

برای این کار هم محتویاتی که move کردی رو کپی کن و پوشه وردپرس رو دوباره بساز تا ریدایرکت نشه

4

به اشتراک گذاری این پست


لینک به پست

شما دیگر به تنظیمات و پیشخوان وردپرس دسترسی ندارد.

وارد phpMyAdmin بشوید

بعد از انتخاب پایگاه داده ای که وردپرس را برروی آن نصب کردین، جدول wp_option را انتخاب و بدنبال siteurl بگردید و مقدارش را تغییر بدین.

5

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

باید در تنظیمات عمومی وردپرس آدرس رو تغییر بدی

قبلا که ایطور بوده : www.example.com/wordpress

تغییرش بده به www.example.com/

برای این کار هم محتویاتی که move کردی رو کپی کن و پوشه وردپرس رو دوباره بساز تا ریدایرکت نشه

چون به کنترل پنل دسترسی ندارم این روش قابل اجرا نیست. ولی نکته خوبی بود چون بعد از استفاده از روشی که آقای Mostafa فرمودن کنترل پنل درست میشه و چون ممکنه کسی از پیوند یکتا استفاده کرده باشه میبینین بعد از عوض کردن مشخصات wp-option توی phpMyAdmin کنترل پنل و ایندکس سایت درست میشه ولی بقیه مطالبی که دارین باز نمیشه و ارور ۴۰۴ میده. بنابراین با این روش (یعنی عوض کردن url از طریق تنظیمات همگانی) خود به خود کل پیوندهای قبلی درست میشه.

مثال : آدرس سایت قبلا بوده


www.example.com/test

و متن شما لینکش این بوده :


www.example.com/test/mytitle

بعد از تغییر تنظیمات phpMyAdmin حالا دیگه کلمه test از آدرس سایت حذف میشه ولی هنوز متن شما ریدایرکت میشه به آدرس قبلی(/test/mytitle) که پیدا نمیشه اونجا.

شما دیگر به تنظیمات و پیشخوان وردپرس دسترسی ندارد.

وارد phpMyAdmin بشوید

بعد از انتخاب پایگاه داده ای که وردپرس را برروی آن نصب کردین، جدول wp_option را انتخاب و بدنبال siteurl بگردید و مقدارش را تغییر بدین.

مرسی. درست شد. واقعا ممنون.

ویرایش شده در توسط payamf1
1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری