progpars

مشکل با qtranslate

14 پست در این موضوع قرار دارد

دوستانی که از qtranslate استفاده میکنند تو قسمت URL Modification Mode وقتی روی Use Pre-Path Mode (Default, puts /en/ in front of URL) میزاریم که به صورت site.com/en مثلاً بیاد بالا . 404 note found میده صفحه باید مقداری اضافه کرد ؟ پیوند یکتا هم تغییر دادم !

0

به اشتراک گذاری این پست


لینک به پست

من خیلی وقت هست از این افزونه استفاده نمیکنم.

ولی قبلا که استفاده می کردم با همین تنظیمات و ست کردن پیوند یکتا بدون مشکل کار میکرد.

البته توی انجمن خود افزونه هم جستجو کنید توضیحاتی در اینمورد داده شده.

اما در حال حاضر بهترین افزونه 2 زبانه wpml هست.

3

به اشتراک گذاری این پست


لینک به پست

من از افزونه qtranslate استفاده میکنم و زبان پیشفرضش رو هم رو فارسی قرار دادم وو طبیعتا باید سایت با زبان فارسی باز بشه ولی هر کاری کردم زبان انگلیسی سایت رو باز میکنه

دلیلش چیه ؟

0

به اشتراک گذاری این پست


لینک به پست

ریدایرکت میشه یا مشکل دیگه داره؟

0

به اشتراک گذاری این پست


لینک به پست

ریدایرکت میشه یا مشکل دیگه داره؟

زبان پیشفرض من روی فارسی هست و سایتم دو زبانه هست وقتی آدرس سایت رو میزنم به جای اینکه زبان پیشفرض فارسی رو بیاره مستقیما وارد صفحه انگلیسی میشه

0

به اشتراک گذاری این پست


لینک به پست

زبان پیشفرض من روی فارسی هست و سایتم دو زبانه هست وقتی آدرس سایت رو میزنم به جای اینکه زبان پیشفرض فارسی رو بیاره مستقیما وارد صفحه انگلیسی میشه

آدرس بخش انگلیسی جداست؟

آدرس میدهید

1

به اشتراک گذاری این پست


لینک به پست

آدرس بخش انگلیسی جداست؟

آدرس میدهید

دوست عزیزم مشکل رو حل کردم / مشکل از تنظیماتش بود / تشکر

(شرمنده اطلاع رسانی نکردم و وقت شما رو بابت این مطلب گرفتم)

0

به اشتراک گذاری این پست


لینک به پست

سلام

دوست عزیز میشه بگید که چجوری مشکل رو حل کردید

0

به اشتراک گذاری این پست


لینک به پست

این های زیر بررسی کنید:


http://www.qianqin.de/qtranslate/installation-guide/


http://wordpress.org/plugins/qtranslate/installation/

1

به اشتراک گذاری این پست


لینک به پست

دوست عزیز تنظیمات رو به صورت زیر انجام دادم

ظاهرا باید پیشفرض فارسی باشه ولی این طور نیست

اینم بگم که تمام حالات رو امتحان کردم

post-5617-0-52956300-1396802883_thumb.jp

0

به اشتراک گذاری این پست


لینک به پست

دوست عزیز تنظیمات رو به صورت زیر انجام دادم

ظاهرا باید پیشفرض فارسی باشه ولی این طور نیست

اینم بگم که تمام حالات رو امتحان کردم

مشکل از تنظیمات نیست مشکل از نبود کدی هست که در داخل افزونه باید اضافه کنید به لینک زیر برید

1

به اشتراک گذاری این پست


لینک به پست

دوست عزیز میشه بگید این کد رو باید کدوم خط اضافه کنم

من قبل از خط زیر وارد کردم ولی باز هم همون مشکل رو دارم یعنی وقتی سایت رو باز میکنم به صورت پیشفرض انگلیسی هستش

if(!defined('WP_ADMIN')) {

راستی من صفحه اول سایتم رو گزاشتم که یکی از page ها رو باز کنه ربطی به این نداره که؟؟؟؟

0

به اشتراک گذاری این پست


لینک به پست

دوست عزیز میشه بگید این کد رو باید کدوم خط اضافه کنم

من قبل از خط زیر وارد کردم ولی باز هم همون مشکل رو دارم یعنی وقتی سایت رو باز میکنم به صورت پیشفرض انگلیسی هستش

if(!defined('WP_ADMIN')) {

راستی من صفحه اول سایتم رو گزاشتم که یکی از page ها رو باز کنه ربطی به این نداره که؟؟؟؟

ببینید من فکر کردم در مورد مشکل qtranslate با پست های سفارشی مشکل دارید.

ولی مشکل شما فکر کنم در مورد باز شدن صفحه به صورت پیشفرض روی زبان انگلیسی هست درسته ؟؟ این مشکل از تنظیماتش هست که باید یکی از تیک ها رو بزنید

در قسمت show advanced یکی از تیک ها رو باید بزنید امتحانش کنید ببینید کدومه.

البته تنظیمات زبان فارسی رو موقع افزودن درست تنظیم کردید ؟؟

post-2281-0-25841800-1396884569_thumb.pn

3

به اشتراک گذاری این پست


لینک به پست

یکی از مهمترین مشکلاتی که پلاگین qtranslate داره اینه که موقع بروزرسانی باید حواستون باشه که افزونه با نسخه جدید همخوانی داشته باشه وگرنه با خطاهایی که برای من پیش اومد روبرو میشید که مجبور شدم به صورت دستی به نسخه قبل وردپرس برگردم. البته خوبیش اینه که قبل بروزرسانی خودش هشدار میده که من جدی نگرفتم :)post-2281-0-02245400-1398148388_thumb.pn

post-2281-0-47793400-1398148398_thumb.pn

post-2281-0-81849200-1398148408_thumb.pn

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط sprants
      سلام
      دوستان عزیز من تمامی مراحل انتقال از لوکال رو انجام داده و سایت کامل بود و تغییرات مد نظرم رو هم انجام داده بودم اما بعد از چند روز ناگهان در صفحه اول پیام نصب اولیه ورد پرس اومد و انگار که از اول میخواین ورد پرس رو اینستال کنیم ! الان در ftp همه آپلود های قبلیم هست وحتی در phpmyadmin دیتابیس و همه اطلاعات وجود داره اما در ادمین ورد پرس انگار یه ورد پرس جدید نصب شده
      لطفا کمک کنید
      ممنونم
    • توسط mrasoul
      با عرض سلام و خسته نباشید ... لطفا این صفحه را ببینید :
      صفحه مورد نظر
      در این صفحه و بعد از ویدئو یک فهرست وجود دارد با آیتمهایی مثلا
      1.Introduction
      2.Brackets Extensions
      و ... که در اصل سرفصل های این آموزش است که شامل یکسری زیر مجموعه هستند ... وقتی روی زیرمجموعه ها کلیک می کنید اون مجموعه را نشان می دهید . به عنوان مثال روی
      1.2The Extension Manager
      کلیک کنید ...
      من اگر بخوام یک پست آموزشی کامل بسازم و تو این پست این سرفصل ها رو تعریف کنم آیا وردپرس امکانی رو داره بدون اینکه برای هر فصل یک پست ساخت همه ی پستها را داخل یک پست نوشت ؟ یعنی یک پست چند صفحه ایی مثلا مقدمه در خود پست و در مقدمه سرفصل ها رو تعریف کنیم حالا همون پست چند صفحه را زیرمجموعه داشته باشد که این صفحه ها همون سرفصل ها باشند .
      چون اگر قرار باشد برای هر فصل یک پست بفرستم طبیعتا کار بسیار مشکل و زمان بری است چرا که در هرکدام از این پستها باید با زمینه دلخواه سرفصل ها را تعریف کنم و هربار که پست جدید بفرستم در داخل بقیه سرفصل های قبل باید بروم و در زمینه دلخوه لینک این سرفصل جدید را تعریف کنم
       
    • توسط lloyd
      سلام دوستان خوبم اگر کسی میتواند پوسته The Voux را در هاست من نصب کند لطفا به من اینجا اطلاع بدهد. خطای نصب: شیوه نامه گم شده است !
       
    • توسط shayan201680
      با سلام
      بنده یک سایت اصلی وردپرسی دارم و قرار شده که در ساب دامینشم از وردپرس استفاده کنم.
      الان میخوام کاری کنم که کاربران اگر در سایت اصلی ثبت نام کردند بتونند با همون مشخصات در ساب دامین نیز لاگین کنند و برعکس!
      ولی نمیدونم باید چکار کنم! 
      ممنون میشم اگر کسی بلده راهنمایی کنه، با تشکر... 
    • توسط dastjerdisf
      با سلام
      در بین اساتید کسی می تونه به من کمک کنه بگه چرا وقتی آدرس سایتم رو می نویسم اتومات این متن رو به اون اضافه می کنه/?i=1
      از مدیریت هاست پرسیدم میگند از کش مرورگر هستش اما چرا سایت های دیگه این جوری نیستند
      آدرس سایتم:http://hushmandyar.ir