محمد رضا

دو ارور برای سایت تازه تاسیس (یکی برای آپلود عکس دوم ارور خاص)

3 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام

یه سوال فوق العاده مهم برام پیش اومده

این نسخه جدید وردپرس مشکلی داره؟

یه سایت ساختم طبق معمول همیشه گی ، نسخه آخر وردپرس هم روشه فقط موقع آپلود عکس این ارور رو میده:

خطایی هنگام بارگذاری پرونده پیش آمده. دوباره تلاش کنید.

در صورتی که توی رسانه و کتابخانه رفته ولی نمیشه ازش استفاده کرد.

دوم اینکه هر کاری میکنم هر چند با رفرش یا تغییر صفحه ارور زیر هم نشون میده:


Warning: Cannot modify header information - headers already sent by (output started at .../public_html/wp-content/themes/.../theme/widgets/footer_social.php:1) in /..../public_html/wp-includes/pluggable.php on line 896

که خط 896 هم اینه:


header("Location: $location", true, $status);

مشکله چیه؟

قبلا از این بازیا نداشت

مشکل نسخه جدید نیست؟

ممون میشم راهنمایی کنید

ویرایش شده در توسط محمد رضا
0

به اشتراک گذاری این پست


لینک به پست

خطای اول رو در انجمن جستجو کنید

برای خطای دوم مشکل از footer_social.php هست بخش اول خطا رو در انجمن جستجو کنید

(قبل از ایجاد تاپیک بهتر هست جستجو شود)

0

به اشتراک گذاری این پست


لینک به پست

خطای اول رو در انجمن جستجو کنید

برای خطای دوم مشکل از footer_social.php هست بخش اول خطا رو در انجمن جستجو کنید

(قبل از ایجاد تاپیک بهتر هست جستجو شود)

بله حق باشماست توی سایت هست ولی با نوار جست و جو درس قابل پیدا شدن نیس

به هر حال مشکل حل شد ولی وقتی اومدم تاپیک رو حذف کنم گزینه ای برای حذفش پیدا نکردم

در صورت تمایل حذفش کنید

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط masoudmosleh267
      سلام دوستان. من یه سایتی رو از بکاپ گرفتم و از یه هاست و دامنه به یه هاست و دامنه جدید انتقال دادم. حالا چه سایت رو که باز میکنم چه وارد پیشخوان وردپرس میشم یه ارور میاد یکی از خطلی functions.php قالب رو نشون میده.
      Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /public_html/wp-content/themes/khadamator/functions.php on line 1132
      مشکل چیه؟
    • توسط amirsa
      سلام
      من محصولات متغیر رو در ووکامرس که وارد میکنم،(محصول ممکنه 2 یا 3 صفت داره که باید انتخاب بشه)
       توی فروشگاه ووکامرس بصورت حد اقل و حداکثر قیمت ها نشون داده میشه
      مثلا کالا دونوع 10 و  20 تومانی هست.صفت آ 15 تومن برای مشتری هایی که بخوان.تو فروشگاه قیمت رو بصورت 10-35 نشون میده که بیشتر از قیمت اصلی است.من میخوام همون 10 و 20 رو نشون بده
      این مشکل انرژی زیادی ازم گرفته ممنون میشم راهنماییم کنید 
    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط Rangarang
      سلام
      دقیقا از دیشب سه تا سایت من با هم بالا نمیاد و وقتی واردش می شیم با صفحه سفید مواجه می شیم.
      من فایل Error_Log رو که چک می کنم می بینم هیچ خطایی موجود نیست. پشتیبانی هاست می گه مشکل از سمت شماست، در صورتی که من شک دارم، چون اولا چرا هر سه تا سایت با هم و تو یک ساعت بالا نمیاد و دوما چرا تو فایل خطا اثری از هیچ اروری نیست. من راهکارهای موجود تو وب رو هم تست کردم، از جمله افزودن کد نمایش خطا تو wp-config ، تغییر نام پوشه پلاگین، تغییر نام پوشه تم، عوض کردن پوسته از دیتابیس به پیشفرض وردپرس و... اما هیچ کدوم تغییری تو وضعیت صفحه سفید نداد.
       
      راه حل پیدا کردن خطا تو چنین مواقعی چی هست؟ چطوری باید ثابت کرد مشکل از سمت سروره یا خودمون؟
      مرسی
    • توسط صالح طالبی
      باسلام خدمت شما عزیزان
      بنده این تکه کد رو که در اصل افزونه نمایش آخرین های انجمن بود برای وردپرس به صورت کد در خود فانکشن قالب دراوردم:
      function ipslatest_main($query) { if ( is_home() && $query->is_main_query() ) { $db_user = 'root'; $db_name = 'ipsdb'; $db_pass = ''; $db_host = 'localhost'; $prefix = get_option('ipslatest_db_prefix'); $url = 'http://localhost/IPS'; $limit = '5'; $title = ''; $width = '300'; $direction = 'rtl'; $translations = array('عنوان','بازدید','پاسخ ها','ارسال شده به وسیله'); $db = new wpdb( $db_user, $db_pass, $db_name,$db_host ); $q = $db->get_results( 'SELECT topic_id,author_name FROM '.$prefix.'forums_posts ORDER BY pid DESC LIMIT '.$limit ); echo '<div id="ipslatest-mainTitle" style="width:'.$width.'">'.$title.$position.'</div>'; echo '<table id="ipslatestTopics" border=0 style="padding:10px;width:'.$width.'">'; echo '<tr><td class="ipslatest-row-views">'.$translations[2].'</td><td class="ipslatest-row-answers">'.$translations[1].'</td><td class="ipslatest-row-sender">'.$translations[3].'</td><td class="ipslatest-row-title">'.$translations[0].'</td> </tr>'; if (is_array($q) || is_object($q)) { foreach ($q as $key => $row) { $topicDetails = $db->get_row('SELECT title,tid,views,posts FROM '.$prefix.'forums_topics WHERE tid='.$row->topic_id); $userMemberID = $db->get_row('SELECT member_group_id FROM '.$prefix."core_members WHERE name='".$row->author_name."'"); $userShowingData = $db->get_row('SELECT prefix,suffix FROM core_groups WHERE g_id='.$userMemberID->member_group_id); echo '<tr id="ipstopic"> <td class="ipslatest-row-views-content"> <span>'.$topicDetails->views.' </span></td> <td class="ipslatest-row-answers-content"><span>'.$topicDetails->posts.'</span></td> <td id="ipslatest-row-sender-content">'.$userShowingData->prefix.$row->author_name.$userShowingData->suffix.'</td> <td class="ipsTitle"> <a rel="follow" href="'.$url.'topic/'.$topicDetails->tid.'-'.strtolower(str_replace(" ","-",$topicDetails->title)).'">'. strip_tags($topicDetails->title) .' </a> </td> </tr>'; } /*}*/ } echo '</table>'; } } به صورت خودکار خود افزونه از کد زیر برای نمایش اون در اول پست های سایت و یا در آخر پست های سایت استفاده میکنه کد ها هم به این شکله:
      add_action( 'wp', 'ipslatestMain' ); function ipslatestMain( $query ) { $position = "bottom"; if($position === "bottom") $acton = "loop_end"; elseif ($position === "top") $acton = "loop_start"; add_action($acton,"ipslatest_main"); } الان بدون هیچ مشکلی نمایش میده در پایین پست ها ولی من میخام این نمایش رو در یه قسمت دیگه از قالب انجام بدم و چجوری میتونم این فانکشن و تابع رو نمایش بدم؟؟؟
      نام افزونه هم در ضمن ipsuite-latest-topics هست و من از حالت افزونه فقط خارجش کردم و در خود قالب و فانکشن اون اوکی کردم.
      فقط مشکل اینه که نمیخام در بالای پست یا پایین پست ها نمایش بدم و میخام در جایی که خودم تعیین میکنم تابع رو نمایش بدم؟!!!
      ممنون میشم راهنمایی بفرمایید.