pirooz

مشکل با پیوند یکتای فارسی

5 پست در این موضوع قرار دارد

سلام

من وردپرس را روی IIS 7.5 و از طریق Web platform installer و روی سرور اختصاصی نصب کرده‌ام.

مشکل این هست که وقتی عنوان یک پستی را فارسی می‌گذارم و پیوند یکتا را چیزی غیر از پیش فرض انتخاب می‌کنم، پیغام Not Found نمایش داده می‌شود. در این حالت اگر عنوان پست انگلیسی باشه همه چیز درست هست.

زبان پیش فرض سرور برای برنامه‌های non-Unicode بر روی فارسی بود که اون را انگلیسی قرار دادم که در این حالت فقط صفحات در صورتی نمایش داده می‌شه که پیوند یکتا به این صورت تنظیم شده باشد:


/%post_id%/%postname%/

در حالت‌های دیگه پیغام Not Found نمایش داده می‌شود.

در این حالت که پیوند یکتا با post_id شروع می‌شود هم اگر نامک دسته‌‌ها و تگ‌ها رو به انگلیسی انتخاب کنم لینک‌های موضوعات و تگ‌ها کار می‌کنه و اگر نامک اونها فارسی باشه باز هم پیغام Not Found نمایش داده می‌شه.

لطف کنید راهنمایی کنید.

0

به اشتراک گذاری این پست


لینک به پست

بطور کلی پرمالینک نیاز به mod_rewrite دارد که IIS اون رو ساپورت نمیکند. توضیحات اضافه نمیدم و شما رو ریفر میدم به خود کدکس تا کاملا موضوع رو متوجه شید

http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

5

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

ممنون از راهنماییتون.

عرض کرده بودم که مشکل من با پیوند یکتا زمانی هست که عناوین به صورت فارسی درج می‌شوند و با نام لاتین مشکلی ندارم.

اما با این وجود کدهای Url rewriting را جایگزین کردم و مشکل نام فارسی در عناوین پست‌ها حل شد.

اما بحث لینک دسته‌ها و برچسب‌ها همچنان باقی هست.

یعنی وقتی که نامک دسته‌ها و برچسب‌ها را فارسی می‌ذارم پست‌های مربوط به دسته‌ها یا برچسب‌ها نمایش داده نمی‌شود ولی وقتی انگلیسی می‌کنم نمایش داده می‌شود.

یعنی وقتی لینک‌ها به این صورت هستند:


http://mysiteName/category/عمومی/
http://mysiteName/tags/آزمایشی/

همچنین در فروشگاه woocommerce نام محصولات که چنین آدرسی می‌گیرند، شناسایی نمی‌شوند:


http://mysiteName/product/محصول-شماره-سه/

فکر می‌کنید این مشکل نام فارسی به چه چیزی مربوط باشه؟!

متشکرم

ویرایش شده در توسط pirooz
0

به اشتراک گذاری این پست


لینک به پست

برای ووکامرس

افزونه این پست را نصب

http://forum.wp-parsi.com/tutorials/article/14-%D9%BE%D8%B3%D8%AA-%D8%B3%D9%81%D8%A7%D8%B1%D8%B4%DB%8C-%D9%BE%DB%8C%D9%88%D9%86%D8%AF-%DB%8C%DA%A9%D8%AA%D8%A7/

و پیوند یکتا را دوباره ذخیره کنید

3

به اشتراک گذاری این پست


لینک به پست

مشکل من حل شد.

گفتم یه لینک بدم تا اگه کسی مثل من گرفتار شد، بتونه جواب رو پیدا کنه:

http://kamrang.com/u...ermalink-iis-7/

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری