aftab98

دانلود شدن صفحه نخست،در عوض باز شدن آن

12 پست در این موضوع قرار دارد

درود بر اساتید گرامی.

قبلا در یک پست،یک سری مشکلات مطرح کرده بودم منجمله همین مشکلی که در تیتر عنوان نوشته ام.البته خود به خود رفع شدند(با اپدیت به 3.7)اما امروز که مشاهده کردم مشکل اساسی و نگران کننده،مجددا برگشته.

متاسفانه در بعضی مواقعی،وقتی ادرس سایت رو میزنم،به جای باز کردن سایت،مرورگر تشخیص میده که این یک صفحه html است که برای دانلود قرار گرفته و سیستم شروع به دانلودش میکنه.که واقعا یک مورد عجیب هست برای من.

تصویر ضمیمه کردم.ممنون میشم دوستان راهنمایی بفرمایند.

سپاس

post-4034-0-02335500-1398934741_thumb.jp

0

به اشتراک گذاری این پست


لینک به پست

با سلام

از کی این مشکل پیش اومده؟

آیا تغییر خاصی انجام دادید؟

0

به اشتراک گذاری این پست


لینک به پست

در روت سایت یا روت قالب اگر برگه ای به نام index.html دارید حذفش کنید

2

به اشتراک گذاری این پست


لینک به پست

سلام

اقا علیرضا،تغییری ندادم،فقط بکاپ از سایت گرفتم و اون رو انتقال دادم به یک هاست دیگه.

جناب فخار عزیز،با حذف ایندیکس(صفحه نخست)قاعدتا مشکل پیش نمیاد؟

0

به اشتراک گذاری این پست


لینک به پست

جناب فخار

در روت سایت یا روت قالب،برگه ای به نام index.html وجود نداشت!

0

به اشتراک گذاری این پست


لینک به پست

از فایل .htaccess بک آپ بگیرید و حذفش کنید.

1

به اشتراک گذاری این پست


لینک به پست

اقای عبدالماجد عرض ادب

امروز عصر بدون هیچ تغییر یا دست کاری ،سایت دوبار بالا اومد.

اما حقیقتش از این مشکل که هر چند مدت پیش میاد و دوباره رفع میشه،خسته شدم.

الزامی هست در پاک کردن فایل اچ تی اکسس؟چون تا جایی که اطلاع دارم،اطلاعاتی همچون نوع پیوند یکتا و...در اون ذخیره میشه،درست عرض میکنم؟

0

به اشتراک گذاری این پست


لینک به پست

1-در روت نباید وردپرس یک index.html باشد

2-در بعضی از مواقع برای محدودکردن از کدهایی استفاده میشود که باعث دانلود شدن فایل میشود که درون httacess ذخیره میشود

3-عبدالماجد گفتند که بک آپ بگیرید و تست کنید

4-به نظر مشکل از هاست هم میاد چون بیشتر مشکلات شما در زمانی خود به خود به وجود و بر طرف میشوند

3

به اشتراک گذاری این پست


لینک به پست

سلام مجدد

جناب اقا مهدی و جناب عبدالماجد

سایت دوباره با همون مشکل مواجه شد.

فایل

httacess رو پاک کردم و رفرش کردم صفحه نخست رو،سایت بدون مشکل بالا اومد

ولی متاسفانه روی هر پستی کلیک میکردم،file not found میزد.مجبور شدم دوباره فایل

httacess رو اضافه کردم.ولی با اضافه کردنش،سایت به مشکل قبلی برنخورد.(ولی احتمالا دوباره به مشکل بربخوره)

نظر کارشناسی تون در مورد این مورد چی هست

:)

0

به اشتراک گذاری این پست


لینک به پست

فایل htaccess را حذف کنید و یک صفحه خالی با دسترسی 666 با نام دات htaccess (بدون نام و با پسوند htaccess) ایجاد کنید

بعد به پیبشخوان -> تنظیمات -> پیوند یکتا برید و ساختار پیوند یکتاتون رو به روز رسانی کنید

بعد از ذخیره صفحه دسترسی فایلی را که عرض شد بسازید بگذارید 644

1

به اشتراک گذاری این پست


لینک به پست

سلام كل كد هاي داخل فايل htaccess رو حذف كنيد و فقط كد هاي زير را در آن بگذاريد :


Options -Indexes
RewriteEngine On
<ifModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file .(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</ifModule>
# 480 weeks
<FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|js|css|swf)$">
Header set Cache-Control "max-age=290304000, public"
</FilesMatch>
<files wp-config.php>
Order deny,allow
deny from all
</files>
<files .htaccess>
Order deny,allow
deny from all
</files>
<files wp-settings.php>
Order deny,allow
deny from all
</files>
<files wp-config.php>
Order deny,allow
deny from all
</files>
<Files *.cgi>
Order Deny,Allow
Deny from all
</Files>
# SQL Injection Protection
RewriteRule ^.*EXEC\(@.*$ - [R=404,L,NC]
RewriteRule ^.*CAST\(.*$ - [R=404,L,NC]
RewriteRule ^.*DECLARE.*$ - [R=404,L,NC]
RewriteRule ^.*DECLARE%20.*$ - [R=404,L,NC]
RewriteRule ^.*NVARCHAR.*$ - [R=404,L,NC]
RewriteRule ^.*sp_password.*$ - [R=404,L,NC]
RewriteRule ^.*%20xp_.*$ - [R=404,L,NC]
# SQL Injection Protection
<IfModule mod_rewrite.c>
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteRule .* index.php [F,L]
</IfModule>

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

اگر باز هم مشكلي وجود داشت فقط كد زير را در فايل htaccess بگذاريد :


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

ویرایش شده در توسط majidmajid0098
1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط t-51
      با سلام خدمت همه .
      بنده یه مشکل کوچیک داشتم قسمت فهرست سازی اونم عبارت از نامعتبر بودن صفحات ورود و ثبت نام به دلیل نامعلوم به شرح عکس زیر کسی میدونه باید چیکار کرد یا اضلا چرا اینطوری شده ؟
       

    • توسط ارتور زم
      سلام دوستان خسته نباشید
      بنده از افزونه لایسنس منیجر استفاده میکنم Software License Manager
      از این افزونه برای بحث لایسنس قالب استفاده میشه یا هر محصول دیگری ...
      اما مشکلی که هست اینه که بعد از اینکه کدلایسنس توسط مشتری فعال شد و کار هم به خوبی انجام میشه و قالب فعال میشه
      اما مشکلی که هست در هر بار لود سایت باید این تایید اعتبار صورت بگیرد ،
      میخام ببینم طوری میشه کرد که فقط بعد از اولین تایید اعتبار (بعد خرید) فعال بشه و دیگر تا زمانی که از سمت سرور (سایت من) برای مشتری در بحث لایسنس ارسال نشد ، به هر دلیلی اگر سایت سرور هم قطع شد ، دیگه خاموش نشه
      چون مشکلی که هست اینه که اگر سایت من قطع بشه کلیه سایت های لایسنس شده مشتریان قطع میشه و این مشکل بزرگی هست.
      از توسعه دهنده پلاگین سوال کردم ، گفت باید کد سمت کلاینت تغییر کنه ، شما راه حلی دارید برای این کد:
       
      <?php define('YOUR_LICENSE_SERVER_URL','https://localhost'); $api_params=array('slm_action'=>'slm_check','secret_key'=>'245454545445','license_key'=>get_option('sample_license_key'),); $response=wp_remote_get(add_query_arg($api_params,YOUR_LICENSE_SERVER_URL),array('timeout'=>20,'sslverify'=>false)); $license_data=json_decode(wp_remote_retrieve_body($response)); global $active,$message;if($license_data->result=='success'){ ?> <?php } else{?> <?php wp_die(__('قالب شما لایسنس شده نمی باشد.'));?><?php }?>  
       
      منظور اینه بعد از هر لود ، تایید اعتبار میخام صورت نگیره ، الان به صورت پیشفرض با هر لود سایت ، درخواست میده به سمت سرور که تایید اعتبار بگیره ، خود سایت به صورت خودکار منظورمه ،
      میخام طوری بشه که بعد از اولین تایید اعتبار ، دیگه نیاز نداشته باشه با هر بار لود تایید بشه و تا زمانی که از سمت سرور دیگه پیغامی مبنی بر انقضا شدن لایسنس یا مثلا بلاک شدن بهش فرستاده نشه (ازداخل پنل افزونه این امکان وجود دارد)
      نیاز به تایید اعتبار پس از هر بار لود نشه …
    • توسط kamran.azarniya
      سلام دوستان
      در قالب  real home هر کاری میکنم امکان ثبت ملک توسط اعضا وجود نداره (با این که عضو میشن ) و لازم به ذکره 3 بار این قالبو از سایتهای مختلف گرفتم و نصب کردم
      تشکر
    • توسط amirmt
      سلام و عرض ادب هنگامی که سایتم و میخوام باز کنم و ادرسش رو سرچ میکنم یه صفحه سفید باز میشه که این اخطار رو میده 
      Parse error: syntax error, unexpected 'text' (T_STRING) in /home/unickir/public_html/wp-includes/class-oembed.php on line 461
      کسی میدونه مشکل کجاست و کمک کنه
      ادرس سایت}: www.unick.ir
    • توسط cloudgamer
      دنبال یه تابع هستم که تعداد تمام بازدید های سایت رو نشون بده 
      (بدون افزونه)