m.Mosibat

مشکل با اظافه کردن یه دسته بندی جدید

1 پست در این موضوع قرار دارد

دوستان عزیز مشکل خیلی مهمه ممنون میشم کمک کنید.

هر کاری که میکنم نمیتونم یه taxonomie جدید اضافه کنم چون وقتی که کدش رو به فانکشن اضافه میکنم همه مطالبم 404 میشن !!

اساتید عزیز میشه راهنمایی کنید مشکل از کجاست ؟


// Register Custom Taxonomy
function Events() {
$labels = array(
'name' => _x( 'مناسب ها', 'Taxonomy General Name', 'text_domain' ),
'singular_name' => _x( 'مناسب ها', 'Taxonomy Singular Name', 'text_domain' ),
'menu_name' => __( 'مناسبت ها', 'text_domain' ),
'all_items' => __( 'همه موارد', 'text_domain' ),
'parent_item' => __( 'مادر', 'text_domain' ),
'parent_item_colon' => __( 'مادر:', 'text_domain' ),
'new_item_name' => __( 'نام', 'text_domain' ),
'add_new_item' => __( 'اضافه کردن', 'text_domain' ),
'edit_item' => __( 'ویرایش', 'text_domain' ),
'update_item' => __( 'بروزرسانی', 'text_domain' ),
'separate_items_with_commas' => __( 'با کاما جدا کنید', 'text_domain' ),
'search_items' => __( 'جستجو', 'text_domain' ),
'add_or_remove_items' => __( 'اضافه و حذف کردن', 'text_domain' ),
'choose_from_most_used' => __( 'انتخاب از میان محبوب ها', 'text_domain' ),
'not_found' => __( 'پیدا نشد', 'text_domain' ),
);
$rewrite = array(
'slug' => '/',
'with_front' => true,
'hierarchical' => false,
);
$args = array(
'labels' => $labels,
'hierarchical' => true,
'public' => true,
'show_ui' => true,
'show_admin_column' => true,
'show_in_nav_menus' => true,
'show_tagcloud' => true,
'rewrite' => $rewrite,
);
register_taxonomy( 'Events', array( 'post' ), $args );
}
// Hook into the 'init' action
add_action( 'init', 'Events', 0 );

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری