mrpress

خروجی پست از وردپرس

7 پست در این موضوع قرار دارد

سلام

من یک برنامه خیلی کوچیک نوشتم که کارش به این صورت هست ، از وردپرس یک خروجی میگیره که پست ها به همراه تصاویر بند انگشتیشون (thumb) بتونه در یک صفحه دیگه به نمایش در بیاد.

من این کار رو برروی لوکال هاست انجام دادم و خیلی هم خوب جواب داد ؛ حالا دقیقا همین کد رو به همراه همین وردپرس برروی هاست نصب کردم ولی با کمال تعجب میبینم که پست ها میان ولی تصویر مربوطه اونها نیست.

به نظر شما مشکل از کجا میتونه باشه ؟!

با این تابع کار میکنم :


<?php ehco get_the_post_thumbnail( $post_id, $size) ?>

0

به اشتراک گذاری این پست


لینک به پست

با عرض معذرت ؛ UP

0

به اشتراک گذاری این پست


لینک به پست

با این چک کنید


<?php ehco get_the_post_thumbnail( $post->ID, $size) ?>

و فرقی که بین لوکال و هاست هست می تونه در سیستم عامل باشه که معمولا سیستم های خانگی سیستم عاملشون ویندوزه و سرورها لینوکس - لینوکس به کوچکی و بزرگی حروف حساسه ولی ویندوز نیست دذر کوچکی و بزرگی حروف توابعتون دقت کنید آی دی مطالب را با حروف بزرگ و باقی را با حروف کوچک بنویسید و تست کنید

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

من یه همچین طرحی براش پیاده کردم ، این توی خود وردپرس نیست ، یک فایل جدا و خارج از اسکریپت وردپرس هست.


for($i=0; $i< $num_rows; $i++){
$size = array(80,80);
$post_id = mysql_result($query_result, $i, "ID"); ;
$blog_title = mysql_result($query_result, $i, "post_title");
$lencheck = strlen($blog_title);
$blog_title = substr($blog_title,0,$character_number);
$blog_content = mysql_result($query_result, $i, "post_content");
$post_len = strlen($blog_content);
$blog_content = implode(' ', array_slice(explode(' ', $blog_content), 0, 24));
$blog_img = mysql_result($query_result, $i, "guid");
$blog_permalink = $blog_url . "?p=" . mysql_result($query_result, $i, "ID");

و بعد این تابع فراخوانی میشه :


<?php ehco get_the_post_thumbnail( $post_id, $size) ?>

ویرایش شده در توسط mrpress
0

به اشتراک گذاری این پست


لینک به پست

این کد را بعد از اصلاح نشانی بگذارید قبل از کوئری دیگه نیازی به رجوع به دیتابیس هم ندارید و تست کنید


define('WP_USE_THEMES', false);
require('/home/fakharbl/public_html/wp-blog-header.php');

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

توی یه هاست دیگه امتحان کردم همچین پیغامی میده :


Fatal error: Call to undefined function get_the_post_thumbnail() in /home3/******/public_html/htdoc/wp/index.php on line 63

یعنی چی میتونه باشه؟

ویرایش شده در توسط mrpress
0

به اشتراک گذاری این پست


لینک به پست

اینطوری که نباید از هاست دیگه مطالب هاست خودتون رو فراخوانی کنید برای اینکار یا باید با json و API آشنایی داشته باشید یا rss یا مطلب مورد نظر را در یک فایل php همراه با دستورات جاوا اسکریپت لود کنید و در قالب اسکریپت به سایتهای دیگه منتقل کنید

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط pouyamahmoudi
      با عرض سلام ، وقت بخیر و خسته نباشید
      قالب وردپرس من با وجود واکنش گرا بودن در نسخه موبایل یک مشکل داره 
      مشکل اینه که به صورت یه صفحه خالی با رنگ پس زمینه سایت میاد و باید صفحه رو بکشم به سمت راست تا محتویات نمایش داده بشه 
      لطفا جهت حل این مشکل راهنمایی کنید
      با سپاس

    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط reza_yki
      سلام من ابزارکی نوشتم که کاربر بتونه به وسیله select option به صورتی multi بتونه چندین دسته رو انتخاب کنه همه چیز درست و بدون مشکل کار میکنه فقط یه مشکل هست اونم اینه که وقتی ابزارک رو برای اولین بار فعال میکنی خطای زیر رو میده وباید یه دونه دسته رو انتخاب و ذخیره کنی تا ابزارک به صورت صحیح کارکنه لطفا راهنماییم کنید.
      Warning: in_array() expects parameter 2 to be array, string given in E:\Program Files\xampp\htdocs\wordpress\wp-content\themes\mymag\functions\widgets\widgets.php on line 29  
      اینم سورس کد:
      <?php public function form( $instance ) { $title = ! empty( $instance['title'] ) ? $instance['title'] : esc_html__( 'عنوان ابزارک', 'text_domain' ); $args = array( 'hide_empty' => 0, 'type' => 'post', 'taxonomy' => 'category', 'orderby' => 'name', 'hierarchical' => true, ); $cats = get_categories( $args ); $instance['cat_id'] = isset( $instance['cat_id'] ) ? ( $instance['cat_id'] ) : '1'; $count_cat = isset ($instance['cat_id']) ? count($instance['cat_id']) : '1' ; $tab_number = isset( $count_cat ) ? absint( $count_cat ) : 1; ?> <p> <label for="<?php echo $this->get_field_name( 'title' ); ?>"><?php _e( 'Title:' ); ?></label><br> <input class="widefat" id="<?php echo $this->get_field_id( 'title' ); ?>" name="<?php echo $this->get_field_name( 'title' ); ?>" type="text" value="<?php echo esc_attr( $title ); ?>" /> </p> <p> <label for="<?php echo $this->get_field_id('tab_number'); ?>"><?php _e( 'تعداد زبانه:'); ?></label><br> <input id="<?php echo $this->get_field_id('tab_number'); ?>" name="<?php echo $this->get_field_name('tab_number'); ?>" type="number" min="0" class="my_widget_number" value="<?php echo $tab_number; ?>" size="3" /> </p> <label for="<?php echo $this->get_field_name( 'cat_id' ); ?>"><?php _e( 'انتخاب دسته بندی : ' ); ?></label> <select id="<?php echo $this->get_field_id( 'cat_id' ); ?>" name="<?php echo $this->get_field_name( 'cat_id[]' ); ?>" multiple="multiple" style="width: 100%; margin: 10px auto; height: auto;"> <?php foreach( $cats as $cat ): ?> <option value="<?php echo esc_attr(__($cat->term_id)); ?>"<?php selected(in_array($cat->term_id, $instance['cat_id'])); // selected($cat->term_id,$cats_id) ?>><?php echo esc_attr(__($cat->name)); ?></option> <?php endforeach; ?> </select> <p> <input type="text" value="<?php echo esc_attr(__(implode(',', $instance['cat_id']))); ?>"> </p> <?php }  
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟
    • توسط hamid_diablo
      سلام دوستان
      من وردپرس رو روی لوکال هاست نصب کرده بودم
       
      تا چند روز پیش مشکلی نداشتم تا اینکه یه پوسته جدید نصب کردم و بعد از اون متاسفانه وردپرس بالا نیامد (صفحه سفید ظاهر شد )
       
      فقط قالب صحیفه رو نمایش میده بدون پیشخوان!!!
       
      وردپرس و پاک کردم و دوباره روی لوکال هسات نصب کردم اما مشکل برطرف نشد !
      ممنون میشم راهنماییم کنید