سیاوش

مشکل بعد از تغییر پیوند یکتا (Permalinks)

9 پست در این موضوع قرار دارد

من ساختار پیوند های یکتا رو عوض کردم (از پیش فرض به postname تغییر دادم.

همه جا رو هم جستجو کردم هم تاپیکای فارسی و هم انگلیسی، نهایتا همه می گن که .htaccess رو ویرایش کن به این شکل:

# BEGIN WordPress

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase /

RewriteRule ^index\.php$ - [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /index.php [L]

</IfModule>

# END WordPress

وقتی که این کار رو می کنم، پیوندها ریدایرکت میشن و صفحات و لینک ها درست باز می شن ولی دایرکتوری wp-admin مثل wp-admin/post-new.php ارور 404 میده!!

اگر هم که تنظیمات رو توی .htaccess پاک کنم، اون ارور 404 از بین میره ولی دیگه صفحه ها باز نمیشه (صفحه سفید) !!!

موندم که چیکار باید بکنم!

ضمنا از یکی دو تا پلاگین هم استفاده کردم ولی ظاهرا اونها هم فقط همین تنظیمات رو به .htaccess اضافه می کنن.

0

به اشتراک گذاری این پست


لینک به پست

کد شما ارتباطی با ارور ادمین نداره ولی برای اطمینان کد را از htaccess حذف کنید و دسترسیش را بگذارید روی 666 بعد از طریق پیشخوان ساختار پیوند یکتا را دوباره ذخیره سازی کنید تا وردپرس خودش کدهای لازم رو در htaccess بگذاره بعد از ذخیره سازی مجددا دستری فایل را 444 بگذارید

2

به اشتراک گذاری این پست


لینک به پست

ممنون از شما

ولی قسمت خنده دار قضیه همین هست که وقتی من این کارها رو می کنم همه چیز درست میشه،

و دسترسی کامل دارم و می تونم همه کارام رو بکنم

ولی وقتی که بعدا دوباره می خوام وارد بشم، ارور 404 می گیرم

یعنی همه پیوندها درست کار می کنه ولی پوشه ادمین ارور 404 میده،

ظاهرا آدرس های پوشه ادمین رو هم ریدایرکت می کنه در حالی که نباید این کار رو بکنه!

و الان باید برای هر دفعه که می خوام کار مدیریتی توی سایت بکنم باید برم همه مراحلی که شما گفتید رو دوباره اجرا کنم!

اگر بتونید کمک کنید خیلی ممنون میشم

0

به اشتراک گذاری این پست


لینک به پست

این تداخل پیوند یکتا نباید بر روی قسمت مدیریت شما تاثیر بگذاره

یا شاید دارین اشتباه کار می کنید

و یا اینکه فایل htaccess توسط پلاگینی دستخوش تغییر هست

3

به اشتراک گذاری این پست


لینک به پست

از اونجایی که تقریبا 90% سایتها همین تغییر در ساختار را انجام می دند و کسی جز شما این مشکل رو نداره شک نکنید که مشکل از طرف شماست پوشه افزونه ها را تغییر نام بدید و تست کنید نتیجه را بفرمایید

2

به اشتراک گذاری این پست


لینک به پست

ممنون

دقیقا همین هم داره من رو گیج می کنه!

چون توی هیچ جایی چه فارسی و چه انگلیسی به این مشکل برخوردم!

در مورد افزونه هم، من افزونه ای که برای تغییر پرمالینک نصب کرده بودم رو حذف کردم و تغییرات htaccess توسط خود وردپرس داره به خوبی انجام میشه

کارهای خاصی که من کردم یکی پسورد گذاشتن واسه پوشه ادمین هست

ممکنه ناشی از این باشه؟؟

0

به اشتراک گذاری این پست


لینک به پست

پسورد بر روی دایرکتوری های درون هاست زیاد تداخل ایجاد نمی کنه

اشاره کردین

در مورد افزونه هم، من افزونه ای که برای تغییر پرمالینک نصب کرده بودم رو حذف کردم

شاید این یکی از موارد باشه

با انجام این امور ، هنوز هم مشکل پابرجاست ؟

2

به اشتراک گذاری این پست


لینک به پست

به یک شاخه بالاتر از روت برید و اگر فایل htaccess داره ازش کپی بگیرید و حذفش کنید

همینطور داخل پوشه wp-admin

2

به اشتراک گذاری این پست


لینک به پست

با تشکر از محبت و توجه دوستان

با حذف کردن پسوورد فولدر ادمین، فعلا مشکل برطرف شده است

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط saramaniaa.13
      سلام 
      من یه قالب ورد پرس طراحی کردم و مشکلی که دارم اینه که بعد از انتقال روی هاست وقتی روی ادامه مطلب کیلک میکنم اررور 500 میده   . روی لوکال مشکلی نداره و صفحه بدون اررور لود میشه.
      ممنون میشم راهنمایی کنید
    • توسط sasan_dingo
      سلام دوستان، من میخوام وقتی پستم رو مینویسم و پابلیش میکنم نام permalink از کاستوم فیلدی که مشخص میکنم گرفته بشه نه از نام تایتل
      ممنونم
    • توسط z.sabet
      سلام وقتتون بخیر
      سایتم permalink اش کار نمیکنه ، فقط روی گزینه پیش فرض کار میکنه !
      و روی حالتهای دیگه با پیغام خطای 404 مواجه میشم!
      چکار میتونم بکنم!!! لطفا راهنمایی ام کنید!!!