مرتضی نظری

نمایش ندادن عنوان های فارسی

12 پست در این موضوع قرار دارد

سلام دوستان،ببخشید من چند تا پوسته دارم که فارسی و راستچینشون میخوام بکنم.اما متاسفانه در بعضی ها عنوان های فارسی(از نوشته گرفته تا ساید بار و فهرست و فوتر و...) رو نشون نمیده.اول فکر کردم که بخاطر utf 8 نبودن فایل ها هست،اونارو به utf 8 تغییر دادم،اما بازم تغییر نکرد،بعدش فکر کردم که بخاطر فونت هاش هست،فونت هارو هم تغییر دادم به تاهوما اما بازم خوب نشد.

نکته ای که وجود داره:همون لحظه اول که لود میشه برای یک لحظه عناوین ظاهر شده (سالم و با فونت تاهوما) و سپس دوباره مخفی و میشه...

هرچی فکر میکنم نمیتونم متوجه بشم این چرا اینجوریه... در ضمن توی جستجویی که تو کد هاش داشتم متوجه شدم که چندین خط کد شده وجود داره که با eval شروع شده.

نمونش :

eval(str_rot13('shapgvba purpx_urnqre(){vs(!(shapgvba_rkvfgf("purpx_shapgvbaf")&&shapgvba_rkvfgf("purpx_s_sbbgre"))){rpub(\'Guvf gurzr vf eryrnfrq haqre perngvir pbzzbaf yvprapr, nyy yvaxf va gur sbbgre fubhyq erznva vagnpg\');qvr;}}'));

به اشتراک گذاری این پست


لینک به پست

سلام

اسم پوسته چی هست؟

اون رشته که گزاشتید هم بنظر نمیرسه ربطی به مشکل داشته باشه.

به اشتراک گذاری این پست


لینک به پست

اسم پوسته ها اینا هستن که همه رو از سایت "www.simplewpthemes.com " دانلود کردم.

WhitePortfolio

secretmagazine

به اشتراک گذاری این پست


لینک به پست

شاید بیا راست به چپ مشکل داره لایه هایی که مخفی می شند رو ltr کنید و درونشون یک لایه ی جدید باز کنید و rtl کنید تست کنید

یا در استایل دنبال

text-indent

بگردید و حذفش کنید (تغییرات را ببینید گاهی باید با عددش بازی کنید تا تنظیم بشه)

به اشتراک گذاری این پست


لینک به پست

اقای فخار ممنون از وقتتون،گفتم که برای یک لحظه میاد بالا ولی درجا مخفی میشه.الان سعی میکنم عکس بزارم...

به اشتراک گذاری این پست


لینک به پست

آقا اگر اول درسته لود که تکمیل میشه متنا فرط میشن و بیشتر عناوبن هستش مال cufon هستش یه فایلی به همین اسم یا با کلمه font با فرمت .js هستش توی قالب فکر کنم 1-2 تا باشن پاکشون کنید مشکل حل میشه !

به اشتراک گذاری این پست


لینک به پست

ببینید یکی از عکس ها عنوان هاش برای لحظه ای عنوان داره.بعد از لحظه ای میشه مریخی...

post-41-0-50987000-1348225179_thumb.pngpost-41-0-78510800-1348225182_thumb.png

آقا اگر اول درسته لود که تکمیل میشه متنا فرط میشن و بیشتر عناوبن هستش مال cufon هستش یه فایلی به همین اسم یا با کلمه font با فرمت .js هستش توی قالب فکر کنم 1-2 تا باشن پاکشون کنید مشکل حل میشه !

اره اتفاقا چنین چیزی توش هست.فقط اگه حذفش کنم مشکلی پیش نمیاد؟

در ضمن نسخه جی کوئریش هم زیاد جدید نیست اگه با نسخه جدید جایگزینش کنم مشکلی پیش نمیاد؟

به اشتراک گذاری این پست


لینک به پست

اون فایل js رو منی تونید پاک کنید می تونید ویرایش کنید و

textIndent را برابر یک عدد یک رقمی بگذارید اگر حذفشم کنید فقط تنظیمات اختصاصی فونت ها از پنل سایت انجام نمی شه که چون معمولا فارسی ساپورت نیست ما باهاشون کاری نداریم

اینکه اول لود می شند و بعد حذف مربوط می شه به اجرای پله کانی css چون اول استایل رو عادی می خونه و بعد از اجرای js استایل رو از روی اون

می تونید نسخه ی jquery رو تغییر بدید ولی بعضی از دستورات ممکنه عمل نکند که جایگزین دارند

http://oscarotero.com/jquery/

برای اصلاح دستورات از لینک بالا استفاده کنید و معمولا تغییرات خیلی جزئی اند مثلا دستور slideIn و slideOut تبدیل شدند به slideToggle()

به اشتراک گذاری این پست


لینک به پست

اتفاقا من این قالب رو داشتم فارسی میکردم. به عنوان پروژه برای گروه فارسی ساز.

دیدم این مشکلات رو داره دیگه بیخیالش شدم.

به اشتراک گذاری این پست


لینک به پست

مشکل خاصی پیش نمیاد با پاک کردنش و 100 درصد از همونه مثل مشکلی که پوسته Bangkok press داشت که حل شد اون فراخوانی رو بستیم اینجا فایل رو حذف میکنیم

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac
    • توسط davood12
      با سلام و احترام
      بنده دنبال یه ورد پرس کار جهت پشتیبانی از asrbourse.ir می گردم در صورت تمایل با شماره *** تماس بگیرید.
      با تشکر
    • توسط masihm90
      سلام جدیدا داخل قسمت رسانه عنوان عکی هایی که فارسی اپلود کرده بودم اینطوری نشون میده چه کنم ؟ جالبیش این هست که یه سری عکس ها اینطوری شده به سریش نشده مشکل چیه ؟
      ممنون

       

    • توسط khkh
      سلام.خسته نباشید.
      من طبق آموزش هایی که توی اینترنت بود، تا اونجایی که  wp-config-sample.php  رو -sample اش رو بر میداری و ویرایشش میکنی رفتم. ولی بعد که میخوام وارد بشم میگه برای ورود به پوشه ی wp-config-sample.php نیاز هستش. وقتی هم که دوباره اسمش رو به همون اسم اولیه تغییر میدم و میرم که وارد بشم،پیغام میده:احتمالاً نام کاربری یا رمز عبور شما در پرونده‌ی wp-config.php اشتباه است. حالا من نمیدونم چکار کنم: اگه اسمش همون اسم اولیه باشه، این پیغام رو میده، اگه اسمش رو تغییر بدم، میگه بهwp-config.php نیاز هستش.
      لطفاً کمکم کنید.