koroush

پیغام خطای nplurals = 1... حین ترجمه یک پوسته

2 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

با سلام خدمت شما

بنده وقتی می خواستم فایل ترجمه یک پوسته و فارسی کنم چون فایل دیفالت نداشت مجبور شدم فایل ترجمه آلمانی اون رو بردارم و ویرایش کنم.

الان هم زمانی که ترجمه عبارتی رو انجام می دم. و می خوام اون رو ذخیره کنم پیغام خطای زیر رو دریافت می کنم.

nplurals = 1...

ممنون میشم راهنمایی نمایید.

نرم افزار بنده poedit هست.

اطلاعات تکمیلی :

الان که برسی کردم دیدم داخل پوشه ربان من فایلی با پسوند .pot بوده که با پاورپوینت ارور می داده اما وقتی اون رو با نرم افزار poedit باز کردم دیدم همون انگلیسی هست !

حالا باید چیکار کنم؟

می تونم ترجمه های انجام شده در فایل زبان آلمانی رو منتقل کنم به فایل انگلیسی زبان؟

با این کار ارور مربوطه رفع میشه؟

با احترام

ویرایش شده در توسط koroush
0

به اشتراک گذاری این پست


لینک به پست

سلام.

آخرین نسخه poedit رو اول نصب کنید بعد فایلی که ایجاد کردید رو (مهم نیست از چه فایلی استفاده کردید) باز کنید از گزینه های بالا به catalog > properties برید، در تب اول پلورال فورم رو روی دیفالت رول بزارید و language رو روی persian iran و فایل رو با نام fa_IR ذخیره کنید ( از منوی فایل save as انجام بدید ).

این مشکل با این کار به احتمال 99 درصد بر طرف میشه ( اگر poedit آخرین نسخه رو داشته باشید.) :)

موفق باشید.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط sajadszm
      با سلام
      من یک افزونه رو با POEDIT فارسی سازی کردم.داخل اون بخش تاریخ هست که متاسفانه  تاریخ به صورت میلادی هستش.افزونه ی تقویم جلالی هم روی سایت نصبه ولی بازم تاریخ تغییری نکرده.چکار کنم؟
    • توسط arashjalili
      سلام من قالبی رو دارم که می خوام فایل فارسی برای اون بسازم اما هنگام درست کردن فایل فارسی ارور های زیر را می دهد: ممنون می شم راهنمایی کنید.
      6/3/2017 1:17:58 PM: C:\Users\name\AppData\Local\Temp\poeA508.tmp\ref.pot:9202: duplicate message definition...
      6/3/2017 1:17:58 PM: C:\Users\name\AppData\Local\Temp\poeA508.tmp\ref.pot:4030: ...this is the location of the first definition
      .و...
      با پلاگین loco translate هم کار نمی کنه .
       
       
       


    • توسط Hamidwp
      سلام خدمت دوستان من یه افزونه ای خریدم که میخوام فارسیش کنم ولی وقتی توی نرم افزار poedit واردش میکنم این خطا رو میده:
      Failed to extract wordpress information
      اینم عکس و فایل log.new .txt

    • توسط n1317
      خسته نباشید دوستان
      من آموزشی در رابطه با کار با poedite دیدم
      افزونه awsome-support رو برای فارسی سازی انتخاب کردم
      بعد اینکه افزونه رو فارسی کردم فایلی با نام awesome-support-fa_IR با پسوند .mo استخراج کردم
      واونو در پوشه languages افزونه قرار دادم
      مشکل اینجاش که هر کاری میکنم نمیتونم ترجمه رو فراخوانی کنم
      فایل اصلی افزونه:



      <?php
      /**
      * @package Awesome Support
      * @author ThemeAvenue <web@themeavenue.net>
      * @license GPL-2.0+
      * @link http://themeavenue.net
      * @copyright 2014 ThemeAvenue
      *
      * @wordpress-plugin
      * Plugin Name: Awesome Support
      * Plugin URI: http://getawesomesupport.com
      * Description: Awesome Support is a great ticketing system that will help you improve your customer satisfaction by providing a unique customer support experience.
      * Version: 3.1.12
      * Author: ThemeAvenue
      * Author URI: http://themeavenue.net
      * Text Domain: wpas
      * License: GPL-2.0+
      * License URI: http://www.gnu.org/licenses/gpl-2.0.txt
      * Domain Path: /languages
      */[/left]

      [left]// If this file is called directly, abort.
      if ( ! defined( 'WPINC' ) ) {
      die;
      }[/left]


      [left]/*----------------------------------------------------------------------------*
      * Shortcuts
      *----------------------------------------------------------------------------*/[/left]


      [left]define( 'WPAS_VERSION', '3.1.12' );
      define( 'WPAS_DB_VERSION', '1' );
      define( 'WPAS_URL', trailingslashit( plugin_dir_url( __FILE__ ) ) );
      define( 'WPAS_PATH', trailingslashit( plugin_dir_path( __FILE__ ) ) );
      define( 'WPAS_TEMPLATE_PATH', 'awesome-support/' );
      define( 'WPAS_ADMIN_ASSETS_URL', trailingslashit( plugin_dir_url( __FILE__ ) . 'assets/admin/' ) );
      define( 'WPAS_ADMIN_ASSETS_PATH', trailingslashit( plugin_dir_path( __FILE__ ) . 'assets/admin/' ) );[/left]


      [left]/*----------------------------------------------------------------------------*
      * Settings
      *----------------------------------------------------------------------------*/[/left]


      [left]define( 'WPAS_FIELDS_DESC', apply_filters( 'wpas_fields_descriptions', true ) );[/left]


      [left]/*----------------------------------------------------------------------------*
      * Addons
      *----------------------------------------------------------------------------*/[/left]


      [left]/**
      * Array of addons to load.
      *
      * @since 3.1.5
      * @var array
      */
      $wpas_addons = array();[/left]


      [left]/*----------------------------------------------------------------------------*
      * Shared Functionalities
      *----------------------------------------------------------------------------*/[/left]


      [left]require_once( WPAS_PATH . 'includes/functions-fallback.php' );
      require_once( WPAS_PATH . 'includes/class-logger.php' );
      require_once( WPAS_PATH . 'class-awesome-support.php' );[/left]


      [left]/**
      * Register hooks that are fired when the plugin is activated or deactivated.
      * When the plugin is deleted, the uninstall.php file is loaded.
      */
      register_activation_hook( __FILE__, array( 'Awesome_Support', 'activate' ) );[/left]


      [left]/**
      * Get an instance of the plugin
      */
      add_action( 'plugins_loaded', array( 'Awesome_Support', 'get_instance' ) );[/left]


      [left]/**
      * Load addons.
      *
      * A couple of addons are built in the plugin.
      * We load them here.
      */
      require_once( WPAS_PATH . 'includes/addons/custom-fields/class-custom-fields.php' );
      require_once( WPAS_PATH . 'includes/addons/file-uploader/class-file-uploader.php' );
      require_once( WPAS_PATH . 'includes/addons/class-mailgun-email-check.php' );[/left]


      [left]/**
      * Call all classes and functions files that are shared
      * through the backend and the frontend. The files only used
      * by the backend or the frontend are loaded
      * by their respective classes.
      */
      require_once( WPAS_PATH . 'includes/functions-post.php' ); // All the functions related to opening a ticket and submitting replies
      require_once( WPAS_PATH . 'includes/functions-user.php' ); // Everything related to user login, registration and capabilities
      require_once( WPAS_PATH . 'includes/functions-addons.php' ); // Addons functions and autoloader
      require_once( WPAS_PATH . 'includes/class-log-history.php' ); // Logging class
      require_once( WPAS_PATH . 'includes/class-email-notifications.php' ); // E-mail notification class
      require_once( WPAS_PATH . 'includes/functions-general.php' ); // Functions that are used both in back-end and front-end
      require_once( WPAS_PATH . 'includes/functions-custom-fields.php' ); // Submission form related functions
      require_once( WPAS_PATH . 'includes/functions-templating.php' ); // Templating function
      require_once( WPAS_PATH . 'includes/class-post-type.php' ); // Register post types and related functions
      require_once( WPAS_PATH . 'includes/class-product-sync.php' ); // Keep the product taxonomy in sync with e-commerce products
      require_once( WPAS_PATH . 'includes/class-gist.php' ); // Add oEmbed support for Gists
      require_once( WPAS_PATH . 'includes/class-wpas-editor-ajax.php' ); // Helper class to load a wp_editor instance via Ajax[/left]


      [left]/**
      * Check if dependencies are loaded.
      *
      * The plugin uses a certain number of dependencies managed through Composer.
      * If those dependencies are not loaded the plugin won't work.
      *
      * In order to avoid errors we check if dependencies are present. If not we simply
      * don't load the plugin.
      *
      * This problem won't happen with the production version as we have scripts
      * doing all the work, but on the development version this can be a problem.
      *
      * @since 3.0.2
      */
      if ( ! Awesome_Support::dependencies_loaded() ) {
      add_action( 'admin_notices', 'wpas_missing_dependencied' );
      }[/left]


      [left]/*----------------------------------------------------------------------------*
      * Public-Facing Only Functionality
      *----------------------------------------------------------------------------*/
      if ( ! is_admin() && Awesome_Support::dependencies_loaded() ) {
      require_once( WPAS_PATH . 'includes/class-notification.php' ); // Load notifications class
      require_once( WPAS_PATH . 'includes/shortcodes/shortcode-tickets.php' ); // The plugin main shortcodes
      require_once( WPAS_PATH . 'includes/shortcodes/shortcode-submit.php' ); // The plugin main shortcode-submit
      }[/left]


      [left]/*----------------------------------------------------------------------------*
      * Dashboard and Administrative Functionality
      *----------------------------------------------------------------------------*/[/left]


      [left]/**
      * The code below is intended to to give the lightest footprint possible.
      */
      if ( is_admin() && Awesome_Support::dependencies_loaded() ) {[/left]


      [left]/* Load main admin class */
      require_once( WPAS_PATH . 'includes/admin/class-admin.php' );
      add_action( 'plugins_loaded', array( 'Awesome_Support_Admin', 'get_instance' ) );[/left]


      [left]/* Load the MailGun e-mail check settings */
      add_filter( 'wpas_plugin_settings', array( 'WPAS_MailGun_EMail_Check', 'settings' ), 10, 1 );[/left]


      [left]/**
      * Add link ot settings tab
      */
      add_filter( 'plugin_action_links_' . plugin_basename( __FILE__ ), array( 'Awesome_Support_Admin', 'settings_page_link' ) );[/left]


      [left]}[/left]


      [left]/**
      * Start the session if needed.
      */
      if ( ! session_id() && ! headers_sent() ) {
      session_start();
      }



      من از کدهای زیادی استفاده کردم ولی ترجمه رو نشناخت
      من از چه کدی استفاده کنم؟
      واقعا گیج شدم باور کنید سردردم گرفتم
      ممنون میشم راهنمایی کنید.
    • توسط n1317
      خسته نباشید دوستان
      من آموزشی در رابطه با کار با poedite دیدم
      افزونه awsome-support رو برای فارسی سازی انتخاب کردم
      بعد اینکه افزونه رو فارسی کردم فایلی با نام awesome-support-fa_IR با پسوند .mo استخراج کردم
      واونو در پوشه languages افزونه قرار دادم
      مشکل اینجاش که هر کاری میکنم نمیتونم ترجمه رو فراخوانی کنم
      فایل اصلی افزونه:



      <?php
      /**
      * @package Awesome Support
      * @author ThemeAvenue <web@themeavenue.net>
      * @license GPL-2.0+
      * @link http://themeavenue.net
      * @copyright 2014 ThemeAvenue
      *
      * @wordpress-plugin
      * Plugin Name: Awesome Support
      * Plugin URI: http://getawesomesupport.com
      * Description: Awesome Support is a great ticketing system that will help you improve your customer satisfaction by providing a unique customer support experience.
      * Version: 3.1.12
      * Author: ThemeAvenue
      * Author URI: http://themeavenue.net
      * Text Domain: wpas
      * License: GPL-2.0+
      * License URI: http://www.gnu.org/licenses/gpl-2.0.txt
      * Domain Path: /languages
      */[/left]

      [left]// If this file is called directly, abort.
      if ( ! defined( 'WPINC' ) ) {
      die;
      }[/left]


      [left]/*----------------------------------------------------------------------------*
      * Shortcuts
      *----------------------------------------------------------------------------*/[/left]


      [left]define( 'WPAS_VERSION', '3.1.12' );
      define( 'WPAS_DB_VERSION', '1' );
      define( 'WPAS_URL', trailingslashit( plugin_dir_url( __FILE__ ) ) );
      define( 'WPAS_PATH', trailingslashit( plugin_dir_path( __FILE__ ) ) );
      define( 'WPAS_TEMPLATE_PATH', 'awesome-support/' );
      define( 'WPAS_ADMIN_ASSETS_URL', trailingslashit( plugin_dir_url( __FILE__ ) . 'assets/admin/' ) );
      define( 'WPAS_ADMIN_ASSETS_PATH', trailingslashit( plugin_dir_path( __FILE__ ) . 'assets/admin/' ) );[/left]


      [left]/*----------------------------------------------------------------------------*
      * Settings
      *----------------------------------------------------------------------------*/[/left]


      [left]define( 'WPAS_FIELDS_DESC', apply_filters( 'wpas_fields_descriptions', true ) );[/left]


      [left]/*----------------------------------------------------------------------------*
      * Addons
      *----------------------------------------------------------------------------*/[/left]


      [left]/**
      * Array of addons to load.
      *
      * @since 3.1.5
      * @var array
      */
      $wpas_addons = array();[/left]


      [left]/*----------------------------------------------------------------------------*
      * Shared Functionalities
      *----------------------------------------------------------------------------*/[/left]


      [left]require_once( WPAS_PATH . 'includes/functions-fallback.php' );
      require_once( WPAS_PATH . 'includes/class-logger.php' );
      require_once( WPAS_PATH . 'class-awesome-support.php' );[/left]


      [left]/**
      * Register hooks that are fired when the plugin is activated or deactivated.
      * When the plugin is deleted, the uninstall.php file is loaded.
      */
      register_activation_hook( __FILE__, array( 'Awesome_Support', 'activate' ) );[/left]


      [left]/**
      * Get an instance of the plugin
      */
      add_action( 'plugins_loaded', array( 'Awesome_Support', 'get_instance' ) );[/left]


      [left]/**
      * Load addons.
      *
      * A couple of addons are built in the plugin.
      * We load them here.
      */
      require_once( WPAS_PATH . 'includes/addons/custom-fields/class-custom-fields.php' );
      require_once( WPAS_PATH . 'includes/addons/file-uploader/class-file-uploader.php' );
      require_once( WPAS_PATH . 'includes/addons/class-mailgun-email-check.php' );[/left]


      [left]/**
      * Call all classes and functions files that are shared
      * through the backend and the frontend. The files only used
      * by the backend or the frontend are loaded
      * by their respective classes.
      */
      require_once( WPAS_PATH . 'includes/functions-post.php' ); // All the functions related to opening a ticket and submitting replies
      require_once( WPAS_PATH . 'includes/functions-user.php' ); // Everything related to user login, registration and capabilities
      require_once( WPAS_PATH . 'includes/functions-addons.php' ); // Addons functions and autoloader
      require_once( WPAS_PATH . 'includes/class-log-history.php' ); // Logging class
      require_once( WPAS_PATH . 'includes/class-email-notifications.php' ); // E-mail notification class
      require_once( WPAS_PATH . 'includes/functions-general.php' ); // Functions that are used both in back-end and front-end
      require_once( WPAS_PATH . 'includes/functions-custom-fields.php' ); // Submission form related functions
      require_once( WPAS_PATH . 'includes/functions-templating.php' ); // Templating function
      require_once( WPAS_PATH . 'includes/class-post-type.php' ); // Register post types and related functions
      require_once( WPAS_PATH . 'includes/class-product-sync.php' ); // Keep the product taxonomy in sync with e-commerce products
      require_once( WPAS_PATH . 'includes/class-gist.php' ); // Add oEmbed support for Gists
      require_once( WPAS_PATH . 'includes/class-wpas-editor-ajax.php' ); // Helper class to load a wp_editor instance via Ajax[/left]


      [left]/**
      * Check if dependencies are loaded.
      *
      * The plugin uses a certain number of dependencies managed through Composer.
      * If those dependencies are not loaded the plugin won't work.
      *
      * In order to avoid errors we check if dependencies are present. If not we simply
      * don't load the plugin.
      *
      * This problem won't happen with the production version as we have scripts
      * doing all the work, but on the development version this can be a problem.
      *
      * @since 3.0.2
      */
      if ( ! Awesome_Support::dependencies_loaded() ) {
      add_action( 'admin_notices', 'wpas_missing_dependencied' );
      }[/left]


      [left]/*----------------------------------------------------------------------------*
      * Public-Facing Only Functionality
      *----------------------------------------------------------------------------*/
      if ( ! is_admin() && Awesome_Support::dependencies_loaded() ) {
      require_once( WPAS_PATH . 'includes/class-notification.php' ); // Load notifications class
      require_once( WPAS_PATH . 'includes/shortcodes/shortcode-tickets.php' ); // The plugin main shortcodes
      require_once( WPAS_PATH . 'includes/shortcodes/shortcode-submit.php' ); // The plugin main shortcode-submit
      }[/left]


      [left]/*----------------------------------------------------------------------------*
      * Dashboard and Administrative Functionality
      *----------------------------------------------------------------------------*/[/left]


      [left]/**
      * The code below is intended to to give the lightest footprint possible.
      */
      if ( is_admin() && Awesome_Support::dependencies_loaded() ) {[/left]


      [left]/* Load main admin class */
      require_once( WPAS_PATH . 'includes/admin/class-admin.php' );
      add_action( 'plugins_loaded', array( 'Awesome_Support_Admin', 'get_instance' ) );[/left]


      [left]/* Load the MailGun e-mail check settings */
      add_filter( 'wpas_plugin_settings', array( 'WPAS_MailGun_EMail_Check', 'settings' ), 10, 1 );[/left]


      [left]/**
      * Add link ot settings tab
      */
      add_filter( 'plugin_action_links_' . plugin_basename( __FILE__ ), array( 'Awesome_Support_Admin', 'settings_page_link' ) );[/left]


      [left]}[/left]


      [left]/**
      * Start the session if needed.
      */
      if ( ! session_id() && ! headers_sent() ) {
      session_start();
      }



      من از کدهای زیادی استفاده کردم ولی ترجمه رو نشناخت
      من از چه کدی استفاده کنم؟
      واقعا گیج شدم باور کنید سردردم گرفتم
      ممنون میشم راهنمایی کنید.