23 پست در این موضوع قرار دارد

خوراک سایت من مشکل زیر رو در یک صفحه زرد رنگ نشان می دهد. دوستان لطفا کمک کنید تا این مشکل رو رفع کنم


XML Parsing Error: XML or text declaration not at start of entity
Location: http://dnoj.ir/feed
Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>
^

به اشتراک گذاری این پست


لینک به پست

http://validator.w3.org/appc/check.cgi?url=http%3A%2F%2Fdnoj.ir%2Ffeed

http://validator.w3.org/appc/docs/error/WPBlankLine.html

به اشتراک گذاری این پست


لینک به پست

از افزونه های زیر هم استفاده کردم ولی باز درست نشد.


http://wordpress.org/extend/plugins/fix-rss-feed/
http://wordpress.org/extend/plugins/broken-rss-feed-fixer/

به اشتراک گذاری این پست


لینک به پست

خط خالی نیست ولی به صورت زیر می باشد.


<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>

به اشتراک گذاری این پست


لینک به پست

اطلاعات ورود به وردپرس رو برام ارسال کنین لطفا.

به اشتراک گذاری این پست


لینک به پست

اطلاعات ورود به وردپرس رو برام ارسال کنین لطفا.

اطلاعات ورود چی رو؟

به اشتراک گذاری این پست


لینک به پست

همینجا از طریق پیام خصوصی هم میتونین ارسال کنین یا mohsengham[at]gmail

به اشتراک گذاری این پست


لینک به پست

روش دیگری برای حل این مشکل کسی سراغ نداره خیلی ظروری هست.

کار هایی که تا حالا برای رفع این مشکل انجام داده ام ولی نتیجه ای در بر نداشته است. :(

1. نصب افزونه های


http://wordpress.org/extend/plugins/fix-rss-feed/
http://wordpress.org/extend/plugins/broken-rss-feed-fixer/

2.کمک گرفتن از دوست عزیزم آقای محسن غیاثی

3. بروزرسانی به نسخه جدید وردپرس

4. تغییر قالب سایت

ویرایش شده در توسط dnojir

به اشتراک گذاری این پست


لینک به پست

فکر می کنم این مشکل کلی باشد چون سایت مپ افزونه سئو وردپرس هم ارور زیر را می دهد


XML Parsing Error: XML or text declaration not at start of entity
Location: http://dnoj.ir/sitemap_index.xml
Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="http://dnoj.ir/.../plugins/wordpress-seo/css/xml-sitemap-xsl.php"?>
^

به اشتراک گذاری این پست


لینک به پست

شاید مشکل شما در فایل functions.php در پوستتون باشه.

چک کنید که ابتدا و انتهای کدهای php درست باز و بسته شده باشه.

ابتدا : php?>

انتها :‌ <?

اگر قبل از بسته شدن کد php فاصله اضافی وجود دارد و همینطور از ابتدا آن را حذف کنید.

در غیر اینصورت فایل های php پوستتون چک کنید.

منبع و منبع

به اشتراک گذاری این پست


لینک به پست

دقیقا همین مشکل رو داشتم که با برسی فایل فانکشن قالبم اونو حل کردم فق عجیب اینه که با حذف این تکه کد ارور حل شد کد رو میزارم کسی از دوسان میدونه مشکلش چیه این کد؟؟؟


<?php
function add_more_buttons($buttons) {
$buttons[] = 'hr';
$buttons[] = 'del';
$buttons[] = 'sub';
$buttons[] = 'sup';
$buttons[] = 'fontselect';
$buttons[] = 'fontsizeselect';
$buttons[] = 'cleanup';
$buttons[] = 'styleselect';
return $buttons;
}
add_filter("mce_buttons_3", "add_more_buttons");
?>

این کد رو من برای این گذاشتم که تعدادی ابزار به ادیتور وردپرسم اضافه بشه.....

دوسان من با نگاه به تاپیکای دیگه ی سایت و جاهای دیگه اکثرا هر کی از کد بالا استفاده کرده تو فانکشن قالبش همشون فیدشون پریده!!!!! مشکل این کد چیه؟؟؟؟

نمونه

ویرایش شده در توسط Metalika

به اشتراک گذاری این پست


لینک به پست

اینجوری که چیزی نیست.

خطایی هم میده؟

به اشتراک گذاری این پست


لینک به پست

هیچ خطایی نمیاد منتها هر کسی از از این کد استفاده منه تو فانکشن قالب فید سایتش دقیقا همین اروری که در این تاپیک عنوان شده رو میده....

اینو اینجا اعلام کردم که اگه دوسان اگه مشکل فید دارن این قضیه رو حتما بررسی کنند

و اینکه اساتید محترم اشکال کد رو بگن....

به اشتراک گذاری این پست


لینک به پست

این مطلب رو دوستانمون در وردپرس 98 نوشته بودند !

برای سایت رفیقم کاربرد داشت .

شما هم تست کنید

سلام دوستان شاید شما هم به این مشکل بر خوردید که ار اس اس سایت شما نشون داده نمیشه خوب این میتونه دلایل مختلفی داشته باشه که بهتون میگم یکی از دلایل که معمولا برای همه پیش میاد فاصله بین تگ های آغازین و پایانی php است به این صورت که قبل تگ <?php و بعد از تگی که بسته میشود یعنی >? نباید فضای خالی یا همون اسپیس افتاده باشه این فاصله ها رو در دو فایل فانکشن قالب و فایل wp-config بررسی کنید . خوب حالا اگر این کار را کردید نشد به ترتیب یکی یکی افزونه هایی را که نصب کردید غیر فعال کرده و بعد تست کنید اگر درست شد که مشکل از اون افزونه است اگر نشد سایت مپ خود رو از اول نصب کنید چون خیلی موقع ها بر میگرده به فایل xml که مشکل پیدا کرده خوب اگر این ها رو هم انجام دادید بازم نشد کد زیر رو داخل تگ <head> قالب خودتون قرار بدید به احتمال ۹۵ % درست میشه



<link title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" rel="alternate" type="application/rss+xml" />
<link title="RSS .92" href="<?php bloginfo('rss_url'); ?>" rel="alternate" type="text/xml" />
<link title="Atom 0.3" href="<?php bloginfo('atom_url'); ?>" rel="alternate" type="application/atom+xml" />
<link href="<?php bloginfo('pingback_url'); ?>" rel="pingback" />

خوب اگر بازم دیدین مشکل رفع نشد مشکل از قالبتون هست و باید قالب رو عوض کنید و یا مشکل رو رفع کنید و یا از افزونه های نمایش ار اس اس برای سایت استفاده کنید.

منبع : http://www.wordpress98.com/wordpress/%D8%B1%D9%81%D8%B9-%D9%85%D8%B4%DA%A9%D9%84-%D9%86%D9%85%D8%A7%DB%8C%D8%B4-%D9%86%D8%AF%D8%A7%D8%AF%D9%86-%D9%81%DB%8C%D8%AF-%D8%B3%D8%A7%DB%8C%D8%AA/

به اشتراک گذاری این پست


لینک به پست

اول header.php خط خالی هست؟

آقا در فایل header من 3خط اول خالی هستش

وقتی با دریم ویور باز میکنمش میینم که خط خالی نیستش ولی تو سورس سایت که نگاه میکنم میبینم که 3خط اول خالی هستش

به اشتراک گذاری این پست


لینک به پست

آقا در فایل header من 3خط اول خالی هستش

وقتی با دریم ویور باز میکنمش میینم که خط خالی نیستش ولی تو سورس سایت که نگاه میکنم میبینم که 3خط اول خالی هستش

احتمالا مشکل از توابعی هست که اجرا میشود

افزونه‌ها را غیرفعال و تست کنید

شاید هم مشکل از پوسته باشد

به اشتراک گذاری این پست


لینک به پست

افزونه ها رو غیرفعال کردم ولی دیدم بازهم چند خط اول قالب خالی هستش

پس مشکل از پوسته هستش

امکان داره از کوئری هایی باشه که در صفحه اصلی استفاده کردم؟

به اشتراک گذاری این پست


لینک به پست

کدهایی که قبل از نمایش سایت اجرا میشوند

کویری ها معمولا بعد از اجرای بخش header هستند

با پوسته پیشفرض تست کنید

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط alireza.habibi70
      سلام و عرض ادب
      یه درخواست راهنمایی داشتم
       
      چندوقتی هست که گوگل داره روزانه مطالب و دسته بندیهایی که قبلا از سایتم حذف شده اند رو بررسی میکنه و نات فوند میزنه ، و همین امر باعث شده خیلی خیلی رتبه سایتم رو خراب کنه و همینجور ایندکس نداشته باشه مطالبم
       
      واسه همین امروز تصمیم گرفتم تغییراتی داخل robot.txt بدم
      اگه ممکنه بررسی کنید ببینید مشکلی نداره این کاری که انجام دادم
       
      برای مثال میخواهم که دسته بندی های زیر را از سایتم بررسی نکنه چون کلا توی سایتم وجود ندارن

      product-category/fruits
      product-category/kid-toys.html
       
      برای همین از کد زیر استفاده کردم درسته؟
      User-agent: *
      Disallow: /wp-admin/
      Allow: /wp-admin/admin-ajax.php
      Disallow: /product-category/fruits.html
      Disallow: /product-category/kid-toys.html
      Disallow: /product-category/foods.html
      Disallow: /product-category/flowers.html
      Disallow: /product-category/fashions.html
      Disallow: /product-category/electronics.html
      Disallow: /product-category/drinks.html
      Disallow: /product-category/beautiful-life.html
      Sitemap: http://apsgraphic.ir/sitemap.xml
       
       
      ممنون میشم راهنمایی کنید
      مچکرم
    • توسط nariman.rf
      سلام؛
      من در قالبم از افزونه wp pagenavi به همون شکلی که در صفحه آموزش افزونه در وردپرس هست استفاده می کنم ولی نمیدونم چرا فلش های بعدی و قبلی، بجای اینکه بیان وسط، رفتن اولش!
       
      درستش اینه که مثلا داشته باشیم:
      «   24   23   22    ...    3    2    1   »
      اگر میتونید، لطفا راهنمایی بفرمایید.

    • توسط TheOnlyMen
      درود
      خواستم از دوستان متخصص در عرصه وردپرس سوالی داشته باشم.
      چگونه می تواند مانند تصویر زیر چنین چیزی را طراحی کرد اسم این مدل چیست؟
      یک راهنمایی کوچک کافی است.
      http://s6.uplod.ir/i/00890/zavsx1f3nq1e.png
      سپاس گزارم
    • توسط nariman.rf
      سلام!
      موضوعی که به این سوالم نزدیک باشه تا در اون حیطه ارسال کنم رو پیدا نکردم
      میخواستم ببینم الان همین انجمن روی چه سیستمی پیدا شده؟ از کجا میشه گرفت؟ میتونم در کنار وردپرس روی هاستم داشته باشم یا نه؟
      بهترین انجمن (از نظر ظاهر و کاربرد فونت ایران سنس) هست که تجربه کردم. ممنون
    • توسط napo
      سلام 
      افزونه max mega menu  رو دانلود کردم ولی متاسفانه راستچین نیست یعنی زیر منو رو سمت راست ایجاد میکنه به جای اینکه در سمت چپ نشون بده همونطوری که توی عکس مشخصه بعد انتخاب دوتا زیر منو کلا از صفحه خارج میشه
      اگه میشه کمکم کنید
      اگه کسی افزونه ای دیگه میشناسه که هم راستیچینه هم اکاردئونی ممنون میشم معرفی کنه