AmirK24

مشکل قالب با مرورگر اپرا

10 پست در این موضوع قرار دارد

سلام خدمت دوستان عزیز

یه مشکلی که برای من پیش اومده اینه که قالبی که برای وردپرس تبدیل کردم تو همه ی مرورگرها حتی اینترنت اکسپلورر به درستی نشون میده ولی توی مرورگر اپرا بهم ریخته نشون میده

قالب وقتی به صورت html هست توی همه مرورگرها درست و بدون مشکل نشون میده اما وقتی تبدیل کردم برای وردپرس توی اپرا بهم میریزه

ممنون میشم دوستان کمک کنند خیلی فوریه

تصویر قالب در سایر مرورگر ها :

http://up.vatandownload.com/images2/olcud4036vup0x3byo1h.jpg

تصویر بهم ریخته در اپرا :

http://up.vatandownload.com/images2/xfaoz3amxzsk4p9crytw.jpg

0

به اشتراک گذاری این پست


لینک به پست

سلام

به انجمن خوش اومدین دوست عزیز

شماباید پوسته تبدیل شده رو روی یک وردپرس نصب کنید و بعد آدرس بدید تا بتونیم انلاین تست کنیم.

1

به اشتراک گذاری این پست


لینک به پست

سلام

ممنون از شما مدیر عزیز

پیام خصوصی شد

0

به اشتراک گذاری این پست


لینک به پست

پوسته تون مشکل اساسی در طراحی داره.

نحوه کدنویسی استایل ها درست نیست و خیلی بهم ریخته کار شده.

با این نوع استایل پیدا کردن محل مشکل سخت شده.

در صمن خیلی از استایل نویسی اینلاین استفاده کردید که اینهم خودش مشکل داره.

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

این یه قالب آماده بود که از یکی از سایتهای اسکریپت دانلود کردم

فقط یه سری تغییر سایز واسه بلوک وسط داخلش دادم و بقیه کدهای اضافی را هم حذف کردم

با این وجود وقتی به صورت html یا php لود میکنم کامل تو همه ی مرورگرها سالم نشون میده ولی وقتی تگهای وردپرس را گذاشتم تو اپرا ریخت بهم

الان برای این کار شما چه راه حلی پیشنهاد میکنید ؟

کلا دو تا استایل داره که style.css استایل اصلی هست و اون table.css مال قسمتهایی هست که میخواد از یه سایت دیگه میخواد یه سری table لود کنه

ویرایش شده در توسط AmirK24
0

به اشتراک گذاری این پست


لینک به پست

آقا مشکل را پیدا کردم :D

ولی خیلی برام عجیبه

این خط را که از توی هدر پاک کردم تو اپرا بهم ریختگیش درست شد


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

استاد به نظرت چرا به خاطر این خط ریخته بود بهم ؟

0

به اشتراک گذاری این پست


لینک به پست

سلام

چک کنید ببینید در فایل header.php کد زیر به همین صورت هست:


<?php wp_head(); ?>
</head>

و همینطور فایل footer.php :


<?php wp_footer(); ?>
</body>

2

به اشتراک گذاری این پست


لینک به پست

این کد رو حذف کنید کلا پوسته از حالت استاندارد خارج میشه.

بصورت زیر تستش کنید:

<!DOCTYPE html>

1

به اشتراک گذاری این پست


لینک به پست

گروه فارسی ساز عزیز ممنون چک میکنم ببینم چه جوابی میده.

هیئت مدیره عزیز ممنون از راهنماییتون ولی از همه ی DOCTYPEها استفاده کردم از ساده گفته تا html4.1 و کلا هرچی که تو اینترنت میشد پیدا کنی و با همش بازم تو اپرا بهم میریخت، حتی با همینی که شما نوشتی

دیگه فعلا مجبور شدم حذفش کنم تا ببینم چیکارش میشه کرد

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

گروه فارسی ساز عزیز ممنون

سعید هستم! ^_^

اگر درست نشد و پوستتون آنلاین هست آدرس بدید.

ویرایش شده در توسط سعید
2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط mahdixq
      سلام من فایل های سایت gzip شدن حتی افزونه نصب کردم فایل اچ تی داکس هم ادیت کردم توی اینسپکت المنت هم فایل های سایتم بخصوص svg هارو encoding رو gzip نشون میده ولی ولی با ابزار gtmetrix انالیز میکنم هیچ نمره ای به gzip (https://gtmetrix.com/reports/chikarkonam.com/FPDb4Ba9)نمیده دوستان چیکار کنم کلافه شدم کلی سایت ایرانی خارجی سر زدم کمکم کنید!!(:
    • توسط stanesti
      با سلام
      من به تازگی یک سایت با وردپرس راه اندازی کردم و الان به مشکل خوردم و هر کار کردم نتونستم حلش کنم و برای همین هم این مطلب رو ارسال می کنم
       
      حالا شرح سوال:
      وب سایت من علاوه بر بخش نوشته ها، از بخش نمونه کار ها، تیم ما، نظرات کاربران و .... نیز برخوردار هست.

      من می خواستم که نوشته هام در پوشه blog/ به نمایش در بیان مثل لینک زیر:
      https://stanesti.ir/blog/how-to-create-gravatar-account/
      برای این منظور اومدم و در داشبورد سایت به "تنظیمات > پیوندهای یکتا" رفتم و این تنظیمات رو اعمال کردم:

      پس از انجام این تنظیمات، نوشته ها به درستی کار می کنن اما نمونه کار ها نیز به پوشه blog/ منتقل شدن مانند لینک زیر:
      https://stanesti.ir/blog/portfolio/argon-dashboard-html-template/
      در حالی که من فقط می خواستم پست هایی که در بخش نوشته ها ارسال می کنم به blog/ منتقل بشن و بقیه پست های بخش های دیگه تغییری نداشته باشن و مثل لینک زیر باشن:
      https://stanesti.ir/portfolio/argon-dashboard-html-template/
       
      حالا به نظرتون چه کار باید بکنم؟ چه راهکاری پیشنهاد میدین؟
       
      ممنون میشم سریع تر جوابم رو بدید چون عجله دارم.
      تشکر
    • توسط mahdyhigh
      با سلام من افزونه yith cost of goods رو برای محاسبه سود زیان فروشگاه ووکامرسم نصب کردم . وقتی از طرف کاربر خرید انجام میشه فرایند بدون مشکل هست و گزارش گیری درست به ما میده
      اما اگه در صفحه سفارشات پنل ادمین اقدام به افزودن سفارش یا  ایجاد سفارش کنید ایتم های اضافه شده تون از نظر این پلاگین نادیده گرفته میشه و در گزارش گیری خودش حساب نمیشه وقیمت خریدش رو جلوی ایتم نمیاره
      از اون جایی که ما علاوه بر وبسایت به صورت تلفنی هم سفارش ایجاد می کنیم من خیلی فوری نیاز دارم که این موضوع حل بشه کسی میتونه راهنمایی کنه؟ پلاگین های دیگر مثل این خدمات ندارن و من هم کلی وقت سر ترجمه افزونه کردم و قیمت خرید کلی محصولات رو هم توش واردکردم برا همین نمیتونم از افزونه دیگه ای استفاده کنم کسی کمکی میتونه بکنه؟
    • توسط jigsaw
      سلام برای نصب ورد برس و تکمیل بایگاه داده (wp-config-sample) از طریق ویرایش متن اقدام کردم اما بعد اینکه با مرورگر برای ادامه نصب ادرس http://localhost/wordpress/wp-admin/setup-config.phpوارد کردم با خطا عدم شناسایی مواجه شدم (قبلش نام را به wp-config)تغیر دادم اما بعد اینکه خواستم با مرورگر بایگاه تکمیل کنم با خطای 2مواجه شدم خطاها بیوست میکنم کمک لطفا


    • توسط hassan_thari
      سلام من دو ماهه یه سایت رو راه انداختم از هر پنج پستی که تو سایت میزارم سه تاشون ایندکس نمیشه مشکل چی هست؟