8 پست در این موضوع قرار دارد

من قالب comfy روی وردپرسم نصب کردم که از کتابخانه 1.8 استفاده میکنه و توی سیستم وردپرس هم دوتا پلاگین نصب کردم که یکیش اسلایدر خود قالب هست و دومیش news ticker هست.

با توجه به نظر مشتری ی اسلایدر به همرا تکست میخواست که پیشنهادشون featured content slider بود. نسخه وردپرسیش موجود بود اما متاسفانه بعد از نصب از نظر استایل به مشکل برمیخورد و علاوه بر اون ( که مشکل اصلی من هست ) بنابه دلیل قدیمی بودن کتابخونه ش که نسخه 1.5 هست با پلاگین هایی که بالا گفتم تداخل داره و زمان اجرا همشون از کار میفتن.

من خیلی سایت هارو گشتم و انجمن ها رو جستجو کردم. از جمله stackoverflow اما تنها چیزی که دستگیرم شد این بود که از تابع no.conflict استفاده کنم. آزمایش کردم اما متاسفانه مشکل برطرف نشد.

با استفاده از consol مرورگر کروم هم که تست میگیرم این خطا صادر میشه:

Object function (a, B) {return new c.fn.init(a, B)} has no method 'cookie'

لطفا کمک کنید تا مشکلم برطرف بشه

ضمنا اگر آدرس سایت رو میخواید بگید تا از طریق پیام خصوصی بفرستم

به اشتراک گذاری این پست


لینک به پست

سلام

نسخه آخر جی کوئری کمترین تداخل رو داره.

شما برای تست بجای $ ها jQuery بزارید.(البته برای نسخه های جدید جی کوئری)

مورد بعدی، اگر جی کوئری قدیمی در هد صفحه لود شده شما جی کوئری نسخه جدید رو در فوتر لود کنید، بیعین هردو لود بشن، بعد تست کنید اسلاید و تیکر از کار میوفتن یا بازهم کار میکنن.

به اشتراک گذاری این پست


لینک به پست

سلام

نسخه آخر جی کوئری کمترین تداخل رو داره.

شما برای تست بجای $ ها jQuery بزارید.(البته برای نسخه های جدید جی کوئری)

من همه راه هایی که شما گفتین رو قبلا سرچ کردم و امتحان کردم نشد. اون مورد فوتر هم الان انجام دادم تغییری نکرد! :(

به اشتراک گذاری این پست


لینک به پست

پس مشکل از کدنویسی اسلاید و تیکر هست که از توابع قدیمی جی کوئری دارن استفاده میکنن.

تنها راه حل این نوع مشکلات هم یا آپدیت کدها توسط نویسنده هست یا اینکه خودتون آپدیت کنید.

یا در نهایت هر دو رو تعویض از کدهای دیگه ایی استفاده کنید.

به اشتراک گذاری این پست


لینک به پست

اگر کسی هست که بتونه برام آپدیت کنه ممنون میشم.من کارم خیلی گیر کرده. :(

به اشتراک گذاری این پست


لینک به پست

اگر تابعش رو کس دیگه ایی نوشته خیلی سخت هست چون باید همه خط هاش بررسی بشه.

به اشتراک گذاری این پست


لینک به پست

کسی هم نیست که بتونه بنویسه؟

به اشتراک گذاری این پست


لینک به پست

قبلا گفتم، بهتره به دنبال جایگزین برای مواردی که درست کار نمیکنن باشید.

خیلی توی وقتتون صرفه جویی میشه.

مطمئنا موارد زیادی پیدا میکنید.

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط alam7o
      با سلام خدمت دوستان عزیز تداخل jquery یکی از مشلاتی بود که خیلی منو اذیت میکرد و مطمئنا خیلی از کاربرا همین شرایط منو دارن امروز با یه مطلب آموزشی کارم راه افتاد خواستم با کاربران عزیز wp-parsi در میون بذارم تا شما هم دیگه در این زمینه مشکلی نداشته باشید
      خب فرض کنید شما یک کد به این شکل رو در قالبتون میذارید
      <script type="text/javascript"> $(document).ready(function(){ $("#tabsholder").tytabs({ tabinit:"1", fadespeed:"fast" }); }); </script> براتون کار میکنه اما بعد از نصب یه افزونه یا مثلا راه اندازی یک اسلایدر از کار میوفته راه حل بسیار ساده ای داره اونم اینه که ابتدای کد رو به این شکل تغییر بدید
      jQuery(document).ready(function($) { که در نهایت کد ما میشه این
      <script type="text/javascript"> jQuery(document).ready(function($) { $("#tabsholder").tytabs({ tabinit:"1", fadespeed:"fast" }); }); </script> اگر مدیران صلاح دونستن این مطلب رو مهم کنن تا اون دسته از کاربرانی که مثل خود بنده مبتدی هستن همیشه به این مطلب دسترسی داشته باشن تا اینقد تایپیک جدید با همین موضوع نداشته باشیم
      باتشکر
    • توسط pooyacsx
      سلام دوستان
      من یک قالب طراحی کردم با کلی فایل اسکریپت و پوسته حالا مشکلم اینه وقتی افزونه ایی نصب می کنم روی وردپرس افزونه درست بالا نمیاد .اینطور هم که جستجو کردم باید مشکل از کانفیلیکت (conflict) اسکریپت های افزونه با اسکریپت های تم باشه!
      راستش خیلی هم سرچ کردم و دستورالعمل های این سایت هم انجام دادم :
      سایت
      ولی به نتیجه ایی نرسیدم(درست نفهمیدم!!) .
      این کد قسمت لود فایل هام داخل هدر پوستست:
      <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/bootstrap.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/default.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/style.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/responsive.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/camera.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/superfish.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/superfish-navbar.css" type="text/css"/> <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/css/superfish-vertical.css" type="text/css"/> <script src="<?php bloginfo('template_url'); ?>/js/jquery.min.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery.mobile.customized.min.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery.easing.1.3.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/bootstrap.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery.isotope.min.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery.magnific-popup.min.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/scripts.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery-noconflict.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/bootstrap.min.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/camera.min.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/superfish.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery.mobilemenu.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/jquery.hoverIntent.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/supersubs.js" type="text/javascript"></script> <script src="<?php bloginfo('template_url'); ?>/js/sftouchscreen.js" type="text/javascript"></script> می دونم خیلی کیلویی ریختم ولی خب روش درست لودش رو بلد نبودم .
      ممنون میشم دوستان حرفه ایی وقت بزارند و روش درست لود فایل ها که هم سایت سبکتر بیاد بالا هم مشکل با افزونه ها نداشته باشه را با مثال یادم بدهند.
      ممنون
    • توسط DariushGreat
      سلام
      برای سایت تازه‌ای که دارم می‌سازم از افزونه پارسی دیت بهره گرفتم ولی مشکلاتی دارم؛ از جمله این‌که ی و ک عربی رو نمی‌تونه تبدیل به پارسی کنه و شماره‌ها هم کماکان انگلیسی نمایش می‌ده (فونتم ایران سنس هست).
      مشکل دیگه اینه که با کدهای جی‌کوئری bxslider تداخل داره و باعث می‌شه کار نکنن!
      من ناچار شدم از جلالی که قدیمی هم هست بهره بگیرم اونم مشکلات بالا رو داره ولی با این تفاوت که تداخل با کد اسلایدرها تداخل نداره. من با همین پارسی دیت راحت‌ترم و افزونه خیلی خوبیه و دلم می‌خواد این نصب باشه ولی مشکلات داره.
      آیا راه حلی دارید؟
      سپاس از زحماتتون
    • توسط DariushGreat
      سلام
      افزونه lazy load تداخل جی‌کوئری داره و باعث می‌شه عکسا بارگزاری نشن. چی کار کنم؟
      ممنون برای کمک
    • توسط runy
      سلام
      مشکل من اینه که مثلا زمانی که دو ورژن جی کوئری را فراخوانی میکنم که یکی برای اسلاید شو و دیگری برای فرضا پوپ آپ هستند ، یکی از این دو از کار می افتند.
      برای این مشکل راه کاری هست ؟؟