ژیهات

مشکل با افزونه post expirator

18 پست در این موضوع قرار دارد

سلام دوستان

وقتی تاریخ خورشیدی رو فعال میکنم

افزونه post expirator ارور میده

https://wordpress.org/plugins/post-expirator

مشکل کجاست ؟

0

به اشتراک گذاری این پست


لینک به پست

سلام

هنوز با این افزونه همسو نشده

متن خطا رو بزارید اینجا

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)


Warning: mktime() expects parameter 6 to be long, string given in C:\wamp\www\theme\wp-content\plugins\post-expirator\post-expirator.php on line 194

آقا مرتضی نمیشه در صورت غیرفعال بود تاریخ خورشیدی فقط تاریخ پست ها رو به شمسی نشون داد با یه تابع ؟؟

ویرایش شده در توسط ژیهات
0

به اشتراک گذاری این پست


لینک به پست

اگه افزونه غیرفعال باشه که نمیشه از توابعش استفاده کرد

مگه اینکه توابع رو جدا هوک کنین

0

به اشتراک گذاری این پست


لینک به پست

نه که کل افزونه غیرفعال باشه

فقط تیک تاریخ خورشیدی غیر فعال باشه

در این صورت میشه به جای


<?php the_date(); ?>

از تابعی استفاده کرد که تاریخ پست داخل حلقه به صورت شمسی دربیاد ؟

اگر خیر بفرمایید طریقه هوک کردن به چه صورته

0

به اشتراک گذاری این پست


لینک به پست

اگر تیک تابع شمسی رو بردارید تاریخ ها همون پیش فرض انگلیسی نمایش داده میشن

0

به اشتراک گذاری این پست


لینک به پست

چاره کار من چیه ؟

0

به اشتراک گذاری این پست


لینک به پست

الویت های سری دوم ما هماهنگی با این افزونه و چند افزونه دیگه هست

چاره از سمت ما کمی صبر برای شما هست :)

1

به اشتراک گذاری این پست


لینک به پست

با سلام و خدا قوت

من هم این مشکلو دارم میشه راهنمایی نمایید

هنگام فعال سازی ورد پرس فارسی افزونه Post Expirator تاریخاش به هم میریزه

نمبشه کاری کرد این افزونه با همون تارخ میلادی خودش کار کنه ؟

ممنون

0

به اشتراک گذاری این پست


لینک به پست

الویت های سری دوم ما هماهنگی با این افزونه و چند افزونه دیگه هست

چاره از سمت ما کمی صبر برای شما هست :)

با سلام خدمت شما اساتید محترم

بنده نیز مشکل تاریخ شمسی با این افزونه را دارم. ممنون میشد دوستان در این مورد راهنمایی کنن.

با احترام

0

به اشتراک گذاری این پست


لینک به پست

با سلام مجدد

من مشکلمو جایی مطرح کردم یکی از دوستان با تغییراتی در این افزونه این مشکل رو برطرف شد

اینجا لینک آپلود نداره ، اگه دوستان نیاز به این افزونه اصلاح شده دارند درخاستشون رو برام ایمیل کنند

ایمیل من : dstgah@gmail.com

موفق باشید

1

به اشتراک گذاری این پست


لینک به پست

با سلام مجدد

من مشکلمو جایی مطرح کردم یکی از دوستان با تغییراتی در این افزونه این مشکل رو برطرف شد

اینجا لینک آپلود نداره ، اگه دوستان نیاز به این افزونه اصلاح شده دارند درخاستشون رو برام ایمیل کنند

ایمیل من : dstgah@gmail.com

موفق باشید

سلام

روی ویرایشگر پیشرفته بزنید، میتونید فایل اپلود کنید

هم میتونید به گیت هاب افزونه کامیت کنید

0

به اشتراک گذاری این پست


لینک به پست

پچ حل مشکل افزونه‌ی Post Expirator

با استفاده از این پچ، میتونید مشکل Post Expirator رو حل کنید. این پچ به زودی به افزونه، ملحق میشه.

برای نصب پچ، مراحل زیر رو پیگیری کنید:

1. مرحله اول:

فایل PHP ملحق‌شده رو دانلود کنید و در فولدر wp-content/plugins/wp-parsidate/includes/plugins آپلود/کپی کنید.

2. مرحله دوم:

در فولدر wp-content/plugins/wp-parsidate، فایل wp-parsidate.php رو با یه ویرایشگر باز کنید و به دنبال کد زیر بگردید:


$files = array(
'parsidate',
'general',
'fixes-archive',
'fixes-permalinks',
'fixes-dates',
'fixes-misc',
'admin/styles-fix',
'admin/lists-fix',
'admin/other-fix',
'fixes-get_calendar',
'fixes-get_archives',
'plugins/woocommerce',
'widget/widget_archive',
'widget/widget_calendar');

سپس این تکه کد رو با تیکه کد زیر جایگزین کنید:



$files = array(
'parsidate',
'general',
'fixes-archive',
'fixes-permalinks',
'fixes-dates',
'fixes-misc',
'admin/styles-fix',
'admin/lists-fix',
'admin/other-fix',
'fixes-get_calendar',
'fixes-get_archives',
'widget/widget_archive',
'widget/widget_calendar',
'plugins/woocommerce',
'plugins/post-expirator');

3. مرحله سوم

وارد برگه "وردپرس پارسی" بشید و در قسمت هماهنگی با افزونه‌ها، در قسمت Post Expirator، جلوی گزینه Fix?، فعال رو تیک بزنید و پیکربندی رو ذخیره کنید.

حالا باید مشکلتون حل شده باشه.

موفق باشید.

post-expirator.php

1

به اشتراک گذاری این پست


لینک به پست

با سلام خدمت شما

با تشکر از پیگیری شما در حل مشکل

بنده این کار رو انجام اولا تاریخ شمسی نشد ثانیا اخطار

Warning: mktime() expects parameter 6 to be long, string given in ................wp-content\plugins\post-expirator\post-expirator.php on line 194

میده

ثالثا تاریخ مطالب در سایت نشون داده نمیشه.

ممنون میشم راهنمایی کنین.

با احترام

0

به اشتراک گذاری این پست


لینک به پست

باید صبر کنید تا نسخه جدید ارائه بشه، تا 3 هفته دیگه، با یه سری تغییرات اساسی در کارایی افزونه، پلاگین آپدیت میشه ;)

1

به اشتراک گذاری این پست


لینک به پست

دوسال گذشته پس کی آپدیت میشه و با این افزونه هماهنگ میشه

0

به اشتراک گذاری این پست


لینک به پست

ترو خدا یکی این افزونه رو ویرایش کنه و درستش کنه خیلیا نیازدارند

0

به اشتراک گذاری این پست


لینک به پست
در در 5/30/2015 at 12:42، Ehsaan گفته است :

باید صبر کنید تا نسخه جدید ارائه بشه، تا 3 هفته دیگه، با یه سری تغییرات اساسی در کارایی افزونه، پلاگین آپدیت میشه ;)

؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری