elshan

فعال کردن جی کوئری

26 پست در این موضوع قرار دارد

درود بر تمام دوستان.بنده چطوری می تونم جی کوئری رو برای سایتم فعال کنم.یه افزونه ای نصب کردم(افزونه ی منوی آباشری بالای سایت) که یه قسمتی که که منو ها با افکت باز بشن ولی وقتی فعال می کنم این قابلیت رو افزونه به درستی کار نمی کنه.تو سایت سازندش نوشته اگه هنگام فعال سازی قابلیت افکت افزونه کار نکرد مشکل از جی کوئری سایتتون هست.حالا باید چجوری این مشکل رو حل کنم؟

0

به اشتراک گذاری این پست


لینک به پست

آخرین نسخه جی کوئری رو به سایتتون اضافه کنید .

1

به اشتراک گذاری این پست


لینک به پست

آخرین نسخه جی کوئری رو به سایتتون اضافه کنید .

سلام. می دونم باید اضافه کنم امام نمی دونم چطوری؟؟!!

0

به اشتراک گذاری این پست


لینک به پست

اینو به فانکشن اضافه کنید


wp_enqueue_script("jquery");

3

به اشتراک گذاری این پست


لینک به پست

وقتی این رو اضافه می کنم اصلا سایت بالا نمی یاد؟؟؟!!!

0

به اشتراک گذاری این پست


لینک به پست

بعد از نگ php اضافه میکنید؟

0

به اشتراک گذاری این پست


لینک به پست

بعد از نگ php اضافه میکنید؟

کلا کدی که شما گفتین رو به آخرش اضافه می کنم

0

به اشتراک گذاری این پست


لینک به پست

به این صورت اضافه میکنید دیگه ؟


<?php wp_enqueue_script("jquery"); ?>

2

به اشتراک گذاری این پست


لینک به پست

به این صورت اضافه میکنید دیگه ؟


<?php wp_enqueue_script("jquery"); ?>

این رو به فانکشن اضافه کنم یا هدر؟

0

به اشتراک گذاری این پست


لینک به پست

به فانکشن

1

به اشتراک گذاری این پست


لینک به پست

به فانکشن

از کجا بدونم جی کوئری سایتم فعاله و مشکلی نداره؟

0

به اشتراک گذاری این پست


لینک به پست

خوب توی مرورگر view source رو بزنید و ببینید که توی کدهای فایل jquery.js وجود داره یا خیر.

1

به اشتراک گذاری این پست


لینک به پست

خوب توی مرورگر view source رو بزنید و ببینید که توی کدهای فایل jquery.js وجود داره یا خیر.

اقای گرانسایه لطف می کنید بگین کلا چجوری جی کوئری سایتم رو هم فعال کنم هم به آخرین نسخه ارتقا بدم؟ تشکر

0

به اشتراک گذاری این پست


لینک به پست

برای فعال کردن #4

برای آخرین نسخه کردنش هم به آدرس زیر برید و فایل نسخه جدید جی کوئری رو جایگزین کنید:

wp-includes/js/jquery/jquery.js

1

به اشتراک گذاری این پست


لینک به پست

برای فعال کردن #4

برای آخرین نسخه کردنش هم به آدرس زیر برید و فایل نسخه جدید جی کوئری رو جایگزین کنید:

wp-includes/js/jquery/jquery.js

سلام تو سایت جی کوئری اسم آخرین نسخه jquery-1.8.2.js هستش ولی تو وردپرس فقط jquery.js هستش .مشکلی پیش نمی یاد؟

برای فعال کردن #4

برای آخرین نسخه کردنش هم به آدرس زیر برید و فایل نسخه جدید جی کوئری رو جایگزین کنید:

wp-includes/js/jquery/jquery.js

بنده محتویات جی کوئری جدی رو توی آدرسی که دادید ریختم و ذخیره کردم.یعنی جی کوئری قدیمی کدهاش رو پاک کردم و جدید رو به جاش ریختم.این کار درسته؟

تو سایت افزونه این رو نوشته:

if dropdown doesn’t work with effects turned on, you may have some problem with your jQuery version.

لازم به ذکر است که من از جی کوئری برای دکمه بالا بر هم استفاده می کنم که کدهاش در زیر آوردم:

<!-- jquery -->

<script src="http://elshan-graphic.ir/site-theme/js/jquery-1.8.2.min.js" type="text/javascript"></script>

<!-- easing plugin ( optional ) -->

<script src="http://elshan-graphic.ir/site-theme/js/easing.js" type="text/javascript"></script>

<!-- UItoTop plugin -->

<script src="http://elshan-graphic.ir/site-theme/js/jquery.ui.totop.js" type="text/javascript"></script>

<script type="text/javascript">

0

به اشتراک گذاری این پست


لینک به پست

یه سورس از سایتم گرفتم.به این کد دقت کنید

<script type='text/javascript' src='http://elshan-graphi...ry.js?ver=1.7.2'></script>

این داره ورژن 1.7.2 رو لود میکنه اما آخرین ورژن 1.8.2 هستش.چطوری این کد رو تغییر بدم؟

0

به اشتراک گذاری این پست


لینک به پست

ادرسش بشه این:

http://elshan-graphic.ir/wp-includes/js/jquery/jquery.js?ver=1.8.2

1

به اشتراک گذاری این پست


لینک به پست

ادرسش بشه این:

http://elshan-graphic.ir/wp-includes/js/jquery/jquery.js?ver=1.8.2

سلام می دونم باید بشه اون.ولی می دونم اون کد رو چجوری جایکزین کنم(تغییر بدم)؟؟

0

به اشتراک گذاری این پست


لینک به پست

<?php
function my_scripts_method() {
wp_deregister_script( 'jquery' );
wp_register_script( 'jquery', get_bloginfo('url')."/wp-includes/js/jquery/jquery.js", false, '1.8.2');
}
add_action('wp_enqueue_scripts', 'my_scripts_method');
?>

1

به اشتراک گذاری این پست


لینک به پست


<?php
function my_scripts_method() {
wp_deregister_script( 'jquery' );
wp_register_script( 'jquery', get_bloginfo('url')."/wp-includes/js/jquery/jquery.js", false, '1.8.2');
}
add_action('wp_enqueue_scripts', 'my_scripts_method');
?>

تو فانکشن؟

تو فانکشن؟

وقتی این کد رو تو فانکشن میزارم بالابر هم اصلا نشون نمی ده!!؟؟؟

0

به اشتراک گذاری این پست


لینک به پست

کد بالا در فانکشن قرار میگیره.

احتمالا بالابر در سایت شما با نسخه جدید جی کوئری سازگار نیست.

باید دنبال کد دیگه ایی باشید.

1

به اشتراک گذاری این پست


لینک به پست

کد بالا در فانکشن قرار میگیره.

احتمالا بالابر در سایت شما با نسخه جدید جی کوئری سازگار نیست.

باید دنبال کد دیگه ایی باشید.

آخه مشکل اینجاست که وقتی اون کد رو قرار می دم نه بالابر کار می کنه و نه منوی بالای سایت!!

0

به اشتراک گذاری این پست


لینک به پست

اینها مشکلات تداخل توابع هستن.

آدرس زیر رو هم مطالعه کنید:

http://codex.wordpress.org/Function_Reference/wp_enqueue_script#jQuery_noConflict_wrappers

2

به اشتراک گذاری این پست


لینک به پست

اینها مشکلات تداخل توابع هستن.

آدرس زیر رو هم مطالعه کنید:

http://codex.wordpress.org/Function_Reference/wp_enqueue_script#jQuery_noConflict_wrappers

چطوری می تونم از این تداخل جلوگیری کنم.راستی آدرس بالا چرا فیلتر هست؟؟

0

به اشتراک گذاری این پست


لینک به پست

توی همون آدرس بالا برای رفع تداخلیک راه مطرح شده.

بخش کدکس وردپرس خیلی وقته فیـلتر شده.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط reza_yki
      سلام من ابزارکی نوشتم که کاربر بتونه به وسیله select option به صورتی multi بتونه چندین دسته رو انتخاب کنه همه چیز درست و بدون مشکل کار میکنه فقط یه مشکل هست اونم اینه که وقتی ابزارک رو برای اولین بار فعال میکنی خطای زیر رو میده وباید یه دونه دسته رو انتخاب و ذخیره کنی تا ابزارک به صورت صحیح کارکنه لطفا راهنماییم کنید.
      Warning: in_array() expects parameter 2 to be array, string given in E:\Program Files\xampp\htdocs\wordpress\wp-content\themes\mymag\functions\widgets\widgets.php on line 29  
      اینم سورس کد:
      <?php public function form( $instance ) { $title = ! empty( $instance['title'] ) ? $instance['title'] : esc_html__( 'عنوان ابزارک', 'text_domain' ); $args = array( 'hide_empty' => 0, 'type' => 'post', 'taxonomy' => 'category', 'orderby' => 'name', 'hierarchical' => true, ); $cats = get_categories( $args ); $instance['cat_id'] = isset( $instance['cat_id'] ) ? ( $instance['cat_id'] ) : '1'; $count_cat = isset ($instance['cat_id']) ? count($instance['cat_id']) : '1' ; $tab_number = isset( $count_cat ) ? absint( $count_cat ) : 1; ?> <p> <label for="<?php echo $this->get_field_name( 'title' ); ?>"><?php _e( 'Title:' ); ?></label><br> <input class="widefat" id="<?php echo $this->get_field_id( 'title' ); ?>" name="<?php echo $this->get_field_name( 'title' ); ?>" type="text" value="<?php echo esc_attr( $title ); ?>" /> </p> <p> <label for="<?php echo $this->get_field_id('tab_number'); ?>"><?php _e( 'تعداد زبانه:'); ?></label><br> <input id="<?php echo $this->get_field_id('tab_number'); ?>" name="<?php echo $this->get_field_name('tab_number'); ?>" type="number" min="0" class="my_widget_number" value="<?php echo $tab_number; ?>" size="3" /> </p> <label for="<?php echo $this->get_field_name( 'cat_id' ); ?>"><?php _e( 'انتخاب دسته بندی : ' ); ?></label> <select id="<?php echo $this->get_field_id( 'cat_id' ); ?>" name="<?php echo $this->get_field_name( 'cat_id[]' ); ?>" multiple="multiple" style="width: 100%; margin: 10px auto; height: auto;"> <?php foreach( $cats as $cat ): ?> <option value="<?php echo esc_attr(__($cat->term_id)); ?>"<?php selected(in_array($cat->term_id, $instance['cat_id'])); // selected($cat->term_id,$cats_id) ?>><?php echo esc_attr(__($cat->name)); ?></option> <?php endforeach; ?> </select> <p> <input type="text" value="<?php echo esc_attr(__(implode(',', $instance['cat_id']))); ?>"> </p> <?php }  
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟
    • توسط hamid_diablo
      سلام دوستان
      من وردپرس رو روی لوکال هاست نصب کرده بودم
       
      تا چند روز پیش مشکلی نداشتم تا اینکه یه پوسته جدید نصب کردم و بعد از اون متاسفانه وردپرس بالا نیامد (صفحه سفید ظاهر شد )
       
      فقط قالب صحیفه رو نمایش میده بدون پیشخوان!!!
       
      وردپرس و پاک کردم و دوباره روی لوکال هسات نصب کردم اما مشکل برطرف نشد !
      ممنون میشم راهنماییم کنید
    • توسط ahmadwp
      سلام خدمت اعضای گرامی.
      در وردپرس فارسی نسخه ۴.۸.۲ مشکلی رو پیدا کردم که راهکاری برای حلش به ذهنم نرسید، ممنون می شم راهنمایی کنید تا حلش کنم.
      وقتی یک قسمت از متن رو انتخاب می کنم و می خوام به اون لینک بدم، وقتی که می خوام بر روی آیکون تیک تا تایید کلیک کنم یا وقتی که می خوام بر روی آیکون چرخ دنده کلیک کنم، پاپ آپ درج لینک هی ظاهر می شه و دوباره محو می شه! و نمی شه بر روی اون آیکون ها کلیک کرد و گزینه ها رو انتخاب کرد.
      ابتدا تصور کردم شاید مشکل از تداخل افزونه ها باشه یا قالب مشکلی داشته باشه یا هنگام به روز رسانی خطایی به وجود اومده باشه، اما وقتی بسته نصبی وردپرس رو مجددا از wp-persian دریافت کردم و بر روی یک فضای دیگه نصب کردم، دیدم که از ابتدا همین مشکل وجود داره، افزونه wp-jalali رو هم غیرفعال کردم اما مشکل حل نشد!
      یعنی چه از ابتدا دریافت و نصب کنین، چه وردپرس قدیمی تر سایت تون رو آپدیت کنین به این نسخه فارسی، همین مشکل براش به وجود میاد.
      یک ویدیو پیوست همین مطلب کردم که به خوبی این مورد رو نشون می ده. سپاسگزارم.
      Video_2017-10-21_110732.wmv