العبد

ریدایرکت شدن صفحه دوم سایت

5 پست در این موضوع قرار دارد

با سلام

سال نوتون مبارک.امیدوارم سال خوبی داشته باشین

می خواستم از دوستان در مورد مشکلی که با ریدایرکت شدن صفحاتم دارم راهنمایی بخوام.به تازگی تعداد پست هام به اندازه ای شد که صفحه دوم ایجاد شد.اما وقتی میخوام برم به اون صفحه ریدایرکت میشم به صفحه اصلی سایت.متاسفانه با نصب افزونه pagenavi هم مشکل حل نشد.

آدرس صفحه اصلی

آدرس صفحه دوم

ممنون میشم دوستان راهنمایی کنن

با تشکر

0

به اشتراک گذاری این پست


لینک به پست

حلقه مطلب صفحه اصلی شما به چه شکل است؟ از wp_query استفاده کردید.

من خودم هیچ تغییری تو کدهای قالب ندادم.

برای این که متوجه بشم استفاده شده یا نه، کدوم فایل قالب رو باید نگاه کنم؟..چه تغییری باید بدم؟

با تشکر

0

به اشتراک گذاری این پست


لینک به پست

ببخشید من مبتدیم..نمی دونم استفاده شده یا نه

فکر کنم این کدهای مربوط به پیج ها باشه:(themes/Aggregate/includes/entry.php)


<?php
if ( is_home() ) {
$args=array(
'showposts'=> (int) get_option('aggregate_homepage_posts'),
'paged'=>$paged,
'category__not_in' => (array) get_option('aggregate_exlcats_recent')
);
if (get_option('aggregate_duplicate') == 'false') {
global $ids;
$args['post__not_in'] = $ids;
}
query_posts($args);
global $paged;
}
$i = 0;
?>
<?php
if (have_posts()) : while (have_posts()) : the_post(); ?>
<?php
$i++;
$et_is_latest_post = ( $paged == 0 && ( is_home() && $i <= 2 ) ) || !is_home();
?>
<div class="post entry clearfix<?php if ( $et_is_latest_post ) echo ' latest'; ?>">
<?php
$thumb = '';
$width = $et_is_latest_post ? 130 : 67;
$height = $et_is_latest_post ? 130 : 67;
$classtext = 'post-thumb';
$titletext = get_the_title();
$thumbnail = get_thumbnail($width,$height,$classtext,$titletext,$titletext,false,'Entry');
$thumb = $thumbnail["thumb"];
?>

<?php if($thumb <> '' && get_option('aggregate_thumbnails_index') == 'on') { ?>
<div class="thumb">
<a href="<?php the_permalink(); ?>">
<?php print_thumbnail($thumb, $thumbnail["use_timthumb"], $titletext, $width, $height, $classtext); ?>
<span class="overlay"></span>
</a>
</div> <!-- end .post-thumbnail -->
<?php } ?>

<h3 class="title"><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h3>
<?php get_template_part('includes/postinfo'); ?>
<?php if (get_option('aggregate_blog_style') == 'on') the_content(''); else { ?>
<?php
$et_excerpt_length = $et_is_latest_post && is_home() ? 215 : 80;
if ( !is_home() ) $et_excerpt_length = 140;
?>
<p><?php truncate_post($et_excerpt_length); ?></p>
<?php }; ?>
<a href="<?php the_permalink(); ?>" class="more"><span><?php esc_html_e('Read More','Aggregate'); ?></span></a>
</div> <!-- end .post-->
<?php endwhile; ?>
<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); }
else { ?>
<?php get_template_part('includes/navigation','entry'); ?>
<?php } ?>
<?php else : ?>
<?php get_template_part('includes/no-results','entry'); ?>
<?php endif; wp_reset_query(); ?>

این هم فایل قالب به صورت کامل

خیلی ممنون

0

به اشتراک گذاری این پست


لینک به پست

دوستان میشه لطف کنن بگن چه کار انجام بدم تا مشکل حل بشه؟

حتی اگر کلا صفحه بندی رو غیرفعال کنم بهتر از این وضعیته که کاربر کلیک کنه ولی برگرده صفحه اصلی دوباره

با تشکر

0

به اشتراک گذاری این پست


لینک به پست

فعلا تعداد پست های صفحه اول رو از 7 به 10 افزایش دادم که صفحه دوم ساخته نشه.ولی مطمئنا دیر یا زود مطالبم بیشتز از 10 تا میشه و دوباره صفحه دوم ایجاد میشه.

دوستان اگه لطف کنن یه راهنمایی کنن که حداقل بدونم مشکل از چی هست تا برم دنبال حلش ممنون میشم

با تشکر

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط alireza_hsi
      سلام.
      متاسفانه درگیر همان مشکل قدیمی شدم.
      بعد از لاگین با ادمین بجای باز شدن پیج داشبورد به پیج سایت میرم و البته با همون یوزر ادمین لاگین هم هست.
      خیلی توی وب گشتم راههای زیادی رو تست کردم که بیشتر سایتها  کپی هم گذاشتند اما نشد و گاهی بدتر هم شد.
      بنظر میاد دسترسی ادمین به داشبورد بلاک شده چون لینک داشبورد کا رمیکنه ومشکلی نداره.
      ممنون میشم کسی که این مشکل رو قبلا حل کرده جواب دقیق بده.
       
    • توسط Mehdi1988
      سلام دوستان
      من یه سایت چند زبانه دارم که زبان اصلی یعنی فارسی رو گذاشتم روی xyz.net و زبان انگلیسی رو گذاشتم روی xyz.net/en
      میخوام کسانی که با IP غیر ایرانی xyz.net  رو میزنن ریدایرکت بشن به xyz.net/en ، چیکار باید بکنم؟
    • توسط unid_user
      سلام و درود
      دوستان گرامی امروز با یه مشکلی برخوردم که نمیدونم چطور باید برطرفش کنم.
      توی گوگل وبمستر خواستم از fetch as google استفاده کنم که خطای زیر رو نشون داد. سرچ کردم و متوجه شدم از https هست یعنی http رو ریدایرکت کرده رو https چه باید کرد؟
      آیا مشکلی برای سئو هست یا نه؟
       
      ممنون

    • توسط mohammad_mh
      سلام
      دوستان خسته نباشید
      یک مشکل برام پیش اومده که سرعت سایت هم کند کرده
      این هست که دامنه اصلی داره ریدایرکت میشه از HTTP به HTTPS و تو سایت های آنالیز مثل gtmetrix ایراد گرفته
      مورد بعدی داره ریدایرکت میشه به دامنه خودم ولی دنبال دامنه یک آدرس اومده ?post=5875&action=edit
      ولی همان صفحه نخست خودم میاد
      حالا میخوام کاری کنم به حالت طبیعی برگرده و دامنه بدون کاراکتر اضافه بیاد یا این ریدایرکت http برداشته بشه چون خیلی از سایت های دیگه ssl دارن ولی gtmetrix ایرادی نگرفته
      افزونه ریدایرکت نصب نکردم و از تو yoast seo هم بررسی کردم لینک صفحه نخست به لینک دیگه ای ریدایرکت نشده
      از تو سی پنل میشه درست کرد؟
      ممنون میشم راهنمایی کنید