solmaz

ارور ساخت نقشه سایت با استفاده از افزونه Yoast WordPress SEO

26 پست در این موضوع قرار دارد

سلام

من از افزونه Yoast WordPress SEO برای seo استفاده میکنم ولی وقتی xml sitemap رو میزنم با ارور مواجه میشم که عکسش رو براتون گذاشتم

مشکل چی هست؟

ممنون

post-1542-0-90718800-1432309287_thumb.jp

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

قالبتون رو به دیفالت ( قالب پیشفرض پس از نصب وردپرس ) تغییر دهید ، سپس تست کنید ببینید سایت مپ کار میکنه یا خیر .

موفق باشید .

ویرایش شده در توسط محمدرضـا
0

به اشتراک گذاری این پست


لینک به پست

متسفانه من پوسته های پیش فرض وردپرس رو پاک کردم

0

به اشتراک گذاری این پست


لینک به پست

پوسته 2014 وردپرس رو نصب کردم اونم همین مشکل رو داره

قفط اروری که میده در لاین 2 هست

قیلی در لاین 3 بود

0

به اشتراک گذاری این پست


لینک به پست

شاید مشکل از افزونه سایت مپ میباشد .

1. تمامی افزونه های خود را آپدیت کنید .

2. سپس افزونه سایت مپ فعلی خود را حذف کنید و

3. این افزونه رو نصب کنید :

لینک صفحه : https://wordpress.org/plugins/google-sitemap-generator/

لینک دانلود : https://downloads.wordpress.org/plugin/google-sitemap-generator.4.0.8.zip

0

به اشتراک گذاری این پست


لینک به پست

ببخشید من از افزونه

Yoast WordPress SEO استفاده میکنم و میخواستم مشکل با این افزونه حل بشه میخوام بدونم مشکل با این افزونه از کجاست

0

به اشتراک گذاری این پست


لینک به پست

من از این افزونه که معرفی کردید هم استفاده کردم ولی باز هم همین ارور هست

واقعا باید چیکار کنم

0

به اشتراک گذاری این پست


لینک به پست

سلام ، تنها افزونه مربوط به نقشه سایتتون همین افزونه هست؟

افزونه های دیگه رو از جمله google sitemap generator رو غیرفعّال و حذف کنید.

افزونه درست کار میکنه و سایت مپ رو ساخته ، منتهی اینکار رو اشتباه انجام داده (به احتمال زیاد به صورت دستی عوض یا با افزونه ای مغایرت داره)

کدی رو که باید در خط اوّل استفاده میکرد در خط سوم استفاده کرده.

آدرس سایت مپتون رو بذارید تا بررسی کنیم.

1

به اشتراک گذاری این پست


لینک به پست

الان دقیقا همون ارور اومد

نمیدونم چرا اینجوری میشه

همه افزونه ها رو غیر فعال کردم ولی این ارور هنوز هست

چیکار میشه کرد؟

0

به اشتراک گذاری این پست


لینک به پست

به بخش مدیریت برید

بخش ساخت نقشه سایت این افزونه را غیر فعال کنید و مطمئن بشید که نقشه سایت حذف شده بعد دوباره فعال کنید و ذخیره بزنید

0

به اشتراک گذاری این پست


لینک به پست

مشکل همچنان باقی است

حالا کاری که من کردم اینه:

همین آدرس نقشه سایت رو در گوگل وب مستر که اتفاقا ثبت هم شد ولی با دو تا ارور

عکسش رو براتون گذاشتم

post-1542-0-12301400-1432400496_thumb.jp

0

به اشتراک گذاری این پست


لینک به پست

روی دوتا ارور کلیک کنید ببینید ارورها چی هستن

0

به اشتراک گذاری این پست


لینک به پست

لینک دو تا نقشه هایی که توی این فایله ارور 404 میده (وجود ندارن) بازم راهکارم راه حل قبلی هست

تمامی افزونه های نقشه سایت رو غیر فعال کنید

بعد بخش نقشه سایت رو غیر فعال کنید ذخیره بزنید

دوباره فعالش کنید ذخیره بزنید

1

به اشتراک گذاری این پست


لینک به پست

من همه اقزونه هامو غیر فعال کردم اما حل نشد

0

به اشتراک گذاری این پست


لینک به پست

بنده قبلا با این اررور مواجه شده بودم و دلیل آن استاندارد نبودن قالب بود .

قالب استاندارد وردپرس ("دو هزار و سیزده") - ("twentythirteen") پیوست شده و روی سایتتون اجرا کنید .

چک کنید و سپس اطلاع بدید .

twentythirteen.zip

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

:| پووووف...

_______

مشکل به خاطر نحوه ساخته شدن سایت مپ شماست.

به سایت مپتون توجّه کنید:

<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="//www.charismaco.com/main-sitemap.xsl"?>

<sitemapindex xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">

<sitemap>

<loc>http://www.charismaco.com/post-sitemap.xml</loc>

<lastmod>2015-05-24T14:58:39+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/page-sitemap.xml</loc>

<lastmod>2015-05-24T08:32:28+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/attachment-sitemap.xml</loc>

<lastmod>2015-05-20T16:27:28+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_portfolio-sitemap.xml</loc>

<lastmod>2013-08-08T11:36:42+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_testimonials-sitemap.xml</loc>

<lastmod>2013-08-08T12:27:29+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_team-sitemap.xml</loc>

<lastmod>2015-05-23T18:36:52+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_logos-sitemap.xml</loc>

<lastmod>2013-08-20T15:00:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_benefits-sitemap.xml</loc>

<lastmod>2013-09-11T08:23:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_gallery-sitemap.xml</loc>

<lastmod>2015-05-16T09:35:55+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_slideshow-sitemap.xml</loc>

<lastmod>2015-03-31T13:46:22+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/category-sitemap.xml</loc>

<lastmod>2015-05-24T14:58:39+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/post_tag-sitemap.xml</loc>

<lastmod>2015-05-24T14:58:39+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_portfolio_category-sitemap.xml</loc>

<lastmod>2013-08-08T11:36:42+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_testimonials_category-sitemap.xml</loc>

<lastmod>2013-08-08T12:27:29+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_team_category-sitemap.xml</loc>

<lastmod>2015-05-23T18:36:52+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_logos_category-sitemap.xml</loc>

<lastmod>2013-08-20T15:00:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_benefits_category-sitemap.xml</loc>

<lastmod>2013-09-11T08:23:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_gallery_category-sitemap.xml</loc>

<lastmod>2015-05-16T09:35:55+00:00</lastmod>

</sitemap>

</sitemapindex>

<!-- XML Sitemap generated by Yoast WordPress SEO -->

سایت مپ شما از خط سوم شروع شده که باید از خط اوّل شروع میشد!

خطا های گوگل ربطی به مشکل نمایش سایت مپ شما نداره ، درواقع اون گفته که 2 تا از زیر سایت مپ هاتون وجود خارجی نداره (یا دسترسی هاش بسته شده)

___

ارور نمایش مرورگر به این دلیل هست که فایل های XML که حامل اطلاعات است باید در خط اوّل توضیحاتش داده بشه

یعنی:

<?xml version="1.0" encoding="UTF-8"?>

این کد که داخل خط سوم هست باید بیاد به خط اوّل

یعنی اینجوری:

<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="//www.charismaco.com/main-sitemap.xsl"?>

<sitemapindex xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">

<sitemap>

<loc>http://www.charismaco.com/post-sitemap.xml</loc>

<lastmod>2015-05-24T14:58:39+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/page-sitemap.xml</loc>

<lastmod>2015-05-24T08:32:28+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/attachment-sitemap.xml</loc>

<lastmod>2015-05-20T16:27:28+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_portfolio-sitemap.xml</loc>

<lastmod>2013-08-08T11:36:42+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_testimonials-sitemap.xml</loc>

<lastmod>2013-08-08T12:27:29+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_team-sitemap.xml</loc>

<lastmod>2015-05-23T18:36:52+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_logos-sitemap.xml</loc>

<lastmod>2013-08-20T15:00:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_benefits-sitemap.xml</loc>

<lastmod>2013-09-11T08:23:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_gallery-sitemap.xml</loc>

<lastmod>2015-05-16T09:35:55+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_slideshow-sitemap.xml</loc>

<lastmod>2015-03-31T13:46:22+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/category-sitemap.xml</loc>

<lastmod>2015-05-24T14:58:39+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/post_tag-sitemap.xml</loc>

<lastmod>2015-05-24T14:58:39+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_portfolio_category-sitemap.xml</loc>

<lastmod>2013-08-08T11:36:42+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_testimonials_category-sitemap.xml</loc>

<lastmod>2013-08-08T12:27:29+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_team_category-sitemap.xml</loc>

<lastmod>2015-05-23T18:36:52+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_logos_category-sitemap.xml</loc>

<lastmod>2013-08-20T15:00:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_benefits_category-sitemap.xml</loc>

<lastmod>2013-09-11T08:23:03+00:00</lastmod>

</sitemap>

<sitemap>

<loc>http://www.charismaco.com/dt_gallery_category-sitemap.xml</loc>

<lastmod>2015-05-16T09:35:55+00:00</lastmod>

</sitemap>

</sitemapindex>

<!-- XML Sitemap generated by Yoast WordPress SEO -->

یعنی با گذاشتن کد بالا در سایت مپتون ارور به صورت موقّت حل میشه!

ولی خب باید بگردید که ارور از کجا ناشی شده!

پیشنهاد من اینکه افزونه رو 1: غیرفعّال و 2: دوباره به روز رسانی کنید (برای به روزرسانی دستی دوباره افزونه باید وارد ویرایشگرش بشید و ورژنش رو 1 عدد به قبل تغییر بدید)

2: قسمت سایت مپ افزونه رو غیرفعّال کنید.

3: سایت مپ رو پاک کنید.

4: تنظیمات افزونه رو به حالت اوّلیّه برگدونین.

5: سایت مپ افزونه رو دوباره فعّال کنید انشاءالله مشکل حل خواهد شد.

اگر این اتفّاق نیفتاد من دیگه چیزی به ذهنم نمیرسه ، میتونید قسمت سایت مپش رو غیرفعّال و از افزونه های مشابه استفاده کنید یا اینکه به صورت دستی همونطور که گفتم فایل رو هر از چند گاهی ویرایش کنید...

(البتّه عذر میخوام سایت مپ آماده کرده شدم توسط انجمن خراب شد. فایل اصلی رو نتونستم پیوست کنم ، شما همون فایل خودتون رو 3 خط خالی اوّل رو پاک کنید.)

ویرایش شده در توسط علی زینلی
1

به اشتراک گذاری این پست


لینک به پست

با سلام

ازتون بخاطر وقتی که میزارید و جواب میدید تشکر میکنم

فایلی که توضیح دادید و قراره من دو تا خط اولش رو پاک کنم تا به صورت موقت فعلا درست بشه کجا هست اون فایل رو پیدا نکردم تا این ویرایش رو انجام بدم

من از پلاگین seo by yoast استفاده میکنم

0

به اشتراک گذاری این پست


لینک به پست

http://www.charismaco.com/sitemap_index.xml

توی این آدرس هست دیگه! اوّل اون روشی که گفتم شاید درست بشه باهاش انجام بدین اگر نشد اینکار رو بکنید یا از افزونه های دیگه برای انجام اینکار استفاده کنید.

1

به اشتراک گذاری این پست


لینک به پست

قربان ، اگر مشکلتان حل نشد ، به طور موقت شما میتونید به صورت دستی نیز سایت مپ ایجاد کنید . (بدون افزونه)

این صفحه از گوگل رو مشاهده کنید :

موفق باشید .

1

به اشتراک گذاری این پست


لینک به پست

منم چنین مشکلی دارم

0

به اشتراک گذاری این پست


لینک به پست

سلام

این مشکل بخاطر وجود فضای خالی در بین کدها (ظاهرا کدهای ابتدایی فایل header.php) هست. مطمئن بشید فضاهای خالی بین کدهای قالبتون کاملا حذف شده.

 

منبع

منبع

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط somy
      سلام
      من از قالب فروشگاهی دیجی کالا برای فروشگاه استفاده می کنم. متاسفانه صفحه بندی محصولات کار نمی کند و روی هر صفحه ای کلیک می شود فقط محصولات صفحه اول را نشان می دهد. مشکل از افزونه خاصی هم نیست، میشه راهنمایی بفرمایید که مشکل از چی میتونه باشه و چه جوری می شه رفعش کرد، چون اونجایی که قالب رو ازش خریداری کردیم پاسخگو نیستن. اگه راه حل خاصی دارید ممنون میشم بفرمایید، بسیار ضروری است.
    • توسط fashionir
      درود، دوستان من یک وب سایت دارم می خوام توسط یک افزونه تمام مزون های تهران رو با اطلاعاتشون معرفی کنم، لطفا افزونه ای برای این کار معرفی کنید، بسیار متشکرم.
    • توسط رضا مهدیار
      سلام دوستان
      گروه ما برای بخش سایت و مدیریت رسانه های اجتماعی با یک فرد با انگیزه تمایل همکاری داره، رسانه ما در زمینه فینتک و اقتصاد هستش ممنون میشم از دوستان اگر  خودتون تمایل دارید یا کسی رو میشناسید معرفی کنید ممنونم
    • توسط marketdl.com@gmail.com
      با سلام. وقت همگی بخیر
      بنده یه قالب فروشگاهی رو طراحی کردم. الان بخش سبد خرید ، عضویت و لاگین و کدتخفیف مشکل داره
      بخش سبد خرید : وقتی کاربر لاگین باشه سبد خرید به درستی کار میکنه، اما وقتی لاگین نباشه نمیتونه 2 تا محصول به سبد اضافه کنه. آدرس سایت هم androidsrc.ir هستش. خودتون تست کنید.
      بخش عضویت و لاگین : بخش عضویت درسته و اطلاعات کاربر پس از عضویت داخل دیتابیس ذخیره میشه، اما توی بخش کاربران وردپرس نمیاد. لاگین هم اصلا کار نمیکنه
      بخش کدتخفیف هم اصلا کار نمیکنه
       
      درضمن سایت بنده قبلا قالبش یه چیز دیگه بود و وردپرس نسخه پایین روش نصب بود، به خاطر اینکه نمی شد وردپرس رو آپدیت کنم، مجبور شدن قالب جدید طراحی کنم تا با وردپرس و ووکامرس جدید همخونی داشته باشه. یه سری اطلاعات از قبل مصل محصول و پست و کاربر وجود داشته. و الان این مشکلات به وجود اومده
      هر کسی میتونه مشکل رفع کنه بنده هزینش رو پرداخت میکنم
    • توسط masoudmosleh267
      سلام دوستان. من یه سایتی رو از بکاپ گرفتم و از یه هاست و دامنه به یه هاست و دامنه جدید انتقال دادم. حالا چه سایت رو که باز میکنم چه وارد پیشخوان وردپرس میشم یه ارور میاد یکی از خطلی functions.php قالب رو نشون میده.
      Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /public_html/wp-content/themes/khadamator/functions.php on line 1132
      مشکل چیه؟