yaserr

مشکل ~ اجرا نشدن ایجکس ( افزودن به سبد ، برگه تسویه حساب ، آپلود عکس )

14 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام خدمت اساتید گرامی..

یه سوال فنی راجع به وردپرس و ووکامرس داشتم هرجا سوالمو پرسیدم کسی جوابی نداد.

من یه سایتی با ووکامرس بالا آوردم امروز به یه مشکلی خوردم . ایجکس ووکامرس کار نمیکنه.

یعنی وقتی روی اضافه به سبد کلیک میکنم اتفاقی نمیفته فقط میچرخه و پیغامی نمیده.

بعد که صفحه رو ریلود میکنم میبینم به سبد اضافه شده .

توی صفحه ی تسویه حساب هم همینجوره، برگه سفارش رو باز نمیکنه فقط سعی میکنه لود کنه.

ممنون میشم اگه راهنمایی کنید.

:wacko::(:blink::wacko:

اینم آدرس سایت : sariosadeh.com

ویرایش شده در توسط yaserr
0

به اشتراک گذاری این پست


لینک به پست

فکر میکنم مشکل تداخل جی کوئری هست

آخریم افزونه هایی که نصب کردید رو دونه دونه غیر فعال کنید تا ببینید مشکل از کدومشون

شایدم چیزی به قالب اضافه کردید که باعث این تداخل شده

برای اطلاعات بیشتر تداخل جی کوئری رو توی گوگل سرچ کنید!

1

به اشتراک گذاری این پست


لینک به پست

فکر میکنم مشکل تداخل جی کوئری هست

آخریم افزونه هایی که نصب کردید رو دونه دونه غیر فعال کنید تا ببینید مشکل از کدومشون

شایدم چیزی به قالب اضافه کردید که باعث این تداخل شده

برای اطلاعات بیشتر تداخل جی کوئری رو توی گوگل سرچ کنید!

جناب رسولی همین کارارو هم کردم .

مشکل از افزونه نیست.

ممنون میشم بازم کمک کنید

0

به اشتراک گذاری این پست


لینک به پست

فکر میکنم مشکل تداخل جی کوئری هست

آخریم افزونه هایی که نصب کردید رو دونه دونه غیر فعال کنید تا ببینید مشکل از کدومشون

شایدم چیزی به قالب اضافه کردید که باعث این تداخل شده

برای اطلاعات بیشتر تداخل جی کوئری رو توی گوگل سرچ کنید!

آقا من با کنسول فایرباگ ارور ها رو گرفتم این ارور رو داد :

Use of inputEncoding is deprecated. script.js:3502:0

0

به اشتراک گذاری این پست


لینک به پست

اطلاعی ندارم دیگه

من چندین بار تداخل جی کوئری داشتم

چند بار مشکل از افزونه ها بود

یکبار مشکل از فراخوانی جاوااسکریپت تو قالب بود

یه بارم به خاطر اسلایدر که خودم اضافه کردم بود

بازم میگم تو گوگل سرچ کنید تداخل جی کوئری شاید کمکتون کنه

شایدم اصلا مشکل از تداخل جی کوئری نباشه من اطلاعی ندارم :)

1

به اشتراک گذاری این پست


لینک به پست

اطلاعی ندارم دیگه

من چندین بار تداخل جی کوئری داشتم

چند بار مشکل از افزونه ها بود

یکبار مشکل از فراخوانی جاوااسکریپت تو قالب بود

یه بارم به خاطر اسلایدر که خودم اضافه کردم بود

بازم میگم تو گوگل سرچ کنید تداخل جی کوئری شاید کمکتون کنه

شایدم اصلا مشکل از تداخل جی کوئری نباشه من اطلاعی ندارم :)

منم فکر میکنم شاید از تداخل باشه .

مشکل شما چی بود؟

چجوری رفعش کردین؟

0

به اشتراک گذاری این پست


لینک به پست

دقیق خودم اطلاع ندارم

ولی مشکل از تداخل نسخه های مختلف جی کوئریه ممکنه مثلا یه افزونه از فلان نسخه و افزونه دیگه از یه نسخه دیگه استفاده کنه بعد اینا هرکدوم نسخه خودشونو لود میکنن تو قالب تداخل ایجاد میکنه

توی این انجمنم چند تا تاپیک هست سرچ کنید

مشکل اگه از این باشه

باید افزونه یا پلاگین معیوب رو پیدا کنید

اونو غیر فعال کنید

اگه از قالب باشه جاوا اسکریپت رو با wp_enqueue_script فراخوانی کنید ++

البته اطلاعات من کامل نیست صبر کنید اساتید بیان مشکلتونو حل کنن

2

به اشتراک گذاری این پست


لینک به پست

سایتتون برای من باز نمی شه

لینک مستقیم به صفحه ای که مشکل داره بدید و شرط ثبت نام را از خرید بردارید (اگر شرط داره)

4

به اشتراک گذاری این پست


لینک به پست

سایتتون برای من باز نمی شه

لینک مستقیم به صفحه ای که مشکل داره بدید و شرط ثبت نام را از خرید بردارید (اگر شرط داره)

ممنون

اون مشکل حل شد.

همونطوری که جناب رسولی گفتن مشکل از تداخل جی کوئری ها بود که با کد زیر که داخل function گذاشتم حل شد.

الان فقط مشکل آپلود عکس دارم.

هنگام آپلود پیغام " خطایی هنگام بارگذاری پیش آمده " میدهد.

اما داخل کتابخانه می بینم آپلود شده ولی بهش دسترسی ندارم.

اگر کمکم کنید ممنون می شم.

اینم کدی که گفتم :


if (!is_admin()) {
function site_init()
{
wp_deregister_script('jquery');
}
add_action('init', 'site_init');
}

0

به اشتراک گذاری این پست


لینک به پست

چک کنید ببینید کدهای زیر در قالب شما وجود دارند یا خیر .

قبل از تگ </head> :


<?php wp_head(); ?>

قبل از تگ </body> :


<?php wp_footer();?>

اگر نبودند بگذارید .

1

به اشتراک گذاری این پست


لینک به پست

چک کنید ببینید کدهای زیر در قالب شما وجود دارند یا خیر .

قبل از تگ </head> :


<?php wp_head(); ?>

قبل از تگ </body> :


<?php wp_footer();?>

اگر نبودند بگذارید .

آقا محمد رضا این تگ هارو هم داره خیلی بلا سرش آوردم اما نمیشه.

راهی به دهنتون نمیرسه؟

0

به اشتراک گذاری این پست


لینک به پست

اتفاقا بنده روی یک قالبی کار می کردم ، همین مشکل رو داشت .

با گذاشتن تگ های <?php wp_head(); ?> و <?php wp_footer();?> باعث تداخل در Ajax قالب میشد .

2

به اشتراک گذاری این پست


لینک به پست

اتفاقا بنده روی یک قالبی کار می کردم ، همین مشکل رو داشت .

با گذاشتن تگ های <?php wp_head(); ?> و <?php wp_footer();?> باعث تداخل در Ajax قالب میشد .

اون مشکل حل شد .

ولی یه مشکلی هنوز هست بالا هم توضیح دادم .

قسمت آپلود عکس کار نمیکنه .

عکسی رو که آپلود میکنم پیغام " خطایی در بارگذاری رخ داده " رو میده.

و داخل کتابخانه هم عکسی لود نمیشه .

اما وقی به هاست میرم میبینم عکس ها اونجا آپلود شده ولی درسترسی ندارم بهشون...

نمیدونم مشکل از کجاست!!!

0

به اشتراک گذاری این پست


لینک به پست

اون مشکل حل شد .

ولی یه مشکلی هنوز هست بالا هم توضیح دادم .

قسمت آپلود عکس کار نمیکنه .

عکسی رو که آپلود میکنم پیغام " خطایی در بارگذاری رخ داده " رو میده.

و داخل کتابخانه هم عکسی لود نمیشه .

اما وقی به هاست میرم میبینم عکس ها اونجا آپلود شده ولی درسترسی ندارم بهشون...

نمیدونم مشکل از کجاست!!!

بیشتر مواقع این مشکلات از functions.php قالب میباشد .

بهتر هست Debug وردپرس خود را فعال کنید سپس چک کنید مشکل شما دقیقا از کدام فایل و در چه لاینی میباشد .

موفق باشید .

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری