18 پست در این موضوع قرار دارد

سلام

من یه مشکل واسم پیش اومده

من وقتی که سایتمو داخل سایت gtmetrix بررسی کردم

دیدم که مشکل خیلی مهم سایت برای سرعت لود سایت کشه!

که من اومدم یه کد رو داخل فایل .htaccess قرار دادم تا اون مشکل برطرف شه و سرعت لود سایت بیشتر شه

مشکل هم برطرف شد و سرعت سایتم بسیار زیاد شد

ولی بدلیل مشکلاتی که برای سایت بوجود آمد (تصویر رو ببینید)eror.PNG

بخاطر همین اون کد رو از سایت برداشتم ولی بازم این مشکل رو دارم

کش مرورگر خودم رو پاک کردم ولی بازم این مشکلو دارم


DirectoryIndex index.php
<IfModule mod_rewrite.c>
RewriteEngine On
#RewriteBase /
RewriteCond %{REQUEST_URI} ^(.*)//(.*)$
RewriteRule . %1/%2 [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^.*$ index.php?qa-rewrite=$0&%{QUERY_STRING} [L]
</IfModule>
# BEGIN Compress text files
<ifModule mod_deflate.c>
<filesMatch "\.(css|js|x?html?|php|woff|ttf|png|jpg|gif)$">
SetOutputFilter DEFLATE
</filesMatch>
</ifModule>
# END Compress text files

اینم محتویات فایل .htaccess

ممنون میشم کمک کنید

http://www.tarfandi.ir

اینم آدرس سایت

0

به اشتراک گذاری این پست


لینک به پست

قربان ، سایت شما به صورت کامل لود می شود .

و مشکلی ندارد .

با یک مرورگر دیگر تست کنید .

1

به اشتراک گذاری این پست


لینک به پست

سایت شما به صورت کامل لود می شود .

و مشکلی ندارد .

با یک مرورگر دیگر تست کنید . :P

دوستان لطفا به تاپیک بنده سربزنید

1

به اشتراک گذاری این پست


لینک به پست

ممنون

از مرورگرهای مختلف هم استفاده کردم ولی بازم این مشکل رو دارم

بله سایت کامل لود میشود ولی من میخوام مثل قبلا دیگه از کش استفاده نکنه

چون امارگیر و تاریخ هم دیگه تغییر نمیکنه

0

به اشتراک گذاری این پست


لینک به پست

ممنون میشم اگه کسی میدونه

کمک کنه

0

به اشتراک گذاری این پست


لینک به پست

اگر اشتباه نکنم فایل های Cache در مسیر wp-content قرار میگیرند .

به این صورت : wp-content/cache/

فولدر cache را Rename (تغییر نام) کنید به cache2 .

سپس چک کنید .

1

به اشتراک گذاری این پست


لینک به پست

ممنون درست شد

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

سلام

سایتم به کل از کار افتاد :)))

Www.tarfandi.ir

تا آدرس رو وارد میکنم فایل _index.html_gzip رو دانلود میکنه

ممنون میشم کمکم کنید

فایل .htaccess که داخل فایل cache اشتباهی پاک شد و این مشکل بوجود اومد

ویرایش شده در توسط mohammad1212
0

به اشتراک گذاری این پست


لینک به پست

ممنون میشم کمک کنید :wub: :wub:

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

سلام. بدون مشکل باز میشه.

سلام بله بدون مشکل باز میشه

ولی برای دفعه اول

و دفعات بعد از کش استفاده میکنه

ویرایش شده در توسط mohammad1212
0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

اساتید محترم این بنده خدا راست میگه. وقتی به آدرس سایت مراجعه میکنیم به صورت اتوماتیک منتقل میشه به این آدرس:


http://www.tarfandi.ir/wp-content/cache/page_enhanced/www.tarfandi.ir/_index.html_gzip

که قاعدتا نباید اینطوری باشه. من برای بار اول وارد سایت شدم و این اتفاق افتاد

البته فقط برگه Home این مدلی هستش و اگه برگه های دیگه رو باز کنیم را روی یکی از پست ها کلیک کنیم مشکلی وجود نداره

ویرایش شده در توسط kavoshgar
1

به اشتراک گذاری این پست


لینک به پست

این مشکل از وقتی بوجود اومد که کد استفاده از کش را داخل فایل

.htaccess قرار دادم که به خاطر اون امارگیر و تاریخ سایت تغییر نمیکرد

و در بعضی اوقات پست های جدید رو نشون نمیداد

و در اخر هم

فایل .htaccess که داخل فایل cache اشتباهی پاک شد و این مشکل بوجود اومد

0

به اشتراک گذاری این پست


لینک به پست

از مدیر سرور تقاضای آخرین بک آپ خود کنید ، سپس آن را دانلود و یا در هاست خود اکسترکت کنید و فایل .htaccess را بازگردانی کنید .

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

از مدیر سرور تقاضای آخرین بک آپ خود کنید ، سپس آن را دانلود و یا در هاست خود اکسترکت کنید و فایل .htaccess را بازگردانی کنید .

ممنون میگم

ممنون از همه کسایی که کمک کردند :wub: :wub:

ویرایش شده در توسط mohammad1212
0

به اشتراک گذاری این پست


لینک به پست

پیدا نشد :((

اگه کسی میتونه کمک کنه خواهش میکنم کمک کنه

اگه هزینه ای هم باید پرداخت شه بگید اگه بتونم پرداخت کنم

سایت کلا خراب شده

0

به اشتراک گذاری این پست


لینک به پست

الان چک کردم دوست عزیز. درست شده و بدون مشکل بالا میاد. تمام برگه ها رو هم چک کردم. فقط برگه ارتباط با ما خطای 404 میده

1

به اشتراک گذاری این پست


لینک به پست

سلام

وقت نکردم بیام بگم

خود به خود درست شد

بازم ممنون

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط sajjadmp
      سلام .
      من یه قالب اختصاصی ساخته بودم که یه ماه نشده باهاش به مشکل خوردم و توی این تاپیک مطرحش کردم که پیشنهادات دوستان کمکی نکرد .اول فک میکردم مشکل از وردپرسه ولی بعد فهمیدم مشکل از قالب سایته که پستا رو نشون نمیده . ولی الان دوباره فهمیدم که کاری به قالب نداره ! چون هرچی سعی میکنم پوسته سایتمو عوض کنم ، باز همون قالب طراحی شده خودمو روی سایت نشون میده .
      افزونه کش سایتم رو هم خیلی وقته غیرفعالش کردم ولی هنوز مشکل پابرجاست .
      ممنون میشم راهنمایی کنید