SadraHkm

مشکل با meta box | مبتدی

1 پست در این موضوع قرار دارد

سلام دوستان

من یک متاباکس ساختم. همه چیزش درست کار میکنه . ولی وقتی خالی میذارم و چیزی توی وارد نمیکنم همش عدد 1 رو چاپ میکنه . با اینکه توی کد گفتم مثلا اگر خالی بود هیچی بزار . اینم کد :


<?php
add_action( 'add_meta_boxes', 'kalagh_add_meta_box');
add_action( 'save_post', 'kalagh_bf_save' );
function kalagh_add_meta_box(){

$screens = array( 'post');

foreach ( $screens as $screen ) {
add_meta_box('kalagh_meta_box','عنوان قبل از عنوان','kalagh_bf_content',$screen,'side','high');
}

}
function kalagh_bf_content($post){

$bf_title=get_post_meta($post->ID,'bf',true);

?>
<div class="panel-wrap">
<div>
<input style="width: 100%;" name="kalagh_bf" class="input" value="<?php echo !empty($bf_title)?$bf_title:''; ?>">
</div>
</div>
<?php

}
function kalagh_bf_save($post_id){

if ( defined( 'DOING_AUTOSAVE' ) && DOING_AUTOSAVE ) {
return;
}

if(isset($_POST['kalagh_bf']) && !empty($_POST['kalagh_bf'])){

update_post_meta($post_id,'bf',sanitize_text_field($_POST['kalagh_bf']));

}

}
function kalagh_show_bf(){

$bf_posts=new WP_Query('showposts=4&meta_key=bf');

while($bf_posts->have_posts()):$bf_posts->the_post();

?>
<div class="post-box"> <a href="<?php the_permalink() ?>"><?php the_post_thumbnail('postpic'); ?></a>
<h4><?php echo get_post_meta(get_the_ID(), 'bf', true); ?></h4>
<?php
endwhile;
}

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری