aliali100

اسم این مشکل پیچیده رو نمیدونم که عنوان بزارم براش!

7 پست در این موضوع قرار دارد

سلام

شرمنده از مدیران تاپیک عزیز

یک مشکل پیچیده ای دارم که واقعا نمیدونم اسمش این مشکل چیه که بخوام برای عنوان تاپیک درنظر بگیرم. از این بابت از همه عذرخواهی میکنم

من یک یک افزونه ثبت نام پیشرفته روی سایت نصب کردم

وقتی میخوام لاگین کنم و وارد بشم مشکلی نداره اما وقتی میخوام ثبت نام کنم وقتی روی دکمه ثبت نام کلیک میکنم صفحه لود نمیشه

پوسته رو عوض کردم مشکل حل نشد

تمام افزونه ها رو غیرفعال کردم بازهم درست نشد

به غیر از فولدر wp-content وردپرس تمام فولدرهای وردپرس رو تغییر دادم بازهم مشکل حل نشد

جالب اینجاست که وقتی برای تست یک ساب دامنه ساختم همین قالب فعال خودم + افزونه ثبت نام رو نصب کردم به خوبی کار کرد فقط نمیدونم چرا تو سایت اصلیم این مشکل هست

آیا میتونه به جداول پایگاه داده ربط داشته باشه؟

آیا میتونه به فایل htaccess ربط داشته باشه؟

من از کجا بدونم مشکل از کجاست؟

2 هفته هستش که درگیر این موضوع هستم

0

به اشتراک گذاری این پست


لینک به پست

سلام

مشکلی شبیه به شما را من هم تجربه کردم و متوجه شدم به خاطر کد Expire headers بود. پیشنهاد می کنم اگر کدی شبیه کد زیر در فایل htaccess خود دارید، آن را حذف کنید و سپس امتحان کنید.

# BEGIN Expire headers
<ifModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresByType image/jpeg "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/jpg "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
ExpiresByType text/css "access plus 1 month"
ExpiresByType text/javascript "access plus 1 year"
ExpiresByType application/javascript "access plus 1 year"
ExpiresByType application/x-javascript "access plus 1 year"
ExpiresByType text/html "access plus 600 seconds"
ExpiresByType application/xhtml+xml "access plus 600 seconds"
ExpiresByType font/ttf "access plus 1 year"
ExpiresByType font/woff "access plus 1 year"
</ifModule>
# END Expire headers
# BEGIN Cache-Control Headers
<ifModule mod_headers.c>
<filesMatch "\.(ico|jpe?g|png|gif|swf|woff|ttf)$">
Header set Cache-Control "max-age=2592000, public"
</filesMatch>
<filesMatch "\.(css)$">
Header set Cache-Control "max-age=2592000, public"
</filesMatch>
<filesMatch "\.(js)$">
Header set Cache-Control "max-age=2592000, private"
</filesMatch>
<filesMatch "\.(x?html?|php)$">
Header set Cache-Control "max-age=600, private, must-revalidate"
</filesMatch>
</ifModule>
# END Cache-Control Headers

1

به اشتراک گذاری این پست


لینک به پست

مرسی بابت کمک شما اما مشکل از این نیست

اینایی که شما درج کردید کدهای مربوط به کش مرورگر هستش که همه رو چک کردم

0

به اشتراک گذاری این پست


لینک به پست

مشکل من دقیقاً از همین کدها بود؛ که حالا یا به صورت کد نوشتید یا با کمک افزونه فعال شده اند.

در ساب دامین این مشکل را نداشتید چون احتمالاً به سراغ نصب افزونه و تغییر در فایل htaccess نرفتید.

0

به اشتراک گذاری این پست


لینک به پست

مشکل من دقیقاً از همین کدها بود؛ که حالا یا به صورت کد نوشتید یا با کمک افزونه فعال شده اند.

در ساب دامین این مشکل را نداشتید چون احتمالاً به سراغ نصب افزونه و تغییر در فایل htaccess نرفتید.

این کدهای من هستش

# BEGIN W3TC Browser Cache
<IfModule mod_deflate.c>
<IfModule mod_headers.c>
Header append Vary User-Agent env=!dont-vary
</IfModule>
AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
<IfModule mod_mime.c>
# DEFLATE by extension
AddOutputFilter DEFLATE js css htm html xml
</IfModule>
</IfModule>
# END W3TC Browser Cache
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
RewriteCond %{HTTP_HOST} ^www.site.com$ [NC]
RewriteRule ^(.*)$ http://site.com/$1 [R=301,L]
# END WordPress

با حذف این کدها هم مشکلم حل نشد

0

به اشتراک گذاری این پست


لینک به پست

شما از افزونه W3 Total Cache استفاده می کنید. به تنظیمات Browser caching بروید و قسمت های زیر را غیر فعال کنید.

Set Last-Modified header - Set expires header - Set cache control header - Set W3 Total Cache header

یکبار امتحان کنید. شاید درست شود.

0

به اشتراک گذاری این پست


لینک به پست

شما از افزونه W3 Total Cache استفاده می کنید. به تنظیمات Browser caching بروید و قسمت های زیر را غیر فعال کنید.

Set Last-Modified header - Set expires header - Set cache control header - Set W3 Total Cache header

یکبار امتحان کنید. شاید درست شود.

دوست خوبم بله از افزونه کش استفاده میکنم اما من میگم تمام افزونه ها رو غیر فعال کردم بازهم مشکل برطرف بود. تمام کدهای درون فایل

htaccess رو پاک کردم و باز هم مشکل برطرف بود

بعید میدونم اصلا از فایل

htaccess باشه

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری