DariushGreat

ترجمه نشدن بندهای functions.php

3 پست در این موضوع قرار دارد

سلام

من قالب دستازی ساختم و زبان پیفرض رو انگلیسی قرار دادم و همزمان دارم براش فایل فارسی هم میسازم. مشکل من اینجاست که همه ترجمه های نمایشی در سایت درست هستن، اما ترجمه های مربوط به پیشخوان و یا عبارات توابع موجود در functions.php اصلا به درستی انجام نمیشن.

برای نمونه من یه Custom Post Type به نام Events تعریف کردم. در برنامه PoEdit هم گزینه هایی که مد نظرم بود برای ترجمه میاد و من ترجمه رو انجام میدم اما در پیشخوان هیچ تغییری انجام نمیشه باز انگلیسی نمایش داده میشه.

post-7168-0-95081700-1440569302_thumb.jp

تکست دامین رو هم در هدر فراخونی کردم

ممنون برای راهنمایی هاتون

0

به اشتراک گذاری این پست


لینک به پست

بروزرسانی:

آقا من کد فراخوانی زبان و تکست دامین رو از سربرگ برداشتم و خط نخست پرونده functions.php گذاشتم. ترجمه برخی از بخش های پست تایپ رو نشون میده اما هنوز خیلی از بخش ها انگلیسیه. تکست دامین هم درسته. پس مشکل از کجاست؟

0

به اشتراک گذاری این پست


لینک به پست

لطفا کمک کنید

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط kingmateoofficial
      سلام به دوستان عزیز اقا من یه سایت ساختم با ورد پرس اولین باره چنین مشکلی رو میبینم .
      سایت همه چیزش اوکی اوکی هست ولی مطالب سایت رو تو صفحه اصلی نشون نمیده بجاش مینویسه Threads Index نمیدونم چرا
      ولی تو لیت نوشته های تازه و دسته بندی و ... نوشته ها هست 
      اینم ادرس وبسایتم 


    • توسط Max
      وقتی می‌خوام پوسته‌ای رو ترجمه کنم، به دو مشکل بر می‌خورم، یکی اینکه بعضی از پوسته‌هایی که دو یا سه رشته متنی دارن، فقط با یک نام دامنه علامت‌گذاری شدند، و متاسفانه فقط یکی از چند رشته در لیست poedit نشون داده میشن، برای مثال:
      printf( _x( 'One Reply to “%s”', 'comments title', 'mytheme' ), دوم اینکه چرا فقط از توابع ــ یا e_ استفاده نمیشه، و مثلا توابع دیگه‌ای هم به‌کار برده می‌شه؟
      وقتی بعضی از پوسته‌های فارسی شده رو -که از سایت‌های دیگه دانلود کردم- نگاه کردم، دیدم مستقیم در خود فایل پی‌اچ‌پی اون بخش‌ها رو فارسی کردن. ممنون میشم اگر اطلاعاتی دارید در این مورد راهنمایی کنین.
    • توسط sydvza
      باسلام من 9 خطا دارم در سایت مپم و ایندکسم رو 400 قفل کرده وبسایتم جهت مشاهده
      https://dackeh.com
      لطفا کمکم کنید.
    • توسط justeducation
      درود
      مشکلي در ارتباط با افزونه يوزر پرو به هنگام ثبت نام در سايت دارم. وقتي تمامي فيلدها رو کامل ميکنم و دکمه ثبت رو ميزنم بعد از چند ثانيه خطاي زير رو نمايش ميده:
      Error in jQuery.ajax while submitting a form: Internal Server Error ورژن افزونه 4.9.26 و نسخه اصلي هست.
      تمامي افزونه ها رو غيرفعال کردم و با پوسته twentyseventeen وردپرس بررسي کردم اما بازم تفاوتي نداره.
      ممنونم
    • توسط hhamedd
      سلام. لطفا سایتم رو ببینید. در سایدبار ابزارک عضویت در خبرنامه رو گذاشتم ولی دو کلمه "email" و "subscribe" هر کاری کردم فارسی نشدن. این دوکلمه اصلا درفایل mo و po نیستن. لطفا اگر راهی به ذهنتون میرسه راهنمایی کنید. باتشکر.
      moshaveraneh.ir