• اطلاعیه ها

    • Saeed Fard

      برگزاری میتاپ وردپرسی   14/08/96

      بعد از اولین دوره همایش وردپرس در ایران اگر پیگیر اخبار وردپرس بوده باشید، حتما خبر برگزاری چندین میتاپ و جلسه متعدد وردپرسی را شنیده‌اید، یکی از بحث‌های اصلی که محور اصلی این میتاپ‌ها بوده است برگزاری وردکمپ بود که به طور جدی دنبال می‌شود. این میتاپ‌ها و جلسات توسط جمعی از فعلان حوزه وردپرس در کنار وردپرس‌پارسی برگزار می‌شد و مسائل مربوط به این حیطه و از جمله وردکمپ مورد بحث قرار می‌گرفت. این بار با رایزنی‌هایی که با تیم اصلی وردپرس داشتیم در بخش دوم این رویدادها قصد داریم که میتاپ‌ها و جلسات وردپرسی را به صورت آزاد برگزار کنیم تا تمامی علاقه‌مندان و دوست‌داران وردپرس فرصت حضور داشته باشند و با گردهمایی، جامعه کاملتری از دوست داران وردپرس بسازیم و از تجربیات یکدیگر استفاده کنیم.   بدیهی است که این رویدادها با رویکرد مثبت در جهت سود رسانی به جامعه وردپرس و افراد حاضر در آن برگزار می‌شود و برای تمامی علاقه‌مندان به وردپرس است. پس اگر یک کاربر معمولی وردپرس یا یک توسعه دهنده هستید می‌توانید در این رویدادها شرکت کنید. ما در ملاقات‌هایمان از موارد مختلف و کاربردی وردپرس صحبت می‌کنیم و علاقمند به توسعه هر چه بیشتر وردپرس در ایران هستیم. ما وردپرس را دوست داریم. عضویت در این گروه برای همه افرادی که مایل به پیوستن هستند بدون در نظرگرفتن توانایی‌ها، مهارت‌ها، وضعیت مالی و یا معیارهای دیگر باز و رایگان است. فضای میتاپ‌ها و جلسات ما دوستانه و آزادنه و دور از هرگونه تبعیض و رفتارهای زننده است. بر این اساس از تمامی دوستانی که علاقه‌مند به شرکت در میتاپ‌های وردپرس هستند دعوت می‌شود تا از طریق لینک زیر در سایت میتاپ اقدام به ثبت‌نام کنند و منتظر خبرهای برگزاری جلسات در آینده باشند . لینک ثبت نام و عضویت : https://www.meetup.com/Iran-WordPress-Meetup    
iwordpress.ir

کتابخانه جی کوئری - پلاگین نویسی

3 پست در این موضوع قرار دارد

سلام .

تو پلاگین نویسی نیاز دام که کتابخونه جی کوئری رو استفاده کنم اما یک مسئله ای که هست میخوام بدونم به فرض وقتی تو پوستمون هم همون کتابخونه استفاده شده و ما هم بیایم تو پلاگینمون استفاده کنیم اونوقت تو سورسمون هم دو تا کتابخانه و تداخل داریم . حالا باید به چه شکل استفاده بشه تو پلاگین !

0

به اشتراک گذاری این پست


لینک به پست

اگر بخواید از خود جی کوئری وردپرس استفاده کنید، چون باید تابع وردپرس استفاده بشه پس یکبار لود میشه اما اگر بخواید جی کوئری خودتون رو لود کنید باید جی کوئری وردپرس رو حذف کنید و جی کوئری خودتون رو لود کنید.

4

به اشتراک گذاری این پست


لینک به پست

من هم همین مشکلو داشتم نیاز داشتم تا نسخه 1.8 جیکوئری رو لود کنم، ولی مال وردپرس 1.7 بود، بعد با کد زیر تونستم کلا جی کوئری که توسط هر پلاگین وردپرس میخواد لود بشه رو غیرفعال کنم و مال خودمو به جاش لود کنم:


if (!is_admin()) add_action("wp_enqueue_scripts", "my_jquery_enqueue", 11);
function my_jquery_enqueue() {
wp_deregister_script('jquery');
wp_register_script('jquery', "". get_template_directory_uri() ."/js/jquery-1.8.1.min.js", false, null);
wp_enqueue_script('jquery');
}

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری