7 پست در این موضوع قرار دارد

با سلام

من یک قالب با کمک آموزش تصویری رابین وب نوشتم و از روی اون الهام گرفتم و نوشتم. و از این طرح ساده ولی از دیدگاه خودم زیبا خیلی خوشم میاد ولی یکسری مشکلات دارم

بزرگترین مشکل: من قالب رو که نصب می کنم زمان ارسال پست گالری تصاویرم باز نمیشه و دلیلش رو هم نمی دونم

ابزارکم درست باز نمیشه اگه میشه کمک کنید

آدرس سایت: www.b-s-t.ir

Capture.JPG

Capture.JPG

0

به اشتراک گذاری این پست


لینک به پست

سلام

فقط با این قالب مشکل دارید ؟ یعنی با قالب های دیگه به راحتی همه قسمت کار میکنند ؟

اگر فقط با این قالب هستش تمام کد های داخل فایل فانکشن قالب رو حذف کنید و تست کنید ببینید بخش گالری درست کار میکنه ؟

اگر درست کار کرد پس باید کل کدهای فانکشن رو چک کنید ببینید کجا اشتباه داشتید.

1

به اشتراک گذاری این پست


لینک به پست
در 6 ساعت قبل، وردپرس فارسی گفته است :

سلام

فقط با این قالب مشکل دارید ؟ یعنی با قالب های دیگه به راحتی همه قسمت کار میکنند ؟

اگر فقط با این قالب هستش تمام کد های داخل فایل فانکشن قالب رو حذف کنید و تست کنید ببینید بخش گالری درست کار میکنه ؟

اگر درست کار کرد پس باید کل کدهای فانکشن رو چک کنید ببینید کجا اشتباه داشتید.

- بله فقط در همین قالب این مشکل ایجاد میشه.

- کدهای فانکشن  قالب رو پاک کردم و تست کردم، گالری قالب درست کار کرد.

* فایل های index.php , sidebar.php , style.css , functions.php رو براتون آپلود میکنم شما هم اگه امکان داره یه نگاهی بندازید.

 

functions.php

index.php

sidebar.php

style.css

0

به اشتراک گذاری این پست


لینک به پست

سلام

فایل فانکشن رو دانلود کنید جایگزین کنید و تست کنید .

functions.php

1

به اشتراک گذاری این پست


لینک به پست
در 19 ساعت قبل، وردپرس فارسی گفته است :

سلام

فایل فانکشن رو دانلود کنید جایگزین کنید و تست کنید .

functions.php

سلام،

این کار رو کردم ولی متاسفانه بازم این مشکل رو دارم... :(

0

به اشتراک گذاری این پست


لینک به پست

سلام مجدد

کد های داخل فایل فانکشن رو کلاً پاک کنید این کد رو جایگزین کنید.

 


<?php
add_theme_support( 'post-thumbnails' );
$args = array(
    'name'          => 'sidebar-right',
    'description'   => __( 'ستون سمت راست'),
	'before_widget' => '<div class="sidebar"><div class="csid"><div class="ul-sidebar">',
    'after_widget' => '</div></div></div>',
	'before_title' => '<div class="tsid">',    		
	'after_title' => '</div>',
 );
if ( function_exists('register_sidebar') ) register_sidebar($args);
if (!function_exists('_checkactive_widgets')) {
// do nothing
}

?>

 

 

 

ویرایش شده در توسط وردپرس فارسی
1

به اشتراک گذاری این پست


لینک به پست
در 7 ساعت قبل، وردپرس فارسی گفته است :

سلام مجدد

کد های داخل فایل فانکشن رو کلاً پاک کنید این کد رو جایگزین کنید.

 



<?php
add_theme_support( 'post-thumbnails' );
$args = array(
    'name'          => 'sidebar-right',
    'description'   => __( 'ستون سمت راست'),
	'before_widget' => '<div class="sidebar"><div class="csid"><div class="ul-sidebar">',
    'after_widget' => '</div></div></div>',
	'before_title' => '<div class="tsid">',    		
	'after_title' => '</div>',
 );
if ( function_exists('register_sidebar') ) register_sidebar($args);
if (!function_exists('_checkactive_widgets')) {
// do nothing
}

?>

 

 

 

عالی شد، خیلی خیلی ممنون، واقعا متشکرم :):)

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط giilass
      عرض ادب
      سایتم رو از دامنه X به دامنه y تغییر دادم.از پنل هاست(دایرکت ادمین)
      هم فایل config.php و هم جداول دیتابیس که url  سایت قدیمی داشت رو ادیت کردم 
      اما باز هم ایکون و فونت ها مشکل داره.
      تمامی مطالب تو نتایج جستجو گوگل رو هم بررسی کردم.اما به نتیجه نرسیدم.
      اگر کسی میتونه راهنمایی بکنه.قالب سایتم اینویژن هست و البته افزونه wpml هم استفاده میکنم.
       
    • توسط giilass
      عرض ادب
      سایتم رو از دامنه X به دامنه y تغییر دادم.از پنل هاست(دایرکت ادمین)
      هم فایل config.php و هم جداول دیتابیس که url  سایت قدیمی داشت رو ادیت کردم 
      اما باز هم ایکون و فونت ها مشکل داره.
      تمامی مطالب تو نتایج جستجو گوگل رو هم بررسی کردم.اما به نتیجه نرسیدم.
      اگر کسی میتونه راهنمایی بکنه.قالب سایتم اینویژن هست و البته افزونه wpml هم استفاده میکنم.
       
    • توسط meysam011
      سلام به همه دوستان
      من یک قالب رایگان برای سایتم خریداری کردم. مشکلی که دارم اینه که وقتی متن رو از طریق وردپرس اضافه میکنم، متن و پاراگراف ها داخل سایت به صورت پشت سر هم نشون داده میشه و به اصطلاح بریک نمیشه. فکر میکنم مشکل از قالب باشه. در ضمن عکسی رو که در وردپرس آپلود میکنم، در سایت نمایش داده نمیشه.
    • توسط sajadszm
      با سلام
      وقتی میخوام قالب رو درون ریزی کنم بعد از ارسال درخواست با مشکلی که توی عکس پیوست هست مواجه میشم.
      چیکار کنم؟
       

    • توسط masoudmosleh267
      سلام. دوستان کسی میدونه چرا این سایت وقتی لود میشه یه لحظه چپ چین میشه دوباره راست چین میشه؟
      آدرس سایت: hamechitamom.com