hiwa

مشکل از کار افتادن جاوا اسکریپت در سایت من+ درخواست کمک

12 پست در این موضوع قرار دارد

سلام به دوستان عزیزم

چند روز پیش، تمام کمپوننتهای سایت من که پویایی(dynamic) دارن و به نوعی در اونها از جاوا اسکریپت استفاده شده(مثل دکمه ها و تب ها و.. هر چیزی که کلیک میخوره یا رفتار مشخصی مثل pop up شدن داره)، به صورت ناگهانی از کار افتادند.

تمام پلاگین رو غیر فعال کردم و هر کاری به ذهنم میرسیده انجام دادم اما مشکلم حل نشده.

تنها حدسم اینه که ممکنه به خاطر پر شدن هاست باشه

چند روز پیش هاستم که داشت پر میشد رو ارتقا دادم

در سی پنل مقدار جدید ارتقا داده شده رو نشون میده و هنوز نصف فضام خالیه

اما در کنترل پنل خود سایت هاست(برتینا) نوشته که هاستم پر شده(مقدار قبل از ارتقا رو نشون میده) و 100% هست. (در واقع 110% )

پشتیبانی برتینا هم تاکید داره که این 100%ی که در سایت برتینا نوشته مهم نیست.

دوستان نظر شما چیه؟

به نظر شما مشکل میتونه از پر شدن هاست باشه/

یا دلیل دیگه ای داره؟

به چه دلیل کدهای جاوا اسکریپت میتونن ناگهانی از کار بیفتند؟

منتظر کمکتون هستم

ممنونم

0

به اشتراک گذاری این پست


لینک به پست

وردپرس رو به ۴.۵ ارتقاء دادید؟ 

2

به اشتراک گذاری این پست


لینک به پست

بله ارتقا دادم. ممکنه مربوط به اون باشه؟

0

به اشتراک گذاری این پست


لینک به پست

سلام. کدهای داخل index وردپرس رو تغییر دادید؟ مجددا index اصلی خود وردپرس را آپلود کنید. (در root هاست)

1

به اشتراک گذاری این پست


لینک به پست
در 32 دقیقه قبل، Gamecock گفته است :

سلام. کدهای داخل index وردپرس رو تغییر دادید؟ مجددا index اصلی خود وردپرس را آپلود کنید. (در root هاست)

سلام  Gamecock عزیز

نه تغییر ندادم. الان فایل index رو آپلود میکنم. نتیجه رو بهتون میگم

مرسی که جواب دادید :)

ویرایش شده در توسط hiwa
0

به اشتراک گذاری این پست


لینک به پست
در 29 دقیقه قبل، hiwa گفته است :

سلام  Gamecock عزیز

نه تغییر ندادم. الان فایل index رو آپلود میکنم. نتیجه رو بهتون میگم

مرسی که جواب دادید :)

فایل index.php رو جایگزین کردم اما متاسفانه چیزی تغییر نکرد.

چیز دیگه ای به ذهنتون میرسه امتحان کنم؟

ممنونم

ویرایش شده در توسط hiwa
0

به اشتراک گذاری این پست


لینک به پست

این کد رو به کدهای php فایل functions.php  اضافه کنید و تست بگیرید 

function aspnetcdn_jquery() {
	if(!is_admin()) {
  		wp_deregister_script( 'jquery' );
		wp_register_script( 'jquery', 'http://ajax.aspnetcdn.com/ajax/jQuery/jquery-1.11.2.min.js', 'jquery', '1.11.2'); 
		wp_enqueue_script('jquery');
	}
}
add_action( 'wp_enqueue_scripts', 'aspnetcdn_jquery' );

 

5

به اشتراک گذاری این پست


لینک به پست

تست کردم با همین تغییر درست می شه

Screenshot_43.thumb.png.1358846676ae792d

2

به اشتراک گذاری این پست


لینک به پست
در 2 ساعت قبل، imanfakhar گفته است :

این کد رو به کدهای php فایل functions.php  اضافه کنید و تست بگیرید 


function aspnetcdn_jquery() {
	if(!is_admin()) {
  		wp_deregister_script( 'jquery' );
		wp_register_script( 'jquery', 'http://ajax.aspnetcdn.com/ajax/jQuery/jquery-1.11.2.min.js', 'jquery', '1.11.2'); 
		wp_enqueue_script('jquery');
	}
}
add_action( 'wp_enqueue_scripts', 'aspnetcdn_jquery' );

 

imanfakhar عزیز و بزرگوار

مشکلم حل شد

نمیدونم چطوری ازتون تشکر کنمو. واقعا ممنونم.

فقط یه سوال

چطوری این مشکل پیش اومده؟

قبلا بدون این هم جی کوئری رو لود میکرد

کار خاصی هم روی سایت انجام ندادم در این چند روز اخیر. البته یه پلاگین دارم که خودکار پلاگینهارو به روز میکنه.

 

سوال دومم اینه که چطوری خود شما تست کردین و گفتین حل شده و اسکرین شات هم گذاشتین؟؟

خیلی جالبه برام

0

به اشتراک گذاری این پست


لینک به پست

قالب به صورت معمول از جی کوئری وردپرس استفاده می کنه و در آخرین نسخه وردپرس جی کوئری ورژن 1.12.2 استفاده شده این ورژن برای وردپرس بهینه شده و بجای $ باید در کد نویسیش از jQuery  استفاده کرد 

در نتیجه خیلی از کدهای جی کوئری روش به مشکل می خورند کدی که دادم خدمتتون جی کوئری وردپرس رو غیر فعال می کنه و بجاش جی کوئری cdn سایت aspnet که مال ماکروسافته و ورژن 1.11.2 که چک شده و درسته رو بجاش ریجستری می کنه

3

به اشتراک گذاری این پست


لینک به پست

کار خاصی نکردم سورس کدتون رو کپی کردم تو نوت پد  اسکریپت جی کوئریش رو حذف کردم و اسکریپت asp.net رو روش قرار دادم و بعد با پسوند html ذخیره کردم و تو بروسر باز کردم 

2

به اشتراک گذاری این پست


لینک به پست

کارتون عالی بود. واقعاً ممنونم ازتون. مرسی :)

1

به اشتراک گذاری این پست


لینک به پست

  • مطالب مشابه

    • توسط kamalwp
      سلام 
      دوستان خیلیا میگن که باید برای طراحی قالب وردپرس از نسخه 1.12.4 استفاده کنیم ، این درسته؟ البته من نگاه کردم هرچی سایت وردپرسیه از نسخه 1.12.4 استفاده کردن
      دلیل اینکار چی هست واینکه نمیشه از تسخه بالاتر استفاده کرد
    • توسط omidtt
      سلام خسته نباشید
      برای وب سایت https://perfectmoney24.com  نیاز به افزونه ای دارم که سایت و به کانال تلگرام متصل کنم . امکانپذیر این مورد ؟ راهنمایی کنید لطفا
       
       
    • توسط arjmand
      سلام دوستان وقت بخیر
      من هاستم رو از هاست لینوکس به هاست وردپرس تغییر دادم
      است قبلی من از فقط از نسخه 5.6 PHP پشتیبانی میکرد
      در هاست جدید نسخه 7.2 PHP موجود هست اما وقتی ورژن PHP هاست رو روی 7.2 قرار میدم سایت ارور "این سایت مشکل فنی را تجربه میکند" رو نمایش میده
      با پشتیبان هاستم صحبت کردم گفت برای اینکه بتونی از نسخه 7.2 استفاده کنی باید تمام پلاگین هات و قالبت بروز بشن
      من پلاگین ها رو زدم بروزرسانی اما بعضی هاشون ارور دادن و بروز نشدن ارور  قرمز رنگ "این سایت مشکل فنی را تجربه میکند"
      بعد از بروز رسانی پلاگین ها دیگ بخش پیشخوان سایت بالا نمیاد و همون ارور رو میده .اما خود سایت بالا میاد و لود میشه 
      نسخه PHP رو که روی 7.2 قرار میدم دیگ سایت هم مثل پیشخوان ارور میده و بالا نمیاد
      الان نسخه PHP هاست بر روی 5.6 هست و سایت بالا میاد ولی بخش پیشخوان همچنان ارور میده
      ایمیلی هم برام ارسال نمیشه برای رفع مشکل.
      کسی هست بتونه راهنمایی کنه جهت رفع مشکل !!!؟
      با تشکر.
    • توسط Enzo
      سلام ، من مشکل عجیبی دارم و سایتم با فیلتر شکن باز نمیشه ! 
      کسی کیتونه راهنمایی کنه ؟
      آدرس سایت
    • توسط unid_user
      سلام و درود
      دوستان گرامی، می خوام وقتی وارد حساب کاربریم میشم اون قسمتی که نوشته ورود به سیستم نمایش داده نشه.
      با تشکر و سپاس