عمارگراف

ارور404
خطای 404 بعد از انتقال به هاست جدید

5 پست در این موضوع قرار دارد

سلام

وقتتون بخیر دوستان

مشکل : تمام برگه ها و دسته ها و مطالب خطای 404 میدن.

اتفاق اخیر : هاستم رو تغییر دادم.

تلاش های انجام شده :

1- فایل htaccess رو دوباره ایجاد کردم و اون دستور وردپرس معروف رو توش گذاشتم.

2- پیوند یکتا رو ذخیره مجدد زدم.(تو این مورد یه مشکلی هست. وقتی مثلا میذارم روی پیشفرض مطالب باز میشن اما فقط تصویر شاخص میاد و متن اصلی اون مطلب نمیاد. وقتی هم میذارم روی "نام نوشته" ارور 404 میده)

لطفا راهنمایی کنید.

ممنون

یا علی

0

به اشتراک گذاری این پست


لینک به پست

سلام 

فکر کنم چون IP هاست تغییر کرده شما باید the permalinks مطالب ( یا همون پیوند های یکتا ) رو ریست کنید 

به قسمت تنظیمات > پیوند های یکتا برید و پیوند یکتای پیشفرض مطالب رو روی نام نوشته قرار بدید و تنظیمات رو ذخیره کنید 

به احتمال زیاد مشکل حل میشه 

ویرایش شده در توسط Alireza Xn
0

به اشتراک گذاری این پست


لینک به پست
در 6 دقیقه قبل، Alireza Xn گفته است :

سلام 

فکر کنم چون IP هاست تغییر کرده شما باید the permalinks مطالب ( یا همون پیوند های یکتا ) رو ریست کنید 

به قسمت تنظیمات > پیوند های یکتا برید و پیوند یکتای پیشفرض مطالب رو روی نام نوشته قرار بدید و تنظیمات رو ذخیره کنید 

به احتمال زیاد مشکل حل میشه 

ممنون که وقت میذارید برای حل مشکل بنده اما عرض کردم که این کار رو انجام دادم و حل نشد.

مشکل بعدی اینجاست که حتی وقتی روی "پیشفرض" میذارم(یعنی به صورت : p=111) مطالب باز میشن اما هیچ محتوایی نمایش داده نمیشه

0

به اشتراک گذاری این پست


لینک به پست

شما فایل بک آپ رو به هاست جدید منتقل کردید؟ مطمعن هستید که این فایل ناقصل آپلود نشده ؟؟؟

میشه وارد هاست بشید و بگید سطح دسترسی پوشه های wp-includes و wp-content روی چه عددی تنظیم شده ؟؟ اگه روی 660 هست روی 666 تنظیم کنید و دوباره تست کنید

یادتون نره حتمی حتمی باید این قطعه کد داخل فایل .htaccess باشه 

 

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

 

تست کنید و نتیجه رو بگید 

ویرایش شده در توسط Alireza Xn
0

به اشتراک گذاری این پست


لینک به پست
در در 4/26/2016 at 23:23، Alireza Xn گفته است :

شما فایل بک آپ رو به هاست جدید منتقل کردید؟ مطمعن هستید که این فایل ناقصل آپلود نشده ؟؟؟

میشه وارد هاست بشید و بگید سطح دسترسی پوشه های wp-includes و wp-content روی چه عددی تنظیم شده ؟؟ اگه روی 660 هست روی 666 تنظیم کنید و دوباره تست کنید

یادتون نره حتمی حتمی باید این قطعه کد داخل فایل .htaccess باشه 

 


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

 

تست کنید و نتیجه رو بگید 

سلام

وقتی سطح دسترسی اون پوشه‌ها رو روی 660 و 666 میذارم سایت دیگه بالا نمیاد! اما روی 755 بالا میاد.

فایل htaccess درسته. دسترسیش ر. هم روی هر مقداری میذارم فرقی نداره.

مشکل :

1-اگر پیوند یکتا روی "پیشفرض(p=123)" باشه سایت بالا میاد اما متن نوشته نشون داده نمیشه. فقط عنوان مطلب بالا میاد.

2-اگر پیوند یکتا روی "نام نوشته" باشه خطای 404 میده.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط amirmt
      سلام و عرض ادب هنگامی که سایتم و میخوام باز کنم و ادرسش رو سرچ میکنم یه صفحه سفید باز میشه که این اخطار رو میده 
      Parse error: syntax error, unexpected 'text' (T_STRING) in /home/unickir/public_html/wp-includes/class-oembed.php on line 461
      کسی میدونه مشکل کجاست و کمک کنه
      ادرس سایت}: www.unick.ir
    • توسط iranibonsai
      درود، سایتی رو با وردپرس بالا آوردیم
      اما اکنون در صفحات داخلی سایت کد خطایی رو در بخش بالای مرورگر نشون میده که نتونستیم رفعش کنیم
      Warning: count(): Parameter must be an array or an object that implements Countable in /home3/zahrefzo/public_html/wp-includes/post-template.php on line 284
      این خطا قبلا وجود نداشت، نفهمیدم به چه علتی بوجود آمده و تو اینترنت هم چیز خاصی راجعبه رفعش پیدا نکردم، ممنون میشم اعلام نظر بفرمایید
      آدرس سایت :
      http://minelbeautysalon.com//
    • توسط leotech
      سلام.
      من یه فروشگاه اینترنتی دارم که متاسفانه آدرسی که براش انتخاب کردم از قبل استفاده شده بود و من زمانی به این موضوع پی بردم که تو گوگل وبمستر 54 هزار تا خطای 404 دریافت کردم.
      که همشون پست ها و صفحاتی هستن که اصلا وجود ندارن حتی تو نتیجه گوگل. و من برای حل این مشکل تمام این صفحات رو با استفاده از برنامه Remove URL کردم و نسخه ای جدیدی از آدرس که اینبار https بود رو تو وبمستر ثبت کردم و بعد از حدود 2 ماه تمام ارورهای 404 از نسخه http پاک شدن ولی جدیدا دوباره 800 تا خطا تو https دریافت کردم که بازم مربوط به همون پست های قدیمی هست.
      جالب اینجاس که هیچ کدوم از صفحاتی که 404 دارن تو گوگل ایندکس نیستن و فقط تو نسخه گوگل وبمستر قدیمی این خطاها اومده و تو نسخه جدیدش فقط 4 تا خطای 404 دارم که طبیعیه.
      آیا این اشتباه نسخه قدیمی گوگله ؟ یا واقعا همچین مشکلی تو سایت من وجود داره؟
      آیا راه حلی هست که این مشکل رو حل کنم؟
       


    • توسط mhmmahdi
      سلام وقت بخیر
      من در قسمت برگه ها با استفاده از افزونه المنتور صفحه ورود و 404 ساختم اما چجوری باید وقتی ورود میزنه ویا صفحه 404 اون صفحه ای که ساختم بیاد؟
      کلا درسته که از طریق برگه ها این صفحات بسازم؟
    • توسط xtrywow
      سلام اقایون من از سمت وبمستر حدود 2700 تا خطای 404 دارم که همشون لینک ها درسته اما یه قطعه لینک اضافه باعث شده 404 بده به این صورت
      http://asa.co.ir/tag/مالیات-بر-خانه‌های-خالی-از-سکنه/info @ asa.co.ir
      http://asa.co.ir/tag/حق-مسکن-۴۰هزارتومانی/info @ asa.co.ir
      http://asa.co.ir/tag/حق-مسکن-۴۰هزارتومانی/
      به این شکل خود سایت هم هست http://asa.co.ir/
      ممنون میشم کمک کنین این مسئله رو حل کنم 
      یک مشکل دیگه هم هست که همین جا بیان میکنم که موضوع جدید نزنم در نوشته های من نوشته آینه میشه یک بار هم پایین بغد فوتر اجرا میشه که از افزونه نیست (تست کردم)
      تو فالب سایت هم در فوتر تنها این کد یکم مشکوک بود  <?php if ( $us_layout->footer_show_top OR $us_layout->footer_show_bottom ): ?>