lifer

سوال در مورد ایجاد تصویر شاخص

6 پست در این موضوع قرار دارد

سلام دوستان ، من میخوام برای پست هام تصویر شاخص بسازم

من خیلی آموزش ها رو زیر و رو کردم ، ولی هیچ کدوم جواب نمیدن 

من این کد رو داخل function.php تعریف کردم :

<?php
    if (function_exists('add_theme_support')) {
        add_theme_support( 'post-thumbnails' );
    }
?>

و این کد رو به index.php اد کردم :

<div id="content">
                                
                                    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>
                                    
                                    <div class="img-post">

                                        <a href="#" class="post-a">
                                            
                                                <?php

                                                    if ( has_post_thumbnail() ) {
                                                        the_post_thumbnail( 'thumbnail', array( 'class' => 'post-img' ) );
                                                    }
                                                    else {
                                                        echo '<img src="' . get_bloginfo( 'stylesheet_directory' ) . '/images/no-thumbnail.png" />';
                                                    }

                                                ?>

                                        </a>

                                    </div>

ولی اصلا کار نمی کنه ! چیکار کنم درست شه ؟

0

به اشتراک گذاری این پست


لینک به پست

سلام و درود به انجمن وردپرس فارسی خوش امدید

شما از چه قالبی استفاده میکنید،میشه ادرس انلاس بدید؟.

0

به اشتراک گذاری این پست


لینک به پست
در 2 ساعت قبل، mk-73 گفته است :

سلام و درود به انجمن وردپرس فارسی خوش امدید

شما از چه قالبی استفاده میکنید،میشه ادرس انلاس بدید؟.

ممنون ، لطف دارید

من قالب اختصاصی نوشتم .

0

به اشتراک گذاری این پست


لینک به پست

دوستان ، کمک کنید خواهشا ! گیر کردم واقعا 

همه چجوری تصویر شاخص دارن با کدهای the_post_thumbnail ، من نمیتونم داشته باشم

چرا ؟ مشکل از چیه !!

0

به اشتراک گذاری این پست


لینک به پست

سلام ، جایگزین کنید ( کد زیر تست شده مشکلی نداره )

<div id="content">
                                
<?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
                                    
                                    <div class="img-post">

                                        <a href="#" class="post-a">
                                            
                                                <?php

                                                    if ( has_post_thumbnail() ) {
                                                        the_post_thumbnail( 'thumbnail', array( 'class' => 'post-img' ) );
                                                    }
                                                    else {
                                                        echo '<img src="' . get_bloginfo( 'stylesheet_directory' ) . '/images/no-thumbnail.png" />';
                                                    }

                                                ?>

                                        </a>

<?php endwhile; else : ?>
<?php endif; ?>
									

                                    </div>

 

ویرایش شده در توسط وردپرس فارسی
0

به اشتراک گذاری این پست


لینک به پست

دوستان مشکلم حل شد !

در واقع مشکلم این بود که فایل توابع رو با نام function.php ذخیره کرده بودم که بادی در اصل با نام functions.php ذخیره میکردم !

از همه دوستان معذرت میخوام و تشکر میکنم . ممنون :)

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط t-51
      با سلام خدمت همه .
      بنده یه مشکل کوچیک داشتم قسمت فهرست سازی اونم عبارت از نامعتبر بودن صفحات ورود و ثبت نام به دلیل نامعلوم به شرح عکس زیر کسی میدونه باید چیکار کرد یا اضلا چرا اینطوری شده ؟
       

    • توسط ارتور زم
      سلام دوستان خسته نباشید
      بنده از افزونه لایسنس منیجر استفاده میکنم Software License Manager
      از این افزونه برای بحث لایسنس قالب استفاده میشه یا هر محصول دیگری ...
      اما مشکلی که هست اینه که بعد از اینکه کدلایسنس توسط مشتری فعال شد و کار هم به خوبی انجام میشه و قالب فعال میشه
      اما مشکلی که هست در هر بار لود سایت باید این تایید اعتبار صورت بگیرد ،
      میخام ببینم طوری میشه کرد که فقط بعد از اولین تایید اعتبار (بعد خرید) فعال بشه و دیگر تا زمانی که از سمت سرور (سایت من) برای مشتری در بحث لایسنس ارسال نشد ، به هر دلیلی اگر سایت سرور هم قطع شد ، دیگه خاموش نشه
      چون مشکلی که هست اینه که اگر سایت من قطع بشه کلیه سایت های لایسنس شده مشتریان قطع میشه و این مشکل بزرگی هست.
      از توسعه دهنده پلاگین سوال کردم ، گفت باید کد سمت کلاینت تغییر کنه ، شما راه حلی دارید برای این کد:
       
      <?php define('YOUR_LICENSE_SERVER_URL','https://localhost'); $api_params=array('slm_action'=>'slm_check','secret_key'=>'245454545445','license_key'=>get_option('sample_license_key'),); $response=wp_remote_get(add_query_arg($api_params,YOUR_LICENSE_SERVER_URL),array('timeout'=>20,'sslverify'=>false)); $license_data=json_decode(wp_remote_retrieve_body($response)); global $active,$message;if($license_data->result=='success'){ ?> <?php } else{?> <?php wp_die(__('قالب شما لایسنس شده نمی باشد.'));?><?php }?>  
       
      منظور اینه بعد از هر لود ، تایید اعتبار میخام صورت نگیره ، الان به صورت پیشفرض با هر لود سایت ، درخواست میده به سمت سرور که تایید اعتبار بگیره ، خود سایت به صورت خودکار منظورمه ،
      میخام طوری بشه که بعد از اولین تایید اعتبار ، دیگه نیاز نداشته باشه با هر بار لود تایید بشه و تا زمانی که از سمت سرور دیگه پیغامی مبنی بر انقضا شدن لایسنس یا مثلا بلاک شدن بهش فرستاده نشه (ازداخل پنل افزونه این امکان وجود دارد)
      نیاز به تایید اعتبار پس از هر بار لود نشه …
    • توسط kamran.azarniya
      سلام دوستان
      در قالب  real home هر کاری میکنم امکان ثبت ملک توسط اعضا وجود نداره (با این که عضو میشن ) و لازم به ذکره 3 بار این قالبو از سایتهای مختلف گرفتم و نصب کردم
      تشکر
    • توسط amirmt
      سلام و عرض ادب هنگامی که سایتم و میخوام باز کنم و ادرسش رو سرچ میکنم یه صفحه سفید باز میشه که این اخطار رو میده 
      Parse error: syntax error, unexpected 'text' (T_STRING) in /home/unickir/public_html/wp-includes/class-oembed.php on line 461
      کسی میدونه مشکل کجاست و کمک کنه
      ادرس سایت}: www.unick.ir
    • توسط cloudgamer
      دنبال یه تابع هستم که تعداد تمام بازدید های سایت رو نشون بده 
      (بدون افزونه)