• اطلاعیه ها

    • Morteza

      باهم بسازیم: اطلس ووکامرس و وردپرس   14/07/96

      تاپیک ایجاد شده برای بحث در جهت ایجاد یک منبع، ویکی، صفحات توضیحی و یا بخش آموزشی جامع برای وردپرس و متعلقات مختلف آن است. لطفا جهت مشارکت در این بحث، ارائه پیشنهاد و یا انتقاد به تاپیک فوق مراجعه کنید. باهم بسازیم: اطلس ووکامرس و وردپرس
chemist

ارور بعد از بروزرسانی وردپرس

6 پست در این موضوع قرار دارد

با سلام و عرض خسته نباشید؛

بنده افزونه ای برای خبر نامه نصب کردم، (افزونه را از پوشه پلاگین های یک سایت دیگر زیپ، دانلود و در سایتم نصب کردم) هیچ اروری موجود نبود. بعد که وردپرس رو بروزرسانی کردم (نسخه 4.6) با این ارور مواجه شدم:

Warning: ini_get_all() has been disabled for security reasons in /home/chemist/public_html/wp-includes/load.php on line 1020


Headers already sent in /home/shimisti/public_html/wp-includes/load.php on line 1020
This is not a good sign, it may just be a poorly written plugin but Headers should not have been sent at this point.
Check the code in the above mentioned file to fix this problem

با غیر فعالسازی افزونه نصب شده و ارتقا نسخه پی اچ پی هاست به 5.6 نیز ارور برطرف نشد. ممنون میشم اگه راهنمایی بفرمائید.

 

ویرایش شده در توسط chemist
0

به اشتراک گذاری این پست


لینک به پست

چیزی که هست شما کدتون یه مشکل و مورد امنیتی داره که در خط 1020 از سورس فایل load.php هستش

ببینید و بررسی کنید که مشکل چیه یا بزارید اینجا در اسرع وقت دیده بشه

1

به اشتراک گذاری این پست


لینک به پست

این مشکل که با بروزرسانی به نسخه 4.6 ایجاد می شود در اکثر موارد با ارتقا نسخه php به 5.6 مرتفع می شود ولی فکر کنم به دلیل عدم سازگاری قالب با php نسخه 5.6 باشه که این مشکل حل نشد.

در فایل .htaccess  با تغییر

AddType Application/x-httpd-php53 php

به

AddType Application/x-httpd-php56 php

سایت به کل از دسترس خارج می شود.

ممنون میشم اگر دوستان روش سازگارسازی قالب با نسخه جدید پی اچ پی را بفرمایند.

0

به اشتراک گذاری این پست


لینک به پست
در 52 دقیقه قبل، chemist گفته است :

این مشکل که با بروزرسانی به نسخه 4.6 ایجاد می شود در اکثر موارد با ارتقا نسخه php به 5.6 مرتفع می شود ولی فکر کنم به دلیل عدم سازگاری قالب با php نسخه 5.6 باشه که این مشکل حل نشد.

در فایل .htaccess  با تغییر

AddType Application/x-httpd-php53 php

به

AddType Application/x-httpd-php56 php

سایت به کل از دسترس خارج می شود.

ممنون میشم اگر دوستان روش سازگارسازی قالب با نسخه جدید پی اچ پی را بفرمایند.

باید به پشتیبانی هاستتون پیام بدین و ازشون بخواهید php شما را ارتقا بدهند نه اینکه توی htaccess تغییر بدهید

1

به اشتراک گذاری این پست


لینک به پست

ممنون از شما؛ بله بنده هم دقیقاً همین کار رو انجام دادم. از طریق سی پنل نسخه پی اچ پی رو ارتقا دادم و با پشتیبانی هاست هم در میان گذاشتم، نظر پشتیبانی هاست هم همین بود.

0

به اشتراک گذاری این پست


لینک به پست
در ۱ ساعت قبل، chemist گفته است :

ممنون از شما؛ بله بنده هم دقیقاً همین کار رو انجام دادم. از طریق سی پنل نسخه پی اچ پی رو ارتقا دادم و با پشتیبانی هاست هم در میان گذاشتم، نظر پشتیبانی هاست هم همین بود.

این مشکل نه تنها برای شما بلکه برای خیلی ها اتفاق افتاده و باید منتظر نسخه جدید وردپرس باشیم

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری