runy

post type
مشکل با کد post type

2 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)


سلام
کد پست تایپ زیر را در فانشن گذاشتم .

//---------------------—
function wpp_custom_post_type() {

    $labels = array(
        'name'                => __( 'Post Types', 'text_domain' ),
        'singular_name'       => __( 'Post Type', 'text_domain' ),
        'menu_name'           => __( 'Post Type', 'text_domain' ),
        'parent_item_colon'   => __( 'Parent Item:', 'text_domain' ),
        'all_items'           => __( 'All Items', 'text_domain' ),
        'view_item'           => __( 'View Item', 'text_domain' ),
        'add_new_item'        => __( 'Add New Item', 'text_domain' ),
        'add_new'             => __( 'Add New', 'text_domain' ),
        'edit_item'           => __( 'Edit Item', 'text_domain' ),
        'update_item'         => __( 'Update Item', 'text_domain' ),
        'search_items'        => __( 'Search Item', 'text_domain' ),
        'not_found'           => __( 'Not found', 'text_domain' ),
        'not_found_in_trash'  => __( 'Not found in Trash', 'text_domain' ),
    );
    $rewrite = array(
        'slug'                => 'post_type',
        'with_front'          => true,
        'pages'               => true,
        'feeds'               => true,
    );
    $capabilities = array(
        'edit_post'           => 'edit_post',
        'read_post'           => 'read_post',
        'delete_post'         => 'delete_post',
        'edit_posts'          => 'edit_posts',
        'edit_others_posts'   => 'edit_others_posts',
        'publish_posts'       => 'publish_posts',
        'read_private_posts'  => 'read_private_posts',
    );
    $args = array(
        'label'               => __( 'post_type', 'text_domain' ),
        'description'         => __( 'Post Type Description', 'text_domain' ),
        'labels'              => $labels,
        'supports'            => array( 'title', 'editor', 'excerpt', 'author', 'thumbnail', 'comments', 'trackbacks', 'revisions', 'custom-fields', 'page-attributes', 'post-formats', ),
        'taxonomies'          => array( 'category', 'post_tag' ),
        'hierarchical'        => false,
        'public'              => true,
        'show_ui'             => true,
        'show_in_menu'        => true,
        'show_in_nav_menus'   => true,
        'show_in_admin_bar'   => true,
        'menu_position'       => 5,
        'menu_icon'           => 'dashicons-welcome-learn-more',
        'can_export'          => true,
        'has_archive'         => true,
        'exclude_from_search' => false,
        'publicly_queryable'  => true,
        'query_var'           => 'post_type',
        'rewrite'             => $rewrite,
        'capabilities'        => $capabilities,
    );
    register_post_type( 'post_type', $args );

}

add_action( 'init', 'wpp_custom_post_type', 0 );
//------------

ولی نمیتونه پست ها را نمایش بده .

مشکل دومش اینکه حتی تو لیست خودش توی پیشخوان هم نمیتونه نمایش بده .


مشکل کجاست  ؟؟

ویرایش شده در توسط runy
0

به اشتراک گذاری این پست


لینک به پست

این رو تست کنید:

function register_simple_post_type() {
    $args = array(
      'public'   => true,
      'label'    => 'پست تایپ من',
      'supports' => array( 'title', 'custom-fields' )
    );
    register_post_type( 'simpletype', $args );
}
add_action( 'init', 'register_simple_post_type' );

 

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط justeducation
      درود
      مشکلي در ارتباط با افزونه يوزر پرو به هنگام ثبت نام در سايت دارم. وقتي تمامي فيلدها رو کامل ميکنم و دکمه ثبت رو ميزنم بعد از چند ثانيه خطاي زير رو نمايش ميده:
      Error in jQuery.ajax while submitting a form: Internal Server Error ورژن افزونه 4.9.26 و نسخه اصلي هست.
      تمامي افزونه ها رو غيرفعال کردم و با پوسته twentyseventeen وردپرس بررسي کردم اما بازم تفاوتي نداره.
      ممنونم
    • توسط unid_user
      درود
      دوستان گرامی، من میخوام که آخرین مطلب از یک پست تایپ خاص رو در بخشی از قالب سایتم نمایش بدم. کسی میتونه کمک کنه؟
      من از کد زیر استفاده میکنم اما این کد تمام پست ها رو نشون میده من فقط می خوام آخرین رو نشون بده.
      <section class="info"> <?php $package = new wp_Query(array( 'post_type' => 'packages', )); while($package->have_posts()): $package->the_post(); ?> <?php the_post_thumbnail(); ?> <div> <h2><?php the_title(); ?></h2> <p> <?php the_excerpt(); ?> </p> <a href="<?php the_permalink(); ?>" class="btn">مطالعه بیشتر</a> </div> <?php endwhile; ?> </section> ممنون و سپاسگذار.
    • توسط kamran.azarniya@yahoo.com
      سلام و درود
      بنده در این سایتم کمی مشکل منو داشتم نمیدونم چه تنظیماتی کردم که منو از جایگاه اصلی خودش اومده پایینتر ، حالا به نظرتون باید چیکار کنم یا چه کدیو اصلاح کنم
      تشکر
      avahesab.ir
    • توسط vazizi69@yahoo.com
      سلام 
      چطور میتونم برای صفحه اصلی سایت و صفحه فروشگاه و یا برگه های دیگه برای هر کدوم  فهرست منو ( منوی اصلی افقی بالای صفحه ) متفات داشته باشم 
      مثلا منوی افقی بالای صفحه مخصوص محصولات رو فقط تو صفحه فروشگاه دیده بشه و در صفحه دیگه ای از سایت منوی دیگه ای رو تنظیم کنم که نشون داده بشه
    • توسط aref74
      با سلام خدمت عزیزان..بنده تازه با ووکامرس آشنا شدم ... چرا وقتی محصولی را ایجاد میکنم و انتشار میدهم در صفحه فروشگاه فقط محصول به تنهایی نشان داده میشود و هیچ گزینه ای برای قیمت و افزودن به سبد خرید نداره.

      سوال دیگرم این بود که برای ساختن اون لینک اختصاصی محصول بهترین روش چیه؟عدد بذاریم یا همون اسم محصول؟چون با اسم محصول ارور میده گویا باید صفحه اختصاصی بسازیم..

      با تشکر