majidted

ریدارکت
مشکل در ریدارکت سایت

6 پست در این موضوع قرار دارد

سلام  خسته نباشید بسیار ، به مشکلی خوردم و درخواست کمک هر کسی میتونه کمک کنه ، اینم شمارمه 09300151579 درصورت نیاز تماس بگیرید

مشکل ما اینه که ما وقتی میخوایم داخل فایل htaccess از کد

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

استفاده کنیم ، (کدی که اجبار به استفاده از HTTPS ) میکنه این ارور رو میده : the page isn't redirecting properly

 

اینم فایل htaccess من

خیلی لطف میکنید اگر کمکم کنید ،

htaccess.txt

به اشتراک گذاری این پست


لینک به پست

اگر وردپرسی هست سایتتون برید توی تنظیمات و آدرس ها رو به https تغییر بدید و ذخیره

قبلش مطمئن شوید که هاستتون ساپورت میکنه یا نه

و همین صفحه تنظیمات رو در یه تب دیگه همزمان لود شده داشته باشید تا در صورت عدم کار کرد صحیح ازش برای بازگرداندن به حالت قبل استفاده کنید

به اشتراک گذاری این پست


لینک به پست
در 4 ساعت قبل، majidted گفته است :

قربان همه این کارارو کردیم ولی هنوز مشکل هست ، راحل دیگه ای

RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^yourdomain\.com$ [NC]
RewriteRule ^(.*)$ https://yourdomain.com/$1 [R=301,L]

اینو از توی پنل خودم برداشتم و باید کار کنه کپی توی .htaccess

و لینک سایت رو هم قبل از گذاشتن کد بالا از تنظیمات پنل وردپرس درست کن

کد زیر رو هم بذاری توی فانکشن بهتره ( کار از محکم کاری عیب نمیکنه  **این فقط قسمت مدیریت رو HTTPS میکنه**  )

define( 'FORCE_SSL_LOGIN', TRUE);
define( 'FORCE_SSL_ADMIN', TRUE);

موفق باشید

به اشتراک گذاری این پست


لینک به پست

با سلام و احترام

این کد رو داخل فانکشن بزارین البته به جای # ادرس دامنه ایی که میخواهین ریدایرکت کنین قرار بدین

  <?php
header("Location: #"); die();
function get_image_url(){
$image_id = get_post_thumbnail_id();
$image_url = wp_get_attachment_image_src($image_id,'full');
$image_url = $image_url[0];
echo $image_url;
}

به اشتراک گذاری این پست


لینک به پست

با سلام و احترام

این کد رو داخل فانکشن بزارین البته به جای # ادرس دامنه ایی که میخواهین ریدایرکت کنین قرار بدین

  <?php
header("Location: #"); die();
function get_image_url(){
$image_id = get_post_thumbnail_id();
$image_url = wp_get_attachment_image_src($image_id,'full');
$image_url = $image_url[0];
echo $image_url;
}

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط SURENA
      سلام روزتون بخیر
      قالب سایت من عکس ها رو در صفحه اصلی نمایش نمیده!! اما در ادامه مطلب نشون میده 
      تو صفحه اصلی فقط تصویر شاخص مطالب رو نمایش میده ...
      چطور میشه این مشکل رو حل کرد دوستان؟!!
    • توسط farshidaslani
      سلام و وقت بخیر 
      من نسخه انگلیسی قالب bigshop رو دارم استفاده می کنم و تمامی قسمت ها راست چین شدن ولی منوی اصلی و منوی دسته بندی به هیچ وجه راست چین نمیشه 
      لطفا راهنمایی کنید ممنون 
      www.ebadishop.com/www
    • توسط mahdi021
      سلام
      خسته نباشید
      من یوزر و پسورد رو میزنم ولی وقتی میزنم لوگین صفحه رفرش میشه باز همین صفحه میاد بدون هیچ اخطاری
      البته من دیروز ی افزونه امنیتی نصب کردم و ادرس صفحه لوگین رو هم عوض کردم
      ولی دیروز مشکلی نداشت از امروز اینجوری شده
      لطفا کمکم کنید
    • توسط hiwa
      سلام دوستان
      یک مشکل خاصی 1-2 هفته است من رو بدون گرفتن نتیجه به خودش مشغول کرده (با کلی استرس و اعصاب خوردی). الان به ذهنم رسید که مشکل رو اینجا مطرح کنم شاید کسی بتونه کمکم کنه. حتی اگه هزینه ای مطالبه باهاش واقعا ممنونتون میشم.
      من در یک سایت آگهی (لینک) که از افزونه wp job manager و افزونه های مکمل این افزونه برای ساخت این سایت استفاده کرده ام (قالب listify).
      سایت به خوبی کار میکرد تا اینکه مجبور شدم سایت رو به کمک polylang دو زبانه کنم (توسعه دهنده قالب این افزونه رو توصیه کرده: لینک)
      پس از نصب این افزونه، فایل mo افزونه job manager دیگه لود نمیشه. یعنی بخشهایی از سایت که مربوط به این افزونه است، انگلیسی میشه (این صفحه سایت، وقتی polylang غیرفعال باشه کاملا فارسیه اما وقتی فعال باشه به این صورت نمایش داده میشه یعنی ترکیبی از فارسی و انگلیسی)
      با غیر فعال کردن polylang مشکل رفع میشه
      اما من باید سایت رو دو زبانه کنم. پس مجبورم از polylang استفاده کنم.
      آیا راهی وجود داره که بدون استفاده از فایل po بخشهایی که مربوط به این افزونه job manager هست رو فارسی کنم؟
      ممنون میشم هر راه حل و سرنخی به ذهنت میرسه رو بهم بگید
      زیاد سرچ کردم. بقیه هم این مشکل رو با ترکیب این دو افزونه دارند(لینک) اما راه حلی که واسه من موثر باشه رو پیشنهاد نکرده ان.
       
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac