مهندس فا

نیاز وردپرس به مشخصات ftp و کار نکردن زمینه های دلخواه

16 پست در این موضوع قرار دارد

دوستان بعد از انتقال به سرور جدید حالا که میخوام باهاش کار کنم میبینم پست که میزنم زمینه های دلخواه جدیدم لود نمیشه .

پست های قبلی زمینه های دلخواه سر جاشه ولی پست های جدید زمینه های دلخواه رو نشون نمیدن .

همچنین وقتی میخوام افزونه ها رو نصب کنم یا اینکه آپدیت کنم درخواست اطلاعات اف تی پی میکنه

همچنین وقتی میخوام تصویر شاخص آپلود کنم خطا میده میده قابل نوشتن نیست .

واسه هر کاری میگه باید دسترسی wp-content رو برابر 777 کنید . در صورتی که قبلاً اینطوری نبود . خیلی گیر شده سرورم . .

مشکل از کجاسیت ؟

0

به اشتراک گذاری این پست


لینک به پست

از چه نسخه ای از وردپرس استفاده میکنید ؟ یادمه یکی از نسخه ها (3.4 یا 3.4.1) با زمینه دلخواه مشکل داشت.

پلاگین hotfix رو نصب کنید ببینید مشکلتون حل میشه یا نه

4

به اشتراک گذاری این پست


لینک به پست

من از 3.5 استفاده میکنم . اره اون مربوط به یک قسمت دیگه بود .

توی همین انجمن یکی از بچه ها گفت cgi فعال نیست . حالا چطوری باید فعالش کنم ؟

این سرور اختصاصی ادم و دیوانه میکنه . . چه غلطی کردم . . حالا مثل بــــــــــــــــــــــــوق !! موندم توش

1

به اشتراک گذاری این پست


لینک به پست

برای نصب که مشخصات میخواد از تنظیمات سرور هست. یکبار وارد کنید دیگه ذخیره کنید. مشکلی نیست

5

به اشتراک گذاری این پست


لینک به پست

آخه مشکل نصب افزونه نیست .

زمینه های دلخواهم توی صفحه اصلی لود نمیشه . تصویر شاخص آپلود نمیشه . . .

اعصابم به هم ریخته . هر باز یک مشکلی داره .

0

به اشتراک گذاری این پست


لینک به پست

شهاب جان در كانفيگ قرار بديد و ذخيره كنيد و تست كنيد :


if(is_admin()) {
add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
define( 'FS_CHMOD_DIR', 0751 );
}

5

به اشتراک گذاری این پست


لینک به پست

مشکل حل نشد .


پرونده فرستاده شده نمی‌تواند به /home/mohandes/domains/mohandesyar.com/public_html/wp-content/uploads/2012/12 برود.

0

به اشتراک گذاری این پست


لینک به پست

این مشکل سطح دسترسی هست.

روی 777-775-755 تست بگیرید. هم پوشه wp-content و هم uploads

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

سلام ،

معمولا شرکت‌هایی که سایت‌های وردپرسی رو میزبانی می‌کنند suPHP رو فعال می‌کنند تا کاربران اینچنین مشکلاتی نداشته باشند.

پ.ن : احتمالا روی سرور قبلی suphp فعال بوده ولی روی سرور جدید فعال نشده !

به مدیر سرور اطلاع بدید تا در صورت امکان suPHP رو فعال کنند تا مشکل‌تون برطرف بشه و دیگه احتیاجی به وارد کردن اطلاعات اف تی پی یا تغییر سطح دسترسی‌ها نداشته باشید .

ویرایش شده در توسط Masoud
3

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

این مشکل سطح دسترسی هست.

روی 777-775-755 تست بگیرید. هم پوشه wp-content و هم uploads

اره درسته اما اینکه همه رو 777 کنم (که جواب میده) از لحاظ امنیتی مشکل داره . من نباید همه رو 777 کنم . باید 755 باشه و در عین حال بتونم افزونه نصب کنم و . . .

حالا اینا به کنار چرا زمینه های دلخواه لود نمیشه ؟

الان سرور ما اختصاصیه . . . من چطور میتونم اینا رو نصب کنم ؟ به هیچ چیز خاصی دسترسی ندارم .

فقط دسترسی ادمین به دایرکت ادمین دارم و دسترسی روت به ssh

این فایل های php.ini و . . رو هم نمیدونم از کجا پیدا کنم و تغییرات بدم .

ویرایش شده در توسط shahab2005
0

به اشتراک گذاری این پست


لینک به پست

دایرکت ادمین رو بر اساس customapache نصب کردید یا custombuild ؟

اگر از custombuild استفاده می‌کنید ، دستورات زیر رو در ssh به ترتیب وارد کنید تا suphp نصب و فعال بشه :


cd /usr/local/directadmin/custombuild/
./build clean
./build update
./build set php5_cgi yes
./build set php5_cli no
./build all d
./build rewrite_confs

بعد از وارد کردن دستورات بالا ، دستورات زیر رو هم در محیط ssh وارد کنید :


./build roundcube
./build squirrelmail
./build phpmyadmin

تموم شد ;)

حالا آپاچی و دایرکت ادمین رو ریستارت کنید.

پ.ن مهم : قبل از اینکه دستورات بالا رو وارد کنید ، مطمئن بشید که هیچ فایل یا فولدری دسترسی 777 نداره ! ( تمامی فولدرها باید دسترسی : 755 داشته باشند و تمامی فایل‌ها دسترسی : 644 )

حتما قبل از اینکه مواردی که در بالا گفته شده رو اجرا کنید ، از سایت‌تون بک‌آپ بگیرید.

4

به اشتراک گذاری این پست


لینک به پست

مدیر سرور اینو گفتن :

باسلام

فکر نمیکنم ربطی به cgi داشته باشه!

معمولا و بصورت پیشفرض php با cli هست.

پیشنهاد هم نمیکنم که php با cgi فعال شود.

0

به اشتراک گذاری این پست


لینک به پست

مشکل زمینه از وردپرس هست. اگر آپدیت یا ایجادنمیشن باید همون راه حل گفته شده رو اجرا کنید.

در مورد سرور هم اگر کانفیگ شده نیست حتما بدید براتون کانفیگ کنن.

4

به اشتراک گذاری این پست


لینک به پست

آقا دابل تشکر . . . مشکل پرمیشن ها حل شد . . .

0

به اشتراک گذاری این پست


لینک به پست

جالبه . بعد از نصب میزان مصرف رم به شدت افت کرده (در حد 1-2 گیگ ) و مصرف سی پی یو کمی افزایش پیدا کرده 2-5 درصد .


top - 01:46:27 up 23 min, 1 user, load average: 0.41, 0.59, 0.98
Tasks: 235 total, 2 running, 233 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.7%us, 0.2%sy, 0.0%ni, 98.0%id, 0.1%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 8174264k total, 1297456k used, 6876808k free, 92124k buffers
Swap: 16771576k total, 0k used, 16771576k free, 685976k cached

اما نمیدونم چرا سرعت لود سایت پایین اومده . . نمیدونم واقعاً اینطوری شده یا سرعت اینترنتم کنده . . .

0

به اشتراک گذاری این پست


لینک به پست

سرعت اینترنتتون رو در اینجا تست بگیرید

http://www.broadbandspeedtest.co.uk/

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری