• اطلاعیه ها

    • Saeed Fard

      برگزاری چهارمین همایش Coder Conf و کد تخفیف برای کاربران وردپرس پارسی   20/04/97

      کدرکانف هر سال در آخرین پنجشنبه مرداد با بورد‌های مختلفی برگزار می‌گردد،امسال نیز کدرکانف در همین تاریخ با حضور برنامه نویسان مطرح کشور در بورد تخصصی جاوااسکریپت برگزار خواهد شد، یک گردهمایی متفاوت با طعم Javascript. Coderconf هر سال نسبت به سال‌های گذشته با حضور برنامه‌نویسان پر رنگتر می‌شود. ما سعی کردیم هر ساله به این کنفرانس مفهوم عمیق تری ببخشیم تا از آنچه در سال‌های گذشته عرضه شده به روزتر و مفیدتر واقع شویم. امسال فرصتی خواهد بود تا با نگرشی جدید و بهبود مطالب ارائه شده، عمیقتر به این موضوع نگاه کنیم تا بجای تکرار مباحث پیشین گامی هر چند کوچک در مسیر ارتقای دانش فنی برنامه‌نویسان ایرانی برداریم. ما در Coderconf ۴ با تمرکز بر روی Javascript نیت کرده‌ایم این فرصت را در اختیار برنامه نویسان قرار دهیم تا با ظرافت و استانداردهای روز دنیا کار خود را پیش ببرند. به نظر ما امسال زمان آن فرا رسیده‌است تا این زبان را به صورت تخصصی و از ابعاد مختلف به چالش بکشیم.   دبیر علمی همایش میلاد حیدری، کدرکانف ۴ را اینگونه توصیف کرده است :اشتراک گذاری دانش بهترین راه رسیدن به جاودانگی اطلاعات است. هر ساله همایش‌های زیادی برگزار میشه که افراد شرکت‌کننده می‌توانند با افراد مجرب شبکه سازی کنند. امسال در کدرکانف سعی کردیم علاوه بر بخش شبکه سازی بین افراد بیشتر روی انتقال دانش و کیفیت ارائه ها تمرکز داشته باشیم . به قصد یک گردهمایی بلند مدت بین برنامه‌نویسان جاوااسکریپت که با هم تبادل دانش و اطلاعات کنند گردهم آییم.
      بنده به عنوان عضو کوچکی از جامعه برنامه‌نویسان جاوااسکریپت ایران امیدوارم در کدرکانف امسال علاوه بر شبکه سازی، از اطلاعاتی که دوستان در این همایش در اختیارتان قرار می‌دهند استفاده کنید. در سایت همایش میتوانید سخنرانان و موضوع پنل همایش کدرکانف رو مشاهده کنید . علاقه‌مندان به حضور در این همایش می‌توانند با کد تخفیف wpparsi اقدام به ثبت نام در این گردهمایی کنند. سایت همایش :‌http://coderconf.org
      بلیط فروشی همایش :‌https://evand.com/events/coderconf4  
Fast-Learn

مشکل با افزونه commentator

5 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

(ببخشید سوالم دوبار ارسال شده نمیدونم چرا، نمیدونمم چطوری یکیشونو حذف کنم)

سلام.

من نسخه رایگان افزونه commentator رو از یه سایت دانلود کردم، وقتی که فعالش میکنم، یدونه از اسکریپتایی که نوشتم (شایدم بیشتر) از کار میفته.

چکار کنم؟

اسکریپتی هم که از کار میفته اینه:

$(function () {
    function bottom_page(element) {
        var pix = $('body').css('height').replace('px','')  - $(element).offset().top - $(element).height();
        return pix;
    }

    var $sidebar   = $("#related-sidebar"),
        $window    = $(window),
        offset     = $sidebar.offset(),
        $post = $('article#main'),
        topPadding = 35;
    var  s = $window.scrollTop();

    $window.scroll(function() {

        if(bottom_page('#sidebar') <= bottom_page('#post-content') && s <= $window.scrollTop()){
        }
        else if ($window.scrollTop() > offset.top && $('body').css('width').replace('px','') >= 992 ) {
            $sidebar.stop().animate({
                marginTop: $window.scrollTop() - offset.top + topPadding,
            });
        } else {
            $sidebar.stop().animate({
                marginTop: 0
            });
        }
        s = $window.scrollTop();
    });

});

 

ویرایش شده در توسط Fast-Learn
0

به اشتراک گذاری این پست


لینک به پست

سلام

خب دو مورد با هم تداخل  دارن. باید خط به خط کدها رو غیرفعال کنید ببینید تداخل مربوط به کدوم قسمت هست. بعد کدنویسی اون بخش رو تغییر بدید.

1

به اشتراک گذاری این پست


لینک به پست

خط به خط کد های افزونه رو؟:blink:

اون شکلی که یه هفته باید بشینم کد تست کنم!

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

فهمیدم اشکال از کجاس

 $sidebar.stop().animate({
                marginTop: $window.scrollTop() - offset.top + topPadding,
            });

با این کد مشکل داره

و وقتی که کد زیر رو جایگزین میکنم دوباره درست کار میکنه!:

$sidebar.css('margin-top',$window.scrollTop() - offset.top + topPadding);

ولی خب نتیجش جالب نمیشه

چکار کنم همون کد اولی درست کار کنه؟

ویرایش شده در توسط Fast-Learn
0

به اشتراک گذاری این پست


لینک به پست

کلا با کد animate مشکل داره

احتمال داره که افزونه ی ورژن قدیمی از جی کوئری رو لود میکنه که توی اون این قابلیت نیست؟

اگه آره چکار کنم که جی کوئری خودمو لود کنه؟

وقتی فعالش میکنم افزونه رو این خطا رو هم میده:

افزونه هنگام فعال شدن٬ 3 نویسه از یک خروجی غیرمنتظره تولید کرد. اگر با پیغام خطای “headers already sent”٬ مشکلات مربوط به خوراک و یا مسائل دیگر مواجه شدید سعی کنید افزونه را غیرفعال یا  حذف کنید.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط kamran.azarniya@yahoo.com
      سلام و درود
      بنده در این سایتم کمی مشکل منو داشتم نمیدونم چه تنظیماتی کردم که منو از جایگاه اصلی خودش اومده پایینتر ، حالا به نظرتون باید چیکار کنم یا چه کدیو اصلاح کنم
      تشکر
      avahesab.ir
    • توسط vazizi69@yahoo.com
      سلام 
      چطور میتونم برای صفحه اصلی سایت و صفحه فروشگاه و یا برگه های دیگه برای هر کدوم  فهرست منو ( منوی اصلی افقی بالای صفحه ) متفات داشته باشم 
      مثلا منوی افقی بالای صفحه مخصوص محصولات رو فقط تو صفحه فروشگاه دیده بشه و در صفحه دیگه ای از سایت منوی دیگه ای رو تنظیم کنم که نشون داده بشه
    • توسط aref74
      با سلام خدمت عزیزان..بنده تازه با ووکامرس آشنا شدم ... چرا وقتی محصولی را ایجاد میکنم و انتشار میدهم در صفحه فروشگاه فقط محصول به تنهایی نشان داده میشود و هیچ گزینه ای برای قیمت و افزودن به سبد خرید نداره.

      سوال دیگرم این بود که برای ساختن اون لینک اختصاصی محصول بهترین روش چیه؟عدد بذاریم یا همون اسم محصول؟چون با اسم محصول ارور میده گویا باید صفحه اختصاصی بسازیم..

      با تشکر
    • توسط ahmad4u
      متاسفانه موقع استفاده از برخی افزونه های وردپرس مشکل علامت سوال (�)  در بین اعداد آن بوجود میاید
      در سایتها هم اشاره شده که مشکل بخاطر ترجمه فایل فارسی وردپرس هست و فایلی زبان فارسی که آنها در سایت قرار دادند آپلود بشه در وردپرس مشکل حل میشه
      و مشکل هم حل میشه اما یک مشکل دیگه بوجود میاد و اون اینکه چون این فایل زبان فارسی قدیمی و مربوط به نسخه های قبلی وردپرس هست بعضی جاهای سایت همچنان ترجمه نشده نمایش داده میشود
      حالا از دوستان میخواستم سوال کنم چه مشکلی در فایل ترجمه فارسی هست که خودم اونو برای نسخه های جدید وردپرس حل کنم؟؟
    • توسط ghasemihassan73
      سلام 
      دوستان افزونه NextGEN Gallery رو نصب کرده بودم
      اخیرا سایت با آپدیت وردپرس و افزونه ها با مشکل مواجه شد و مجبور شدم افزونه ها رو از سی پنلم غیرفعال کنم 
      الان که میخوام دوباره از وردپرس فعالش کنم ارور میده که : به ‌دلیل داشتن مشکلی جدی افزونه فعال نشد.
      چاره چیه ؟